By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,082 Members | 2,135 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,082 IT Pros & Developers. It's quick & easy.

VS Develper (non Admin) missing IIS MMC Management

P: n/a
Hi,

I am trying to set up VS Developer users with non-administrator rights
debug ASP (3) in VB.Net, and of course manage IIS MMC. This has
succeeeded on 3 machines, including my own - but since then it hasnt
been able to work, with seemingly exactly the same install & debug
setup. All machines are Windows 2000 with IIS 5.0.

My main 2 problems are:
1. the user cannot see the web site properties in MMC.
2. I get all of the errors from this kb article
http://support.microsoft.com/default...b;EN-US;320451
(but tried the resolution and it's not it)

I have tried re-installing IIS, VB.Net & ASP.Net 1.1 (in that order),
doing the usual permission stuff (adding the user to debugger & vs
developer group, file permissions on inetpub and temp asp.net files,
etc etc). Frontpage is installed (this shouldnt matter as it is a
local box not remote debugging). And I've tried aspnet_regiis.exe
reg'ing aspnet_isapi.dll). I've tried everything!

This is an absolute pain as we are all still developing in ASP 3 and
moving forward has taken 18 months sofar and got nowhere - any ideas
would be great!
Jul 21 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Windows 2000
Easy: Log in as admin and add their accounts to the Operators tab.

Windows XP
Create a stub to run as admin, as the operators tab is gone.

--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA

************************************************
Think Outside the Box!
************************************************
"Andrew Clancy" <us****@achren.org> wrote in message
news:dd**************************@posting.google.c om...
Hi,

I am trying to set up VS Developer users with non-administrator rights
debug ASP (3) in VB.Net, and of course manage IIS MMC. This has
succeeeded on 3 machines, including my own - but since then it hasnt
been able to work, with seemingly exactly the same install & debug
setup. All machines are Windows 2000 with IIS 5.0.

My main 2 problems are:
1. the user cannot see the web site properties in MMC.
2. I get all of the errors from this kb article
http://support.microsoft.com/default...b;EN-US;320451
(but tried the resolution and it's not it)

I have tried re-installing IIS, VB.Net & ASP.Net 1.1 (in that order),
doing the usual permission stuff (adding the user to debugger & vs
developer group, file permissions on inetpub and temp asp.net files,
etc etc). Frontpage is installed (this shouldnt matter as it is a
local box not remote debugging). And I've tried aspnet_regiis.exe
reg'ing aspnet_isapi.dll). I've tried everything!

This is an absolute pain as we are all still developing in ASP 3 and
moving forward has taken 18 months sofar and got nowhere - any ideas
would be great!

Jul 21 '05 #2

P: n/a
Thanks Greg - but I dont have the operators tab in windows 2000 pro for some
reason?
Is there a group policy I can apply that achieves the same?

Does this solve my .Net project creation problems too?

Thanks,
Andy

"Cowboy (Gregory A. Beamer) [MVP]" <No************@comcast.netNoSpamM> wrote
in message news:e0**************@tk2msftngp13.phx.gbl...
Windows 2000
Easy: Log in as admin and add their accounts to the Operators tab.

Windows XP
Create a stub to run as admin, as the operators tab is gone.

--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA

************************************************
Think Outside the Box!
************************************************
"Andrew Clancy" <us****@achren.org> wrote in message
news:dd**************************@posting.google.c om...
Hi,

I am trying to set up VS Developer users with non-administrator rights
debug ASP (3) in VB.Net, and of course manage IIS MMC. This has
succeeeded on 3 machines, including my own - but since then it hasnt
been able to work, with seemingly exactly the same install & debug
setup. All machines are Windows 2000 with IIS 5.0.

My main 2 problems are:
1. the user cannot see the web site properties in MMC.
2. I get all of the errors from this kb article
http://support.microsoft.com/default...b;EN-US;320451
(but tried the resolution and it's not it)

I have tried re-installing IIS, VB.Net & ASP.Net 1.1 (in that order),
doing the usual permission stuff (adding the user to debugger & vs
developer group, file permissions on inetpub and temp asp.net files,
etc etc). Frontpage is installed (this shouldnt matter as it is a
local box not remote debugging). And I've tried aspnet_regiis.exe
reg'ing aspnet_isapi.dll). I've tried everything!

This is an absolute pain as we are all still developing in ASP 3 and
moving forward has taken 18 months sofar and got nowhere - any ideas
would be great!


Jul 21 '05 #3

P: n/a
W2k Pro and XP Pro do not have operator tab.
this is client OSes limitation of IIS.

and operator tab has been remove from IIS 6.0 as well.

--
Regards,
Bernard Cheah
http://www.tryiis.com/
http://support.microsoft.com/
http://www.msmvps.com/bernard/

"Andrew Clancy" <contactATachrenDOTorg> wrote in message
news:#L**************@TK2MSFTNGP12.phx.gbl...
Thanks Greg - but I dont have the operators tab in windows 2000 pro for some reason?
Is there a group policy I can apply that achieves the same?

Does this solve my .Net project creation problems too?

Thanks,
Andy

"Cowboy (Gregory A. Beamer) [MVP]" <No************@comcast.netNoSpamM> wrote in message news:e0**************@tk2msftngp13.phx.gbl...
Windows 2000
Easy: Log in as admin and add their accounts to the Operators tab.

Windows XP
Create a stub to run as admin, as the operators tab is gone.

--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA

************************************************
Think Outside the Box!
************************************************
"Andrew Clancy" <us****@achren.org> wrote in message
news:dd**************************@posting.google.c om...
Hi,

I am trying to set up VS Developer users with non-administrator rights
debug ASP (3) in VB.Net, and of course manage IIS MMC. This has
succeeeded on 3 machines, including my own - but since then it hasnt
been able to work, with seemingly exactly the same install & debug
setup. All machines are Windows 2000 with IIS 5.0.

My main 2 problems are:
1. the user cannot see the web site properties in MMC.
2. I get all of the errors from this kb article
http://support.microsoft.com/default...b;EN-US;320451
(but tried the resolution and it's not it)

I have tried re-installing IIS, VB.Net & ASP.Net 1.1 (in that order),
doing the usual permission stuff (adding the user to debugger & vs
developer group, file permissions on inetpub and temp asp.net files,
etc etc). Frontpage is installed (this shouldnt matter as it is a
local box not remote debugging). And I've tried aspnet_regiis.exe
reg'ing aspnet_isapi.dll). I've tried everything!

This is an absolute pain as we are all still developing in ASP 3 and
moving forward has taken 18 months sofar and got nowhere - any ideas
would be great!



Jul 21 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.