468,771 Members | 1,589 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,771 developers. It's quick & easy.

Dotnet printing problem: the data area passed to a system call is too small

I'm having problems printing to a line printer from both Crystal Reports and
SQL Server reporting services using dotnet. When I try and print a report
from an application with Crystal I get the error message "the data area
passed to a system call is too small", and nothing else. With SSRS when I
try to print the report from the IDE I get the same error, I can load the
report up to the report server and view it with IE, then print it from there
but there are some formatting issues.

So far I've found that this appears to be an error that can be generated by
different processes, I found one that seemed to be almost exactly my
problem:
http://support.microsoft.com/default...b;en-us;822779
The common elements are dotnet printing - I'm assuming that printdocument
class is used by both Crystal and SSRS, and the plain text printer driver.

The problem is that it's the wrong operating system, my client is XP and the
print server is Windows 2003 server.

I'm using Visual Studio 2003, everything is up to date.

Has anyone seen this with XP/2003 and if so, have any tips on finding the
cause?

Thanks in advance;

David Craig.
ABC-CLIO
Jul 21 '05 #1
1 8714


"DCraig" wrote:
I'm having problems printing to a line printer from both Crystal Reports and
SQL Server reporting services using dotnet. When I try and print a report
from an application with Crystal I get the error message "the data area
passed to a system call is too small", and nothing else. With SSRS when I
try to print the report from the IDE I get the same error, I can load the
report up to the report server and view it with IE, then print it from there
but there are some formatting issues.

So far I've found that this appears to be an error that can be generated by
different processes, I found one that seemed to be almost exactly my
problem:
http://support.microsoft.com/default...b;en-us;822779
The common elements are dotnet printing - I'm assuming that printdocument
class is used by both Crystal and SSRS, and the plain text printer driver.

The problem is that it's the wrong operating system, my client is XP and the
print server is Windows 2003 server.

I'm using Visual Studio 2003, everything is up to date.

Has anyone seen this with XP/2003 and if so, have any tips on finding the
cause?

Thanks in advance;

David Craig.
ABC-CLIO


Craig,

Did you ever get an answer from MS on this? I am having a similiar problem
when printing from aDOTNET program I worte and also Crystal Reportsd. My
problem is that the report is "clipped" off. I have so far tracked it down to
the visable clipped area (the area available for printing) for the graphics
object is wrong. It is too small. Where you running the application on
Windows 2003 Server? On XP all applications work fine. I am trying to
determine if this is a Windows 2003 Server issue.

Thanks

Bob Maier
Jul 21 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Brett Mostert | last post: by
4 posts views Thread by Rob T | last post: by
7 posts views Thread by DazedAndConfused | last post: by
6 posts views Thread by Chris Dunaway | last post: by
reply views Thread by zhoujie | last post: by
1 post views Thread by Marin | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.