By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,991 Members | 1,888 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,991 IT Pros & Developers. It's quick & easy.

from .NET 1.0 to .NET 1.1

P: n/a
I need some comments/help on this.

Some months ago, all I had installed in my computer was .NEt 1.0 and the Framework 1.0 .
I developed an ASP application then, it run fine, got installed in another server, while I deleted all the programs from my computer after they were saved in Source Safe.

After this, I started a new project with handhelds, for which I had to install .NEt 2003 with the Framewrok 1.1 .
My mobile applications (windows app). runs fine, as of today.

But today I had to go back to the ASP app. to add some enhancements to the same. I downloaded the app. from source safe, made sure the virtual directory to it is still valid, and try running it (note when I open its solutions, it opens .NET 1.0). problems started here:

1. If I am in Debug mode, I get a
Error while trying to run project: Unable to start debugging on the web server. Catastrophic failure.

2. If I switch to Release mode, I keep getting hte message that a class project has to be started from either a url or another progrem. I made sure the starting point is the url, but I keep gettting this message.

3. If I run without debugging, it runs......but it uses the 1.1 Framework, this, being a 1.0 application.

I tried transforming the whole app. to 1.1, and now I keep getting the error
Error while trying to run project: Unable to start debugging on the web server. Catastrophic failure.

A search within microsoft, let me to http://support.microsoft.com/default...b;en-us;827559 .

Yes, I am running windows 2000 with SP4, but I had .NET 1.1 installed before I installed SP4 (and of course IIS was already installed)
Anyway I tried following the instructions here, but cannot find Domain Controller Security Policy .
Still the app. runs without debugging, but some of the XML/XSLT methods I used in the original app. have become obsolete now......I have tor eview the code and update parts of it.
Still I would like to run my app. with debugging capabilites, just as I used to in the past. Can anybody help on this?
Jul 21 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
You can configure the old app to use .Net 1.0 while still running 1.1
side-by-side.

There's a nice free tool to help you with this:

ASP.NET Version Switcher

"The ASP.NET Version Switcher is a little utility that can be used to
quickly switch the .NET Framework version that the ASPX pages are compiled
against. This is helpful for developers who often have to test their web
applications for compatibility with different version of the .NET Framework"

http://www.denisbauer.com/NETTools/A...nSwitcher.aspx
"rocio" <ro************@softwareservices.net> wrote in message
news:%2****************@tk2msftngp13.phx.gbl...
I need some comments/help on this.

Some months ago, all I had installed in my computer was .NEt 1.0 and the
Framework 1.0 .
I developed an ASP application then, it run fine, got installed in another
server, while I deleted all the programs from my computer after they were
saved in Source Safe.

After this, I started a new project with handhelds, for which I had to
install .NEt 2003 with the Framewrok 1.1 .
My mobile applications (windows app). runs fine, as of today.

But today I had to go back to the ASP app. to add some enhancements to the
same. I downloaded the app. from source safe, made sure the virtual
directory to it is still valid, and try running it (note when I open its
solutions, it opens .NET 1.0). problems started here:

1. If I am in Debug mode, I get a
Error while trying to run project: Unable to start debugging on the web
server. Catastrophic failure.

2. If I switch to Release mode, I keep getting hte message that a class
project has to be started from either a url or another progrem. I made sure
the starting point is the url, but I keep gettting this message.

3. If I run without debugging, it runs......but it uses the 1.1 Framework,
this, being a 1.0 application.

I tried transforming the whole app. to 1.1, and now I keep getting the error
Error while trying to run project: Unable to start debugging on the web
server. Catastrophic failure.

A search within microsoft, let me to
http://support.microsoft.com/default...b;en-us;827559 .

Yes, I am running windows 2000 with SP4, but I had .NET 1.1 installed before
I installed SP4 (and of course IIS was already installed)
Anyway I tried following the instructions here, but cannot find Domain
Controller Security Policy .
Still the app. runs without debugging, but some of the XML/XSLT methods I
used in the original app. have become obsolete now......I have tor eview the
code and update parts of it.
Still I would like to run my app. with debugging capabilites, just as I used
to in the past. Can anybody help on this?
Jul 21 '05 #2

P: n/a
if you got the project properties | Common Properties | General then select
the Supported Runtimes you can select which versions your applications
support. Enabling both 1.0 and 1.1 versions of .net.

luke
www.luke-smith.co.uk

"Ken Cox [Microsoft MVP]" <BA************@sympatico.ca> wrote in message
news:eK*************@TK2MSFTNGP11.phx.gbl...
You can configure the old app to use .Net 1.0 while still running 1.1
side-by-side.

There's a nice free tool to help you with this:

ASP.NET Version Switcher

"The ASP.NET Version Switcher is a little utility that can be used to
quickly switch the .NET Framework version that the ASPX pages are compiled
against. This is helpful for developers who often have to test their web
applications for compatibility with different version of the .NET Framework"
http://www.denisbauer.com/NETTools/A...nSwitcher.aspx
"rocio" <ro************@softwareservices.net> wrote in message
news:%2****************@tk2msftngp13.phx.gbl...
I need some comments/help on this.

Some months ago, all I had installed in my computer was .NEt 1.0 and the
Framework 1.0 .
I developed an ASP application then, it run fine, got installed in another
server, while I deleted all the programs from my computer after they were
saved in Source Safe.

After this, I started a new project with handhelds, for which I had to
install .NEt 2003 with the Framewrok 1.1 .
My mobile applications (windows app). runs fine, as of today.

But today I had to go back to the ASP app. to add some enhancements to the
same. I downloaded the app. from source safe, made sure the virtual
directory to it is still valid, and try running it (note when I open its
solutions, it opens .NET 1.0). problems started here:

1. If I am in Debug mode, I get a
Error while trying to run project: Unable to start debugging on the web server. Catastrophic failure.

2. If I switch to Release mode, I keep getting hte message that a class
project has to be started from either a url or another progrem. I made sure the starting point is the url, but I keep gettting this message.

3. If I run without debugging, it runs......but it uses the 1.1 Framework,
this, being a 1.0 application.

I tried transforming the whole app. to 1.1, and now I keep getting the error Error while trying to run project: Unable to start debugging on the web server. Catastrophic failure.

A search within microsoft, let me to
http://support.microsoft.com/default...b;en-us;827559 .

Yes, I am running windows 2000 with SP4, but I had .NET 1.1 installed before I installed SP4 (and of course IIS was already installed)
Anyway I tried following the instructions here, but cannot find Domain
Controller Security Policy .
Still the app. runs without debugging, but some of the XML/XSLT methods I
used in the original app. have become obsolete now......I have tor eview the code and update parts of it.
Still I would like to run my app. with debugging capabilites, just as I used to in the past. Can anybody help on this?

Jul 21 '05 #3

P: n/a
That works very well with WinForms, but mucks up more often than not with
ASP.NET. I assume it has something to do with the fact that IIS has to
ground to one runtime.

--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA

************************************************** ********************
Think Outside the Box!
************************************************** ********************
"Luke Smith" <lu**********@btinternet.com> wrote in message
news:uT**************@TK2MSFTNGP09.phx.gbl...
if you got the project properties | Common Properties | General then select the Supported Runtimes you can select which versions your applications
support. Enabling both 1.0 and 1.1 versions of .net.

luke
www.luke-smith.co.uk

"Ken Cox [Microsoft MVP]" <BA************@sympatico.ca> wrote in message
news:eK*************@TK2MSFTNGP11.phx.gbl...
You can configure the old app to use .Net 1.0 while still running 1.1
side-by-side.

There's a nice free tool to help you with this:

ASP.NET Version Switcher

"The ASP.NET Version Switcher is a little utility that can be used to
quickly switch the .NET Framework version that the ASPX pages are compiled against. This is helpful for developers who often have to test their web
applications for compatibility with different version of the .NET

Framework"

http://www.denisbauer.com/NETTools/A...nSwitcher.aspx
"rocio" <ro************@softwareservices.net> wrote in message
news:%2****************@tk2msftngp13.phx.gbl...
I need some comments/help on this.

Some months ago, all I had installed in my computer was .NEt 1.0 and the
Framework 1.0 .
I developed an ASP application then, it run fine, got installed in another server, while I deleted all the programs from my computer after they were saved in Source Safe.

After this, I started a new project with handhelds, for which I had to
install .NEt 2003 with the Framewrok 1.1 .
My mobile applications (windows app). runs fine, as of today.

But today I had to go back to the ASP app. to add some enhancements to the same. I downloaded the app. from source safe, made sure the virtual
directory to it is still valid, and try running it (note when I open its
solutions, it opens .NET 1.0). problems started here:

1. If I am in Debug mode, I get a
Error while trying to run project: Unable to start debugging on the

web
server. Catastrophic failure.

2. If I switch to Release mode, I keep getting hte message that a class
project has to be started from either a url or another progrem. I made

sure
the starting point is the url, but I keep gettting this message.

3. If I run without debugging, it runs......but it uses the 1.1 Framework, this, being a 1.0 application.

I tried transforming the whole app. to 1.1, and now I keep getting the

error
Error while trying to run project: Unable to start debugging on the

web
server. Catastrophic failure.

A search within microsoft, let me to
http://support.microsoft.com/default...b;en-us;827559 .

Yes, I am running windows 2000 with SP4, but I had .NET 1.1 installed

before
I installed SP4 (and of course IIS was already installed)
Anyway I tried following the instructions here, but cannot find Domain
Controller Security Policy .
Still the app. runs without debugging, but some of the XML/XSLT methods I used in the original app. have become obsolete now......I have tor eview

the
code and update parts of it.
Still I would like to run my app. with debugging capabilites, just as I

used
to in the past. Can anybody help on this?


Jul 21 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.