By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,515 Members | 1,363 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,515 IT Pros & Developers. It's quick & easy.

Any ideas? Authentication problem with .NET application

P: n/a
How do I get a remote XP Pro computer user on one domain to access and run a
..NET application on a different domain?

Scenario: I was given a .NET application on domain (B) that I need to allow
a remote XP PRO computer user to run from the other domain (A). The only way
I have been able to get the application to run remotely is by having the XP
PRO computer belong to domain (B) where the application resides, and using
"RUN AS" under an authorized user of domain (B) credentials. I was not able
to get the application to run if the XP PRO PC was made part of a Workgroup,
although I did have access to the network. Is there a way of running an
application on the remote domain (B) using, "RUN AS", with the authorized
user's credentials (B), but not having the XP PRO computer a member of the
domain (B)?

The following is how the .NET application
authentication progressed before it failed:

Name: domain(A)\ username
Is Authenticated: True
Authentication Type: NTLM
Is In domain(B)\ Net Application Users*: False

*( W2000 AD Global Security Group authorized to use the .Net Application)
Also was not able to run the application using "Run As" a known authorized
username@domain(B).

When the XP Pro PC is then made a member of domain (B), here is the .NET
application authentication progress and it run successfully:

Name: domain(BE)\ username
Is Authenticated: True
Authentication Type: NTLM
Is In domain(B)\ Net Application Users*: True

Also am able to "Run As" with any other authorized username@domain(B)

Appreciate any and all suggestions,
robert
Jul 21 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.