By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,136 Members | 1,205 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,136 IT Pros & Developers. It's quick & easy.

Why doesn't my user control gets added to My User Control Tab

P: n/a
I added a project to my solution that contains a user control. Now I 'd like
to add the user control from that project to a form in my solution. The
problem is that the control doesn't gets added to the My User Control tab.

Any ideas?

Thanks in advance, Henke!
Jul 21 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Just drag and drop the DLL from your user control project into the toolbox.
By doing so the user controls in the DLL will show up in the toolbox.

--
Greetz

Jan Tielens
________________________________
Read my weblog: http://weblogs.asp.net/jan
"Henke" <he********@hotmail.com> wrote in message
news:#6*************@tk2msftngp13.phx.gbl...
I added a project to my solution that contains a user control. Now I 'd like to add the user control from that project to a form in my solution. The
problem is that the control doesn't gets added to the My User Control tab.

Any ideas?

Thanks in advance, Henke!

Jul 21 '05 #2

P: n/a
Hi, and thanks for your answer. That could work but if I do like that I only
add the dll from that specific directory. It doesn't get update when I
change from Debug to Release and so on. All my other User Controls are
displayed in the Tab, with a nice lite User Control Icon. When you drag the
dll-file to the tab an other icon is displayed.

/Henke

"Jan Tielens" <ja*@no.spam.please.leadit.be> skrev i meddelandet
news:ev**************@TK2MSFTNGP09.phx.gbl...
Just drag and drop the DLL from your user control project into the toolbox. By doing so the user controls in the DLL will show up in the toolbox.

--
Greetz

Jan Tielens
________________________________
Read my weblog: http://weblogs.asp.net/jan
"Henke" <he********@hotmail.com> wrote in message
news:#6*************@tk2msftngp13.phx.gbl...
I added a project to my solution that contains a user control. Now I 'd

like
to add the user control from that project to a form in my solution. The
problem is that the control doesn't gets added to the My User Control tab.
Any ideas?

Thanks in advance, Henke!


Jul 21 '05 #3

P: n/a
Agreed... I had your problem some time ago too. My quick work-around was to
drop the dll on the toolbox... I hope somebody else has a solution.

--
Greetz

Jan Tielens
________________________________
Read my weblog: http://weblogs.asp.net/jan
"Henke" <he********@hotmail.com> wrote in message
news:ui**************@TK2MSFTNGP11.phx.gbl...
Hi, and thanks for your answer. That could work but if I do like that I only add the dll from that specific directory. It doesn't get update when I
change from Debug to Release and so on. All my other User Controls are
displayed in the Tab, with a nice lite User Control Icon. When you drag the dll-file to the tab an other icon is displayed.

/Henke

"Jan Tielens" <ja*@no.spam.please.leadit.be> skrev i meddelandet
news:ev**************@TK2MSFTNGP09.phx.gbl...
Just drag and drop the DLL from your user control project into the

toolbox.
By doing so the user controls in the DLL will show up in the toolbox.

--
Greetz

Jan Tielens
________________________________
Read my weblog: http://weblogs.asp.net/jan
"Henke" <he********@hotmail.com> wrote in message
news:#6*************@tk2msftngp13.phx.gbl...
I added a project to my solution that contains a user control. Now I 'd
like
to add the user control from that project to a form in my solution.
The problem is that the control doesn't gets added to the My User Control

tab.
Any ideas?

Thanks in advance, Henke!



Jul 21 '05 #4

P: n/a
I've noticed this happening sometimes if I have a usercontrol project in the
solution with my main windows forms project. Sometimes the usercontrol's
just disappear from the "My User Controls" tab.

One solution that I've seen in the past (which works most of the time, but
not all the time) is to:

1) Close all designer windows
2) Build your solution
3) Open the designer for the usercontrol
4) Change something, then change it back (so it prompts you to save the
file)
5) Save and close the designer.
6) Open up one of the forms in your other project.
7) Cross your fingers and hope the control appears in the "My User Controls"
tab ;)

Hope this helps,

Trev.

"Jan Tielens" <ja*@no.spam.please.leadit.be> wrote in message
news:%2****************@TK2MSFTNGP12.phx.gbl...
Agreed... I had your problem some time ago too. My quick work-around was to drop the dll on the toolbox... I hope somebody else has a solution.

--
Greetz

Jan Tielens
________________________________
Read my weblog: http://weblogs.asp.net/jan
"Henke" <he********@hotmail.com> wrote in message
news:ui**************@TK2MSFTNGP11.phx.gbl...
Hi, and thanks for your answer. That could work but if I do like that I

only
add the dll from that specific directory. It doesn't get update when I
change from Debug to Release and so on. All my other User Controls are
displayed in the Tab, with a nice lite User Control Icon. When you drag

the
dll-file to the tab an other icon is displayed.

/Henke

"Jan Tielens" <ja*@no.spam.please.leadit.be> skrev i meddelandet
news:ev**************@TK2MSFTNGP09.phx.gbl...
Just drag and drop the DLL from your user control project into the

toolbox.
By doing so the user controls in the DLL will show up in the toolbox.

--
Greetz

Jan Tielens
________________________________
Read my weblog: http://weblogs.asp.net/jan
"Henke" <he********@hotmail.com> wrote in message
news:#6*************@tk2msftngp13.phx.gbl...
> I added a project to my solution that contains a user control. Now I 'd like
> to add the user control from that project to a form in my solution. The > problem is that the control doesn't gets added to the My User
Control tab.
>
> Any ideas?
>
> Thanks in advance, Henke!
>
>



Jul 21 '05 #5

P: n/a
Thanks Trev, it worked this time anyway...
/Henke

"Codemonkey" <hu*********@hotmail.com> skrev i meddelandet
news:eX**************@tk2msftngp13.phx.gbl...
I've noticed this happening sometimes if I have a usercontrol project in the solution with my main windows forms project. Sometimes the usercontrol's
just disappear from the "My User Controls" tab.

One solution that I've seen in the past (which works most of the time, but
not all the time) is to:

1) Close all designer windows
2) Build your solution
3) Open the designer for the usercontrol
4) Change something, then change it back (so it prompts you to save the
file)
5) Save and close the designer.
6) Open up one of the forms in your other project.
7) Cross your fingers and hope the control appears in the "My User Controls" tab ;)

Hope this helps,

Trev.

"Jan Tielens" <ja*@no.spam.please.leadit.be> wrote in message
news:%2****************@TK2MSFTNGP12.phx.gbl...
Agreed... I had your problem some time ago too. My quick work-around was

to
drop the dll on the toolbox... I hope somebody else has a solution.

--
Greetz

Jan Tielens
________________________________
Read my weblog: http://weblogs.asp.net/jan
"Henke" <he********@hotmail.com> wrote in message
news:ui**************@TK2MSFTNGP11.phx.gbl...
Hi, and thanks for your answer. That could work but if I do like that I
only
add the dll from that specific directory. It doesn't get update when I
change from Debug to Release and so on. All my other User Controls are
displayed in the Tab, with a nice lite User Control Icon. When you
drag
the
dll-file to the tab an other icon is displayed.

/Henke

"Jan Tielens" <ja*@no.spam.please.leadit.be> skrev i meddelandet
news:ev**************@TK2MSFTNGP09.phx.gbl...
> Just drag and drop the DLL from your user control project into the
toolbox.
> By doing so the user controls in the DLL will show up in the
toolbox. >
> --
> Greetz
>
> Jan Tielens
> ________________________________
> Read my weblog: http://weblogs.asp.net/jan
>
>
> "Henke" <he********@hotmail.com> wrote in message
> news:#6*************@tk2msftngp13.phx.gbl...
> > I added a project to my solution that contains a user control. Now

I 'd
> like
> > to add the user control from that project to a form in my
solution. The
> > problem is that the control doesn't gets added to the My User

Control tab.
> >
> > Any ideas?
> >
> > Thanks in advance, Henke!
> >
> >
>
>



Jul 21 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.