468,301 Members | 1,402 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,301 developers. It's quick & easy.

VSA Scripting problem with the set Moniker

I'm having a problem with the moniker. If I destroy my
object that implements the IVsaEngine interface, (VB:
engine = nothing) it does not release the moniker for use
by another engine. I have to physically close the running
program and have it reopen for that moniker to be
available again. How can I fix this? Thanks!
Jul 21 '05 #1
1 940
-----Original Message-----
I'm having a problem with the moniker. If I destroy my
object that implements the IVsaEngine interface, (VB:
engine = nothing) it does not release the moniker for use
by another engine. I have to physically close the runningprogram and have it reopen for that moniker to be
available again. How can I fix this? Thanks!
.


ALSO! This is new from the 1.1 of the framework, compiled
on the 1.0 this was not an issue. We have just put a
random number (1-10000) as a string on the end of the
moniker anytime the engine is created to assure it's
random. This is NOT a fix I would like to keep. Thanks!
Jul 21 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

4 posts views Thread by The_Incubator | last post: by
9 posts views Thread by What-a-Tool | last post: by
8 posts views Thread by rmacias | last post: by
6 posts views Thread by Wolfgang Keller | last post: by
2 posts views Thread by infidel | last post: by
1 post views Thread by andrewcw | last post: by
reply views Thread by Teichintx | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.