By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,391 Members | 1,387 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,391 IT Pros & Developers. It's quick & easy.

MTS transactions problems against Oracle 9iR2 with vb.Net

P: n/a
I'm having problems with EnterpriseServices transactions running
against Oracle 9iR2.

I am inconsistently getting Oracle ORA-24761: Transaction Rolled Back
results mid-transaction. If I start the transaction and run it against
an object it might fail. If I rerun the same transaction again it
might work. But on trying again it might fail.

If I disable transactions <Transaction(TransactionOption.Disabled)>
the app runs and all the data is processed correctly. I have confirmed
that the basic selects, inserts and updates all run successfully
without transactions.

I have a small test app I used to confirm that all the components are
setup to run transactions; I can test failure and commit on success
and that works. But when running the full application I am developing
it is just plain inconsistent.

Environment:

WinXPPro
VS.Net 2003
Oracle 9iR2 patched to 9.2.0.4 plus OraMTS configured.
Oracle version of the DAAB patched to fix output parameter problems
Questions:

1. Is anyone else out there running this configuration successfully?
2. Is anyone else running a configuration near to this?
3. Any suggestions on where to look within the oracle world to
determine the root cause of the transaction rollback that Oracle is
issuing?
4. Anyone experiencing problems running transactions in Debug mode vs
Release?

Thanks for the help
Rick
Jul 21 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
On 29 Oct 2003 11:35:14 -0800, rk*******@earthlink.net (Rick) wrote:

I'm having problems with EnterpriseServices transactions running
against Oracle 9iR2.

I am inconsistently getting Oracle ORA-24761: Transaction Rolled Back
results mid-transaction. If I start the transaction and run it against
an object it might fail. If I rerun the same transaction again it
might work. But on trying again it might fail.

If I disable transactions <Transaction(TransactionOption.Disabled)>
the app runs and all the data is processed correctly. I have confirmed
that the basic selects, inserts and updates all run successfully
without transactions.

I have a small test app I used to confirm that all the components are
setup to run transactions; I can test failure and commit on success
and that works. But when running the full application I am developing
it is just plain inconsistent.

Environment:

WinXPPro
VS.Net 2003
Oracle 9iR2 patched to 9.2.0.4 plus OraMTS configured.
Oracle version of the DAAB patched to fix output parameter problems


Questions:

1. Is anyone else out there running this configuration successfully?
2. Is anyone else running a configuration near to this?
3. Any suggestions on where to look within the oracle world to
determine the root cause of the transaction rollback that Oracle is
issuing?
4. Anyone experiencing problems running transactions in Debug mode vs
Release?

You might want to check the Oracle MetaLink site (you will probably need to create an account). I
found a couple of articles that refer to the error you are getting but don't know whether they
apply. I assume you are using Oracle's .NET provider since you are using their middleware.

http://metalink.oracle.com/metalink/...l2_gui.startup
Paul ~~~ pc******@ameritech.net
Microsoft MVP (Visual Basic)
Jul 21 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.