By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
432,002 Members | 2,137 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 432,002 IT Pros & Developers. It's quick & easy.

Add/Remove Programs Icon

P: n/a
When I create an install package, all I see is a folder Icon in the
Add/Remove programs. I have set the AddRemoveProgramsIcon property in
my install package, but that doesn't do anything. I have created
packages before that worked correctly, but not anymore. I have even
tried installing this to different machines, but there was no change.

Is there a different property that has to be set for this icon to be
displayed?

Thanks in advance.

Kalvin
Jul 21 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Hi Kalvin,

A dumb safety question - have you checked the icon conforms the requirements
imposed by the Add/Remove Programs applet (if any exist)?

--
Dmitriy Lapshin [C# / .NET MVP]
X-Unity Test Studio
http://x-unity.miik.com.ua/teststudio.aspx
Bring the power of unit testing to VS .NET IDE

"Kalvin" <kt***@streck.com> wrote in message
news:87**************************@posting.google.c om...
When I create an install package, all I see is a folder Icon in the
Add/Remove programs. I have set the AddRemoveProgramsIcon property in
my install package, but that doesn't do anything. I have created
packages before that worked correctly, but not anymore. I have even
tried installing this to different machines, but there was no change.

Is there a different property that has to be set for this icon to be
displayed?

Thanks in advance.

Kalvin


Jul 21 '05 #2

P: n/a
I had a similar problem - there are several places in the Visual Studio
installer project that has an icon property that needs to be configured to
point at your icon; make sure you find them all (it's easy to miss one) and
that they point to valid files. You can check the icons actually in the
install package if you open up the msi file with ORCA and look at the
tables.

"Kalvin" <kt***@streck.com> wrote in message
news:87**************************@posting.google.c om...
When I create an install package, all I see is a folder Icon in the
Add/Remove programs. I have set the AddRemoveProgramsIcon property in
my install package, but that doesn't do anything. I have created
packages before that worked correctly, but not anymore. I have even
tried installing this to different machines, but there was no change.

Is there a different property that has to be set for this icon to be
displayed?

Thanks in advance.

Kalvin

Jul 21 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.