469,275 Members | 1,528 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,275 developers. It's quick & easy.

IDE not breaking at breakpoint

When I run (F5) my web app and put a breakpoint on page load it won't
stop at the breakpoint! The code that's in the routine executes, but
..NET won't stop at the breakpoint!

It's driving me nuts. any help would be greatly appreciated. I am sure
it's an option/setting but I can't figure it out.
Jul 21 '05 #1
3 2221
Are you sure that you are in "debug mode" (as opposed to "release mode")?

Go to the "Build -> Configuration Manager" option in the menus. Make sure
the "Active Solution Configuration" is set to "Debug"

Debug Mode generates extra code that allows the IDE to debug your programs
easier. Release Mode removes this extra debugging code to make the program
more efficient when producing the final product.

There are a few other things that could cause this, so let me know if this
solves your problem.

Hope this helps,

Trev.

"Kevin" <kt******@yahoo.com> wrote in message
news:2d*************************@posting.google.co m...
When I run (F5) my web app and put a breakpoint on page load it won't
stop at the breakpoint! The code that's in the routine executes, but
.NET won't stop at the breakpoint!

It's driving me nuts. any help would be greatly appreciated. I am sure
it's an option/setting but I can't figure it out.

Jul 21 '05 #2
Yes, I have been in debug mode (in the configuration manager). I also
have not been running "start w/o debugging" (ctl+F5).

You said you might have more options? Please help. This is indeed
frustrating.

Thanks Trev,
Kevin

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Jul 21 '05 #3
What kind of web app are you debugging? Asp.net, web services or a .net dll
that is used by the web app?

If you are debugging Asp.net, make sure you have the web server set up for
debugging:

1) Go to Control Panel>Administrative Tools>Computer Management>Services And
Applications>Internet Information Services

2) Right click web application and go to Properties

3) On the Directory Tab, click Configuration and go to the debugging tab.
Make sure Client side and server side debugging is on.

4) Go to the Directory security tab and edit the Anonymous Access and
Authentication control. Try disabling Anonymous access.

I've had problems with this in the past and it's been kinda hit and miss to
try and find out what's causing it.

If all else fails, try searching on http://groups.google.com for things like
"debug asp.net application" etc.

Sorry I can't be of more help.

Trev.

"Kevin Bach" <kt******@yahoo.com> wrote in message
news:uo**************@TK2MSFTNGP10.phx.gbl...
Yes, I have been in debug mode (in the configuration manager). I also
have not been running "start w/o debugging" (ctl+F5).

You said you might have more options? Please help. This is indeed
frustrating.

Thanks Trev,
Kevin

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!


Jul 21 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

4 posts views Thread by Wal Turner | last post: by
5 posts views Thread by lawrencelee | last post: by
5 posts views Thread by One Handed Man [ OHM# ] | last post: by
3 posts views Thread by Kevin | last post: by
1 post views Thread by RLN | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
reply views Thread by suresh191 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.