473,883 Members | 1,440 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

Re: Having trouble successfully deploying WCF service to public website

can you show me in more detail? I have same problem where on the page
it's https://service.premilance.com/Company.svc, but the svcutil tells
me to get it from https://pserver1/Company.svc?wsdl which is
incorrect.. I have no clue how to fix it and i'm struggling for two
days already :(
On Mar 13, 3:09 pm, "Tiago Halm" <th...@nospam.h otmail.comwrote :
If hosting in IIS, just set the hostheader of the website to the public
hostname. The generated WSDL/XSDs will contain the hostname with which it
was accessed.

Tiago Halm

<kiern...@yahoo .comwrote in message

news:c8******** *************** ***********@d21 g2000prf.google groups.com...
I'm fairly new to deploying WCF web services and am running into
problems deploying my WCF service to a public web site. I want this
web service to be accessible by clients outside my domain.
The problem I'm running into first off is that the WSDL contains the
server's name instead of the web site's name. The WSDL elements and
attributes listed below contain "http://<server_interna l_name>/..."
instead of "http://<web_site_nam e>/...":
* xsd:import schemaLocation
* soap12:address location/@location
* wsa10:Address
The second manifestation of the problem is that when I create a client
app in VS 2008 and then add a service reference to this service (using
the Add Service Reference option in the Solution Explorer), the
endpoint address also contains the server's name instead of the web
site name. One other thing that I notice is that when I try to add the
reference to the web service, the MetadataSource address in the svcmap
file refers to the "/mex" address instead of pointing to the wsdl
(which looks like "...?wsdl") .
I have tried to fix this by adding <baseaddresse s>/<add
baseaddress=".. ." /></baseaddressesen tries into the web.config for
the web service. Also added <identity><dn s value="..." /></identity>
entries in an attempt to fix this. I'm hoping that all is wrong is
that I'm missing some configuration values.
Can somebody tell me what I'm doing wrong? Thanks!
Jun 27 '08 #1
3 2784
On May 1, 7:12*am, kkao77 <kka...@gmail.c omwrote:
can you show me in more detail? *I have same problem where on the page
it'shttps://service.premila nce.com/Company.svc, but the svcutil tells
me to get it fromhttps://pserver1/Company.svc?wsd lwhich is
incorrect.. I have no clue how to fix it and i'm struggling for two
days already :(

On Mar 13, 3:09 pm, "Tiago Halm" <th...@nospam.h otmail.comwrote :
If hosting in IIS, just set the hostheader of the website to the public
hostname. The generated WSDL/XSDs will contain the hostname with which it
was accessed.
Tiago Halm
<kiern...@yahoo .comwrote in message
news:c8******** *************** ***********@d21 g2000prf.google groups.com...
I'm fairly new to deploying WCF web services and am running into
problems deploying my WCF service to a public web site. I want this
web service to be accessible by clients outside my domain.
The problem I'm running into first off is that the WSDL contains the
server's name instead of the web site's name. The WSDL elements and
attributes listed below contain "http://<server_interna l_name>/..."
instead of "http://<web_site_nam e>/...":
* xsd:import schemaLocation
* soap12:address location/@location
* wsa10:Address
The second manifestation of the problem is that when I create a client
app in VS 2008 and then add a service reference to this service (using
the Add Service Reference option in the Solution Explorer), the
endpoint address also contains the server's name instead of the web
site name. One other thing that I notice is that when I try to add the
reference to the web service, the MetadataSource address in the svcmap
file refers to the "/mex" address instead of pointing to the wsdl
(which looks like "...?wsdl") .
I have tried to fix this by adding <baseaddresse s>/<add
baseaddress=".. ." /></baseaddressesen tries into the web.config for
the web service. Also added <identity><dn s value="..." /></identity>
entries in an attempt to fix this. I'm hoping that all is wrong is
that I'm missing some configuration values.
Can somebody tell me what I'm doing wrong? Thanks!- Hide quoted text -

- Show quoted text -
Since you have a server certificate in IIS, you cannot set the host
header name via the UI, so IIRC you need to use adsutil.vbs for that.
Its useful to read this blog and view the webcast on setting Host
Headers with SSL in IIS 6.0.
http://agramont.net/blogs/conrad/arc.../06/26/21.aspx

Tiago Halm
Jun 27 '08 #2
Thanks for this post this fixes the problem for me. And here is the
detail in a nice easy to find place.

To list all the sites in IIS
C:\Inetpub\Admi nScripts>adsuti l.vbs enum /p w3svc

[/w3svc/1]
[/w3svc/922169312] <-the site that you want to secure using a
hostheader
[/w3svc/AppPools]
[/w3svc/Filters]
[/w3svc/Info]

C:\Inetpub\Admi nScripts>adsuti l.vbs get /w3svc/922169312/
serverbindings
serverbindings : (LIST) (1 Items)
":80:testddi.do verport.co.uk"

C:\Inetpub\Admi nScripts>adsuti l.vbs get /w3svc/922169312/
securebindings
securebindings : (LIST) (1 Items)
":443:"

C:\Inetpub\Admi nScripts>adsuti l.vbs set /w3svc/922169312/
securebindings ":443:host.head er.com"
securebindings : (LIST) ":443:host.head er.com"

Again many thanks just the right solution
Andy
On May 6, 6:13*pm, tiago.h...@gmai l.com wrote:
On May 1, 7:12*am, kkao77 <kka...@gmail.c omwrote:
can you show me in more detail? *I have same problem where on the page
it'shttps://service.premila nce.com/Company.svc, but the svcutil tells
me to get it fromhttps://pserver1/Company.svc?wsd lwhichis
incorrect.. I have no clue how to fix it and i'm struggling for two
days already :(
On Mar 13, 3:09 pm, "Tiago Halm" <th...@nospam.h otmail.comwrote :
If hosting in IIS, just set the hostheader of the website to the public
hostname. The generated WSDL/XSDs will contain the hostname with whichit
was accessed.
>Tiago Halm
<kiern...@yahoo .comwrote in message
>news:c8******* *************** ************@d2 1g2000prf.googl egroups.com....
I'm fairly new to deploying WCF web services and am running into
problems deploying my WCF service to a public web site. I want this
web service to be accessible by clients outside my domain.
The problem I'm running into first off is that the WSDL contains the
server's name instead of the web site's name. The WSDL elements and
attributes listed below contain "http://<server_interna l_name>/..."
instead of "http://<web_site_nam e>/...":
* xsd:import schemaLocation
* soap12:address location/@location
* wsa10:Address
The second manifestation of the problem is that when I create a client
app in VS 2008 and then add a service reference to this service (using
the Add Service Reference option in the Solution Explorer), the
endpoint address also contains the server's name instead of the web
site name. One other thing that I notice is that when I try to add the
reference to the web service, the MetadataSource address in the svcmap
file refers to the "/mex" address instead of pointing to the wsdl
(which looks like "...?wsdl") .
I have tried to fix this by adding <baseaddresse s>/<add
baseaddress=".. ." /></baseaddressesen tries into the web.config for
the web service. Also added <identity><dn s value="..." /></identity>
entries in an attempt to fix this. I'm hoping that all is wrong is
that I'm missing some configuration values.
Can somebody tell me what I'm doing wrong? Thanks!- Hide quoted text-
- Show quoted text -

Since you have a server certificate in IIS, you cannot set the host
header name via the UI, so IIRC you need to use adsutil.vbs for that.
Its useful to read this blog and view the webcast on setting Host
Headers with SSL in IIS 6.0.http://agramont.net/blogs/conrad/arc.../06/26/21.aspx

Tiago Halm
Jun 27 '08 #3
Thanks for this post this fixes the problem for me. And here is the
detail in a nice easy to find place.

To list all the sites in IIS
C:\Inetpub\Admi nScripts>adsuti l.vbs enum /p w3svc

[/w3svc/1]
[/w3svc/922169312] <-the site that you want to secure using a
hostheader
[/w3svc/AppPools]
[/w3svc/Filters]
[/w3svc/Info]

C:\Inetpub\Admi nScripts>adsuti l.vbs get /w3svc/922169312/
serverbindings
serverbindings : (LIST) (1 Items)
":80:host.heade r.com"

C:\Inetpub\Admi nScripts>adsuti l.vbs get /w3svc/922169312/
securebindings
securebindings : (LIST) (1 Items)
":443:"

C:\Inetpub\Admi nScripts>adsuti l.vbs set /w3svc/922169312/
securebindings ":443:host.head er.com"
securebindings : (LIST) ":443:host.head er.com"

Again many thanks just the right solution
Andy
On May 6, 6:13*pm, tiago.h...@gmai l.com wrote:
On May 1, 7:12*am, kkao77 <kka...@gmail.c omwrote:
can you show me in more detail? *I have same problem where on the page
it'shttps://service.premila nce.com/Company.svc, but the svcutil tells
me to get it fromhttps://pserver1/Company.svc?wsd lwhichis
incorrect.. I have no clue how to fix it and i'm struggling for two
days already :(
On Mar 13, 3:09 pm, "Tiago Halm" <th...@nospam.h otmail.comwrote :
If hosting in IIS, just set the hostheader of the website to the public
hostname. The generated WSDL/XSDs will contain the hostname with whichit
was accessed.
>Tiago Halm
<kiern...@yahoo .comwrote in message
>news:c8******* *************** ************@d2 1g2000prf.googl egroups.com....
I'm fairly new to deploying WCF web services and am running into
problems deploying my WCF service to a public web site. I want this
web service to be accessible by clients outside my domain.
The problem I'm running into first off is that the WSDL contains the
server's name instead of the web site's name. The WSDL elements and
attributes listed below contain "http://<server_interna l_name>/..."
instead of "http://<web_site_nam e>/...":
* xsd:import schemaLocation
* soap12:address location/@location
* wsa10:Address
The second manifestation of the problem is that when I create a client
app in VS 2008 and then add a service reference to this service (using
the Add Service Reference option in the Solution Explorer), the
endpoint address also contains the server's name instead of the web
site name. One other thing that I notice is that when I try to add the
reference to the web service, the MetadataSource address in the svcmap
file refers to the "/mex" address instead of pointing to the wsdl
(which looks like "...?wsdl") .
I have tried to fix this by adding <baseaddresse s>/<add
baseaddress=".. ." /></baseaddressesen tries into the web.config for
the web service. Also added <identity><dn s value="..." /></identity>
entries in an attempt to fix this. I'm hoping that all is wrong is
that I'm missing some configuration values.
Can somebody tell me what I'm doing wrong? Thanks!- Hide quoted text-
- Show quoted text -

Since you have a server certificate in IIS, you cannot set the host
header name via the UI, so IIRC you need to use adsutil.vbs for that.
Its useful to read this blog and view the webcast on setting Host
Headers with SSL in IIS 6.0.http://agramont.net/blogs/conrad/arc.../06/26/21.aspx

Tiago Halm
Jun 27 '08 #4

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

1
5759
by: Erik Myllymaki | last post by:
I am trying to start and stop a service with python. This used to work on an NT box but not on this 2003 server machine. (note- using "net stop myService" and net start myService" from the command line works just fine). The event viewer does tell me that a "Start command was sent to myService" but the service never starts. ------------------------------------------------------------------------- import win32serviceutil
1
1789
by: Glenn | last post by:
I have used this code successfully in a form application. I tried to add the same code in a service and have not been able to get the application to start. I have the service starting with a local account and the Interact with the Desktop is Checked. Windows media player seems to start but then closes almost immediately. I would appreciate any help. Thanks, Glenn
1
1744
by: dansan | last post by:
We have a webservice that we have been deploying using the deployment project in Visual Studio. Now we are trying to deploy this service to a server that has multiple sites. I have looked everywhere in the deployement project to see where I can allow the person installing to choose the root, but I can't find anything. Is there a way to install in a desired root using the deployment project? or is Visual Studio installer more of a...
3
3240
by: BravesCharm | last post by:
BravesCharm Dec 7, 10:57 am show options Newsgroups: microsoft.public.dotnet.distributed_apps From: "BravesCharm" <mastrauc...@gmail.com> Date: 7 Dec 2004 10:57:40 -0800 Local: Tues, Dec 7 2004 10:57 am Subject: Have trouble with reference counts! Reply | Reply to Author | Forward | Print | Individual Message | Show original | Remove | Report Abuse
1
2787
by: Duncan | last post by:
Guys a little please, I'm creating a windows application that uses a webservice and WSE1.0 to talk to a database, currently this works fine when using localhost, I now want to test the deployment of this webservice on another server (inhouse) so I know it will work when I come to put the webservice on to the webserver (external), I have used the copy project wizard in VB2K3 using file share and it puts the files on to the server, when I...
3
5012
by: Olivier BESSON | last post by:
Hello, I have a web service of my own on a server (vb.net). I must declare it with SoapRpcMethod to be used with JAVA. This is a simple exemple method of my vb source : >************************************************************************ > <WebMethod(), System.Web.Services.Protocols.SoapRpcMethod()> _ > Public Function HelloWorld() As > <System.Xml.Serialization.SoapElementAttribute("return")> String
8
1746
by: Afshar | last post by:
Hi Group, Please help ending my Nightmare! There's a Windows Service written in VC++ and I have an ASP.NET project that uses this sevice as a COM library. It just works fine in VS Internal Web Server and also in my IIS. I can publish it on my computer easily, But CAN'T publish or deploy it on other machines with almost same configuration. The Service in working on all other machines too. I've tried several ways to set all permissions...
0
2689
by: =?Utf-8?B?TWFuaQ==?= | last post by:
Hi All, Problem in deploying my WebService developed using Asp.net WebServices 2005. I have designed simple WebService using Asp.net Webservices 2.0 , The webservice look this , using System; using System.Web; using System.Web.Services; using System.Web.Services.Protocols;
5
5593
by: Oriane | last post by:
Hi, I have a .Net Visual Studio solution with one asp.net Web application, which uses a Asp.Net Web service. Both are compiled in debug mode, and both are using the Studio development web server for debugging. I have also add the Web reference to the web service with the "Add Web service in the solution" choice, that is the Web app starts the Web service with the Studio development web server. So I thought I could set breakpoints on...
0
9933
marktang
by: marktang | last post by:
ONU (Optical Network Unit) is one of the key components for providing high-speed Internet services. Its primary function is to act as an endpoint device located at the user's premises. However, people are often confused as to whether an ONU can Work As a Router. In this blog post, weíll explore What is ONU, What Is Router, ONU & Routerís main usage, and What is the difference between ONU and Router. Letís take a closer look ! Part I. Meaning of...
0
9789
by: Hystou | last post by:
Most computers default to English, but sometimes we require a different language, especially when relocating. Forgot to request a specific language before your computer shipped? No problem! You can effortlessly switch the default language on Windows 10 without reinstalling. I'll walk you through it. First, let's disable language synchronization. With a Microsoft account, language settings sync across devices. To prevent any complications,...
0
11129
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. Here is my compilation command: g++-12 -std=c++20 -Wnarrowing bit_field.cpp Here is the code in...
0
10734
jinu1996
by: jinu1996 | last post by:
In today's digital age, having a compelling online presence is paramount for businesses aiming to thrive in a competitive landscape. At the heart of this digital strategy lies an intricately woven tapestry of website design and digital marketing. It's not merely about having a website; it's about crafting an immersive digital experience that captivates audiences and drives business growth. The Art of Business Website Design Your website is...
1
10838
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For most users, this new feature is actually very convenient. If you want to control the update process,...
0
10408
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the choice of these technologies. I'm particularly interested in Zigbee because I've heard it does some...
0
7119
by: conductexam | last post by:
I have .net C# application in which I am extracting data from word file and save it in database particularly. To store word all data as it is I am converting the whole word file firstly in HTML and then checking html paragraph one by one. At the time of converting from word file to html my equations which are in the word document file was convert into image. Globals.ThisAddIn.Application.ActiveDocument.Select();...
0
5794
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in the same network. But I'm wondering if it's possible to do the same thing, with 2 Pfsense firewalls...
2
4213
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.