473,850 Members | 2,067 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

Problem with a web service

DLN
Hello all,

I'm running into a problem with one of our site's production web
applications that was written in VB.net. The web app is running on
W2K3/IIS6 and up until this afternoon, was working just fine. The
application calls a web service that exists as an application under the main
application's root directory, and it looks as though this is where the
application dies. The UI returns "The request failed with HTTP status 400:
Bad Request" plus the source file and line number where the unhandled
exception occurred and a stack trace. The IIS server log returns a 500
error (internal server error), which still isn't all that helpful. I have
the web app source code from the developers which I have built and
configured to hit the exact same web service on the production server, and
my sandbox web app appears to function properly. The difference though is
that in my sandbox, the web app is not running off the production server
(although the web service still is). With the production system, the web
service and web app are both are running off the same box.

I don't know what has changed to cause this behavior, I've just been tasked
to fix it. I've been pulled off another project to look at this problem and
it's the first time I've seen this code. There's also a time delay between
our site and where the developers are, so I'm on my own for the next few
hours. I could really use some advice on how I can troubleshoot this
problem further. Based on the fact that the app seems to run fine when
running off a separate server than the web service I'm wondering if
something is misconfigured on the server, but I've run out of places to
look.

Just some additional info (in hopes that it might be useful), both the app
and web service are using the same IIS application pool and the pool is
configured to run as "Network Service". Both the app and service are
configured to allow anonymous logons through IIS but the web.config file for
the application is set for forms based authentication and "identity
impersonate". The web service's web.config file is set to windows
authentication.

I certainly would appreciate any hints, tips or suggestions.

Regards,

dln
Mar 8 '07 #1
1 1755
DLN
Figured it out - it was a problem with assigning an IP address to the web
site (as opposed to "All Unassigned") and configuring a host header value.
Once I changed the site to use all unassigned IP addresses and removed the
host header value, everything started working again.

"DLN" <dn**********@h otmail.comwrote in message
news:OF******** ******@TK2MSFTN GP06.phx.gbl...
Hello all,

I'm running into a problem with one of our site's production web
applications that was written in VB.net. The web app is running on
W2K3/IIS6 and up until this afternoon, was working just fine. The
application calls a web service that exists as an application under the
main application's root directory, and it looks as though this is where
the application dies. The UI returns "The request failed with HTTP status
400: Bad Request" plus the source file and line number where the unhandled
exception occurred and a stack trace. The IIS server log returns a 500
error (internal server error), which still isn't all that helpful. I have
the web app source code from the developers which I have built and
configured to hit the exact same web service on the production server, and
my sandbox web app appears to function properly. The difference though is
that in my sandbox, the web app is not running off the production server
(although the web service still is). With the production system, the web
service and web app are both are running off the same box.

I don't know what has changed to cause this behavior, I've just been
tasked to fix it. I've been pulled off another project to look at this
problem and it's the first time I've seen this code. There's also a time
delay between our site and where the developers are, so I'm on my own for
the next few hours. I could really use some advice on how I can
troubleshoot this problem further. Based on the fact that the app seems
to run fine when running off a separate server than the web service I'm
wondering if something is misconfigured on the server, but I've run out of
places to look.

Just some additional info (in hopes that it might be useful), both the app
and web service are using the same IIS application pool and the pool is
configured to run as "Network Service". Both the app and service are
configured to allow anonymous logons through IIS but the web.config file
for the application is set for forms based authentication and "identity
impersonate". The web service's web.config file is set to windows
authentication.

I certainly would appreciate any hints, tips or suggestions.

Regards,

dln

Mar 8 '07 #2

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

3
5225
by: David Fraser | last post by:
Hi We are trying to debug a problem with services created using py2exe. It seems that these problems have arisen after services were installed and removed a few times. OK, first the actual problem we're seeing. After compiling a service with py2exe, running "service -install" and attempting to start it from the Services dialog, it pops up the message "Windows could not start the Service on Local Computer. For more information,...
0
3503
by: David | last post by:
I've written a small windows service, and I'm having a problem that I'm spending a lot more time on than I'd like. If anyone has experienced this problem and has any hints or solutions; they would be appreciated. Simply leaving the threadMain() method if something unexpected occurs during thread execution leaves the thread in a ThreadState.Running state. This (apparently??) causes the Thread.Join() in service.OnStop() to hang...
9
2261
by: Sudesh Sawant | last post by:
Hello, We have an application which communicates using remoting. There is a server which is a Windows Service. The server exposes an object which is a singleton. The client is a Web Application which makes calls to the service. We are using tcp channel which is using binaryformatter by default. The problem is that after a certain number of remoting calls the calls dont get through to the server. The client application makes the call and...
16
4935
by: Dany | last post by:
Our web service was working fine until we installed .net Framework 1.1 service pack 1. Uninstalling SP1 is not an option because our largest customer says service packs marked as "critical" by Microsoft must be installed on their servers. Now german Umlaute (ä, ü, ö) and quotes are returned incorrectly in SOAP fault responses. This can be easily verified: Implement the following in a web service method (just raises a SOAPException with a...
2
1946
by: =?Utf-8?B?aGVsZmk=?= | last post by:
Hi all, I have replied with my own questions to an older post entry but after a while I thought it's better to start a new thread based on the previous one. Perhaps with the new thread I will catch more eyes and find someone who had the same problem and solved it or has more information about it. This is a summary of my problem:
4
3174
by: Dave Burns | last post by:
I am self hosting a Web Service in a Windows service. I am trying to start the service using the NT AUTHORITY\NetworkService account. I get a NullReferenceException on ServiceHost.Open() in the ServiceBase.OnStart() method. SCM throws a 1067 error as well. I get the same problem with NT AUTHORITY\LocalService. When I use the LocalSystem account, my domain account, or another regular user account, the windows service starts just fine.
0
11011
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. Here is my compilation command: g++-12 -std=c++20 -Wnarrowing bit_field.cpp Here is the code in...
0
10666
jinu1996
by: jinu1996 | last post by:
In today's digital age, having a compelling online presence is paramount for businesses aiming to thrive in a competitive landscape. At the heart of this digital strategy lies an intricately woven tapestry of website design and digital marketing. It's not merely about having a website; it's about crafting an immersive digital experience that captivates audiences and drives business growth. The Art of Business Website Design Your website is...
1
10724
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For most users, this new feature is actually very convenient. If you want to control the update process,...
0
9503
agi2029
by: agi2029 | last post by:
Let's talk about the concept of autonomous AI software engineers and no-code agents. These AIs are designed to manage the entire lifecycle of a software development project—planning, coding, testing, and deployment—without human intervention. Imagine an AI that can take a project description, break it down, write the code, debug it, and then launch it, all on its own.... Now, this would greatly impact the work of software developers. The idea...
1
7899
isladogs
by: isladogs | last post by:
The next Access Europe User Group meeting will be on Wednesday 1 May 2024 starting at 18:00 UK time (6PM UTC+1) and finishing by 19:30 (7.30PM). In this session, we are pleased to welcome a new presenter, Adolph Dupré who will be discussing some powerful techniques for using class modules. He will explain when you may want to use classes instead of User Defined Types (UDT). For example, to manage the data in unbound forms. Adolph will...
0
7071
by: conductexam | last post by:
I have .net C# application in which I am extracting data from word file and save it in database particularly. To store word all data as it is I am converting the whole word file firstly in HTML and then checking html paragraph one by one. At the time of converting from word file to html my equations which are in the word document file was convert into image. Globals.ThisAddIn.Application.ActiveDocument.Select();...
0
5735
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in the same network. But I'm wondering if it's possible to do the same thing, with 2 Pfsense firewalls...
1
4546
by: 6302768590 | last post by:
Hai team i want code for transfer the data from one system to another through IP address by using C# our system has to for every 5mins then we have to update the data what the data is updated we have to send another system
2
4140
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.