473,550 Members | 2,436 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

Runtime error while running web application on remote machine

Hi,

After deploymnet web application on web server I can access page on local
machine and login fine but when I'm trying to access web site from remote
machine I can see login page, but when I'm trying to login with correct
credentials it give me error:

Server Error in '/PDVMgr' Application.

----------------------------------------------------------------------------
----

Runtime Error

Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable
on remote machines, please create a <customErrors > tag within a "web.config "
configuration file located in the root directory of the current web
application. This <customErrors > tag should then have its "mode" attribute
set to "Off".

ANY SUGGESTIONS AND CONCERNS???????

Thanks

Marina
Jul 21 '05 #1
9 2983
Try getting the actual error message by temporarily setting the customErrors
mode to off. That should show you the actual exception you're getting on the
remote server.

--
This posting is provided "AS IS" with no warranties, and confers no rights.
Use of included script samples are subject to the terms specified at
http://www.microsoft.com/info/cpyright.htm.

"Marina Anufreichik" <marina_at_pdvc orp_dot_com> wrote in message
news:uK******** ******@TK2MSFTN GP10.phx.gbl...
Hi,

After deploymnet web application on web server I can access page on local
machine and login fine but when I'm trying to access web site from remote
machine I can see login page, but when I'm trying to login with correct
credentials it give me error:

Server Error in '/PDVMgr' Application.

-------------------------------------------------------------------------- -- ----

Runtime Error

Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors > tag within a "web.config " configuration file located in the root directory of the current web
application. This <customErrors > tag should then have its "mode" attribute
set to "Off".

ANY SUGGESTIONS AND CONCERNS???????

Thanks

Marina

Jul 21 '05 #2
In web config the setting for customErrors is off, but it still not
displaying

Thanks

Marina

"Shuvro Mazumder [MSFT]" <sh*****@online .microsoft.com> wrote in message
news:%2******** ********@TK2MSF TNGP14.phx.gbl. ..
Try getting the actual error message by temporarily setting the customErrors mode to off. That should show you the actual exception you're getting on the remote server.

--
This posting is provided "AS IS" with no warranties, and confers no rights. Use of included script samples are subject to the terms specified at
http://www.microsoft.com/info/cpyright.htm.

"Marina Anufreichik" <marina_at_pdvc orp_dot_com> wrote in message
news:uK******** ******@TK2MSFTN GP10.phx.gbl...
Hi,

After deploymnet web application on web server I can access page on local machine and login fine but when I'm trying to access web site from remote machine I can see login page, but when I'm trying to login with correct
credentials it give me error:

Server Error in '/PDVMgr' Application.


--------------------------------------------------------------------------
--
----

Runtime Error

Description: An application error occurred on the server. The current

custom
error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could,

however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be

viewable
on remote machines, please create a <customErrors > tag within a

"web.config "
configuration file located in the root directory of the current web
application. This <customErrors > tag should then have its "mode" attribute set to "Off".

ANY SUGGESTIONS AND CONCERNS???????

Thanks

Marina


Jul 21 '05 #3
Maybe the setting is overridden in the machine.config on your webserver

- Shuvro

--
This posting is provided "AS IS" with no warranties, and confers no rights.
Use of included script samples are subject to the terms specified at
http://www.microsoft.com/info/cpyright.htm.

"Marina Anufreichik" <marina_at_pdvc orp_dot_com> wrote in message
news:e9******** ******@TK2MSFTN GP15.phx.gbl...
In web config the setting for customErrors is off, but it still not
displaying

Thanks

Marina

"Shuvro Mazumder [MSFT]" <sh*****@online .microsoft.com> wrote in message
news:%2******** ********@TK2MSF TNGP14.phx.gbl. ..
Try getting the actual error message by temporarily setting the

customErrors
mode to off. That should show you the actual exception you're getting on

the
remote server.

--
This posting is provided "AS IS" with no warranties, and confers no

rights.
Use of included script samples are subject to the terms specified at
http://www.microsoft.com/info/cpyright.htm.

"Marina Anufreichik" <marina_at_pdvc orp_dot_com> wrote in message
news:uK******** ******@TK2MSFTN GP10.phx.gbl...
Hi,

After deploymnet web application on web server I can access page on local machine and login fine but when I'm trying to access web site from remote machine I can see login page, but when I'm trying to login with correct credentials it give me error:

Server Error in '/PDVMgr' Application.


--------------------------------------------------------------------------
--
----

Runtime Error

Description: An application error occurred on the server. The current

custom
error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could,

however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be

viewable
on remote machines, please create a <customErrors > tag within a

"web.config "
configuration file located in the root directory of the current web
application. This <customErrors > tag should then have its "mode" attribute set to "Off".

ANY SUGGESTIONS AND CONCERNS???????

Thanks

Marina



Jul 21 '05 #4
Hi, Shuvro.

A setting in machine.config *cannot*
override a setting in web.config.

A setting in web.config *can*
override a setting in machine.config.


Juan T. Llibre
ASP.NET MVP
===========
"Shuvro Mazumder [MSFT]" <sh*****@online .microsoft.com> wrote in message
news:uu******** *****@TK2MSFTNG P11.phx.gbl...
Maybe the setting is overridden in the machine.config on your webserver

- Shuvro "Marina Anufreichik" <marina_at_pdvc orp_dot_com> wrote in message
news:e9******** ******@TK2MSFTN GP15.phx.gbl...
In web config the setting for customErrors is off, but it still not
displaying

Thanks

Marina

"Shuvro Mazumder [MSFT]" <sh*****@online .microsoft.com> wrote in message
news:%2******** ********@TK2MSF TNGP14.phx.gbl. ..
> Try getting the actual error message by temporarily setting the

customErrors
> mode to off. That should show you the actual exception you're getting
> on

the
> remote server.
>
> --
> This posting is provided "AS IS" with no warranties, and confers no

rights.
> Use of included script samples are subject to the terms specified at
> http://www.microsoft.com/info/cpyright.htm.
>
>
>
> "Marina Anufreichik" <marina_at_pdvc orp_dot_com> wrote in message
> news:uK******** ******@TK2MSFTN GP10.phx.gbl...
> > Hi,
> >
> > After deploymnet web application on web server I can access page on

local
> > machine and login fine but when I'm trying to access web site from

remote
> > machine I can see login page, but when I'm trying to login with correct > > credentials it give me error:
> >
> > Server Error in '/PDVMgr' Application.
> >
>


--------------------------------------------------------------------------
> --
> > ----
> >
> > Runtime Error
> >
> > Description: An application error occurred on the server. The current
> custom
> > error settings for this application prevent the details of the

application
> > error from being viewed remotely (for security reasons). It could,
> however,
> > be viewed by browsers running on the local server machine.
> >
> > Details: To enable the details of this specific error message to be
> viewable
> > on remote machines, please create a <customErrors > tag within a
> "web.config "
> > configuration file located in the root directory of the current web
> > application. This <customErrors > tag should then have its "mode"

attribute
> > set to "Off".
> >
> >
> >
> > ANY SUGGESTIONS AND CONCERNS???????
> >
> >
> >
> > Thanks
> >
> > Marina
> >
> >
>
>



Jul 21 '05 #5
However, a server Admin can always enforce customErrors=Re moteOnly. That's
what I meant.

--
This posting is provided "AS IS" with no warranties, and confers no rights.
Use of included script samples are subject to the terms specified at
http://www.microsoft.com/info/cpyright.htm.

"Juan T. Llibre" <no***********@ nowhere.com> wrote in message
news:et******** ******@TK2MSFTN GP11.phx.gbl...
Hi, Shuvro.

A setting in machine.config *cannot*
override a setting in web.config.

A setting in web.config *can*
override a setting in machine.config.


Juan T. Llibre
ASP.NET MVP
===========
"Shuvro Mazumder [MSFT]" <sh*****@online .microsoft.com> wrote in message
news:uu******** *****@TK2MSFTNG P11.phx.gbl...
Maybe the setting is overridden in the machine.config on your webserver

- Shuvro

"Marina Anufreichik" <marina_at_pdvc orp_dot_com> wrote in message
news:e9******** ******@TK2MSFTN GP15.phx.gbl...
In web config the setting for customErrors is off, but it still not
displaying

Thanks

Marina

"Shuvro Mazumder [MSFT]" <sh*****@online .microsoft.com> wrote in message news:%2******** ********@TK2MSF TNGP14.phx.gbl. ..
> Try getting the actual error message by temporarily setting the
customErrors
> mode to off. That should show you the actual exception you're getting
> on
the
> remote server.
>
> --
> This posting is provided "AS IS" with no warranties, and confers no
rights.
> Use of included script samples are subject to the terms specified at
> http://www.microsoft.com/info/cpyright.htm.
>
>
>
> "Marina Anufreichik" <marina_at_pdvc orp_dot_com> wrote in message
> news:uK******** ******@TK2MSFTN GP10.phx.gbl...
> > Hi,
> >
> > After deploymnet web application on web server I can access page on
local
> > machine and login fine but when I'm trying to access web site from
remote
> > machine I can see login page, but when I'm trying to login with

correct
> > credentials it give me error:
> >
> > Server Error in '/PDVMgr' Application.
> >
>
-------------------------------------------------------------------------

-
> --
> > ----
> >
> > Runtime Error
> >
> > Description: An application error occurred on the server. The current > custom
> > error settings for this application prevent the details of the
application
> > error from being viewed remotely (for security reasons). It could,
> however,
> > be viewed by browsers running on the local server machine.
> >
> > Details: To enable the details of this specific error message to be
> viewable
> > on remote machines, please create a <customErrors > tag within a
> "web.config "
> > configuration file located in the root directory of the current web
> > application. This <customErrors > tag should then have its "mode"
attribute
> > set to "Off".
> >
> >
> >
> > ANY SUGGESTIONS AND CONCERNS???????
> >
> >
> >
> > Thanks
> >
> > Marina
> >
> >
>
>



Jul 21 '05 #6
Below is the section you need to put in machine.config. Make sure you remove
the existing <customerrors > section and then use the below. It's in a
location allowOverride=" false" to prevent users from overriding the setting
in their web.config.

<location allowOverride=" false">
<system.web>
<!--
customErrors Attributes:
mode="[On|Off|RemoteOn ly]"
On: Always display custom errors
Off: Always display ASP.NET error pages
RemoteOnly: Display custom errors to remote clients and ASP.NET
errors to localhost
defaultRedirect ="url" - Url to redirect client to when an error
occurs
-->
<customErrors mode="Off" />
</system.web>
</location>

Check if this is set in your machine.config on the server?
- Shuvro

--
This posting is provided "AS IS" with no warranties, and confers no rights.
Use of included script samples are subject to the terms specified at
http://www.microsoft.com/info/cpyright.htm.

"Juan T. Llibre" <no***********@ nowhere.com> wrote in message
news:et******** ******@TK2MSFTN GP11.phx.gbl...
Hi, Shuvro.

A setting in machine.config *cannot*
override a setting in web.config.

A setting in web.config *can*
override a setting in machine.config.


Juan T. Llibre
ASP.NET MVP
===========
"Shuvro Mazumder [MSFT]" <sh*****@online .microsoft.com> wrote in message
news:uu******** *****@TK2MSFTNG P11.phx.gbl...
Maybe the setting is overridden in the machine.config on your webserver

- Shuvro

"Marina Anufreichik" <marina_at_pdvc orp_dot_com> wrote in message
news:e9******** ******@TK2MSFTN GP15.phx.gbl...
In web config the setting for customErrors is off, but it still not
displaying

Thanks

Marina

"Shuvro Mazumder [MSFT]" <sh*****@online .microsoft.com> wrote in message news:%2******** ********@TK2MSF TNGP14.phx.gbl. ..
> Try getting the actual error message by temporarily setting the
customErrors
> mode to off. That should show you the actual exception you're getting
> on
the
> remote server.
>
> --
> This posting is provided "AS IS" with no warranties, and confers no
rights.
> Use of included script samples are subject to the terms specified at
> http://www.microsoft.com/info/cpyright.htm.
>
>
>
> "Marina Anufreichik" <marina_at_pdvc orp_dot_com> wrote in message
> news:uK******** ******@TK2MSFTN GP10.phx.gbl...
> > Hi,
> >
> > After deploymnet web application on web server I can access page on
local
> > machine and login fine but when I'm trying to access web site from
remote
> > machine I can see login page, but when I'm trying to login with

correct
> > credentials it give me error:
> >
> > Server Error in '/PDVMgr' Application.
> >
>
-------------------------------------------------------------------------

-
> --
> > ----
> >
> > Runtime Error
> >
> > Description: An application error occurred on the server. The current > custom
> > error settings for this application prevent the details of the
application
> > error from being viewed remotely (for security reasons). It could,
> however,
> > be viewed by browsers running on the local server machine.
> >
> > Details: To enable the details of this specific error message to be
> viewable
> > on remote machines, please create a <customErrors > tag within a
> "web.config "
> > configuration file located in the root directory of the current web
> > application. This <customErrors > tag should then have its "mode"
attribute
> > set to "Off".
> >
> >
> >
> > ANY SUGGESTIONS AND CONCERNS???????
> >
> >
> >
> > Thanks
> >
> > Marina
> >
> >
>
>



Jul 21 '05 #7
Shuvro,

with all due respect, wouldn't setting
<location allowOverride=" false">
affect *all* websites in a server ?

The default machine.config setting is :
<location allowOverride=" true">

That would imply that any web.config setting would
override any machine.config setting, as it should be.

Simply setting <customErrors mode="Off" /> in an application's
web.config would do the same job, unless the setting in
machine.config has been changed to <location allowOverride=" false">
( the setting you're recommending).

I'd really hesitate to recommend *any* user to change
machine.config at all, especially to override default settings
which affect *all* websites in a machine.

It's vastly preferrable to override any setting in machine.config
with a setting in web.config, as opposed to establishing a
machine-wide override in machine.config.

Juan T. Llibre
ASP.NET MVP
===========
"Shuvro Mazumder [MSFT]" <sh*****@online .microsoft.com> wrote in message
news:%2******** *********@TK2MS FTNGP15.phx.gbl ...
Below is the section you need to put in machine.config. Make sure you
remove
the existing <customerrors > section and then use the below. It's in a
location allowOverride=" false" to prevent users from overriding the
setting
in their web.config.

<location allowOverride=" false">
<system.web>
<!--
customErrors Attributes:
mode="[On|Off|RemoteOn ly]"
On: Always display custom errors
Off: Always display ASP.NET error pages
RemoteOnly: Display custom errors to remote clients and ASP.NET
errors to localhost
defaultRedirect ="url" - Url to redirect client to when an error
occurs
-->
<customErrors mode="Off" />
</system.web>
</location>

Check if this is set in your machine.config on the server?
- Shuvro "Juan T. Llibre" <no***********@ nowhere.com> wrote in message
news:et******** ******@TK2MSFTN GP11.phx.gbl...
Hi, Shuvro.

A setting in machine.config *cannot*
override a setting in web.config.

A setting in web.config *can*
override a setting in machine.config.


Juan T. Llibre
ASP.NET MVP
===========
"Shuvro Mazumder [MSFT]" <sh*****@online .microsoft.com> wrote in message
news:uu******** *****@TK2MSFTNG P11.phx.gbl...
> Maybe the setting is overridden in the machine.config on your webserver
>
> - Shuvro

> "Marina Anufreichik" <marina_at_pdvc orp_dot_com> wrote in message
> news:e9******** ******@TK2MSFTN GP15.phx.gbl...
>> In web config the setting for customErrors is off, but it still not
>> displaying
>>
>> Thanks
>>
>> Marina
>>
>> "Shuvro Mazumder [MSFT]" <sh*****@online .microsoft.com> wrote in message >> news:%2******** ********@TK2MSF TNGP14.phx.gbl. ..
>> > Try getting the actual error message by temporarily setting the
>> customErrors
>> > mode to off. That should show you the actual exception you're
>> > getting
>> > on
>> the
>> > remote server.
>> >
>> > --
>> > This posting is provided "AS IS" with no warranties, and confers no
>> rights.
>> > Use of included script samples are subject to the terms specified at
>> > http://www.microsoft.com/info/cpyright.htm.
>> >
>> >
>> >
>> > "Marina Anufreichik" <marina_at_pdvc orp_dot_com> wrote in message
>> > news:uK******** ******@TK2MSFTN GP10.phx.gbl...
>> > > Hi,
>> > >
>> > > After deploymnet web application on web server I can access page
>> > > on
>> local
>> > > machine and login fine but when I'm trying to access web site from
>> remote
>> > > machine I can see login page, but when I'm trying to login with
> correct
>> > > credentials it give me error:
>> > >
>> > > Server Error in '/PDVMgr' Application.
>> > >
>> >
>>

------------------------------------------------------------------------- - >> > --
>> > > ----
>> > >
>> > > Runtime Error
>> > >
>> > > Description: An application error occurred on the server. The current >> > custom
>> > > error settings for this application prevent the details of the
>> application
>> > > error from being viewed remotely (for security reasons). It could,
>> > however,
>> > > be viewed by browsers running on the local server machine.
>> > >
>> > > Details: To enable the details of this specific error message to
>> > > be
>> > viewable
>> > > on remote machines, please create a <customErrors > tag within a
>> > "web.config "
>> > > configuration file located in the root directory of the current
>> > > web
>> > > application. This <customErrors > tag should then have its "mode"
>> attribute
>> > > set to "Off".
>> > >
>> > >
>> > >
>> > > ANY SUGGESTIONS AND CONCERNS???????
>> > >
>> > >
>> > >
>> > > Thanks
>> > >
>> > > Marina
>> > >
>> > >
>> >
>> >
>>
>>
>
>




Jul 21 '05 #8
I was not recommending any solution. I was trying to help Marina with her
original problem, where she observed that changing the setting on the
web.config for customErrors key *DID NOT* change the behavior. My suggestion
was to ask the server Admin on which she was deploying her solution, if such
a setting have been made on the machine.config.

I agree with your observation that changes to machine.config would affect
all websites. However, the location allowOverride=" False" allows the server
administrator to specify default behavior for keys they ABSOLUTELY do not
want their users to override. Think about an ISP Scenario providing ASP.Net
web hosting. For security reasons, they might want to not allow users to
have customErrors mode="Off" set (that's how my ISP has their server set
up). In such cases it makes more sense to change the settings in
machine.config and not rely on individual applications having the setting in
their web.config.

Hope this helps
- Shuvro

--
This posting is provided "AS IS" with no warranties, and confers no rights.
Use of included script samples are subject to the terms specified at
http://www.microsoft.com/info/cpyright.htm.

"Juan T. Llibre" <no***********@ nowhere.com> wrote in message
news:OA******** ******@TK2MSFTN GP09.phx.gbl...
Shuvro,

with all due respect, wouldn't setting
<location allowOverride=" false">
affect *all* websites in a server ?

The default machine.config setting is :
<location allowOverride=" true">

That would imply that any web.config setting would
override any machine.config setting, as it should be.

Simply setting <customErrors mode="Off" /> in an application's
web.config would do the same job, unless the setting in
machine.config has been changed to <location allowOverride=" false">
( the setting you're recommending).

I'd really hesitate to recommend *any* user to change
machine.config at all, especially to override default settings
which affect *all* websites in a machine.

It's vastly preferrable to override any setting in machine.config
with a setting in web.config, as opposed to establishing a
machine-wide override in machine.config.

Juan T. Llibre
ASP.NET MVP
===========
"Shuvro Mazumder [MSFT]" <sh*****@online .microsoft.com> wrote in message
news:%2******** *********@TK2MS FTNGP15.phx.gbl ...
Below is the section you need to put in machine.config. Make sure you
remove
the existing <customerrors > section and then use the below. It's in a
location allowOverride=" false" to prevent users from overriding the
setting
in their web.config.

<location allowOverride=" false">
<system.web>
<!--
customErrors Attributes:
mode="[On|Off|RemoteOn ly]"
On: Always display custom errors
Off: Always display ASP.NET error pages
RemoteOnly: Display custom errors to remote clients and ASP.NET
errors to localhost
defaultRedirect ="url" - Url to redirect client to when an error
occurs
-->
<customErrors mode="Off" />
</system.web>
</location>

Check if this is set in your machine.config on the server?
- Shuvro

"Juan T. Llibre" <no***********@ nowhere.com> wrote in message
news:et******** ******@TK2MSFTN GP11.phx.gbl...
Hi, Shuvro.

A setting in machine.config *cannot*
override a setting in web.config.

A setting in web.config *can*
override a setting in machine.config.


Juan T. Llibre
ASP.NET MVP
===========
"Shuvro Mazumder [MSFT]" <sh*****@online .microsoft.com> wrote in message news:uu******** *****@TK2MSFTNG P11.phx.gbl...
> Maybe the setting is overridden in the machine.config on your webserver >
> - Shuvro

> "Marina Anufreichik" <marina_at_pdvc orp_dot_com> wrote in message
> news:e9******** ******@TK2MSFTN GP15.phx.gbl...
>> In web config the setting for customErrors is off, but it still not
>> displaying
>>
>> Thanks
>>
>> Marina
>>
>> "Shuvro Mazumder [MSFT]" <sh*****@online .microsoft.com> wrote in

message
>> news:%2******** ********@TK2MSF TNGP14.phx.gbl. ..
>> > Try getting the actual error message by temporarily setting the
>> customErrors
>> > mode to off. That should show you the actual exception you're
>> > getting
>> > on
>> the
>> > remote server.
>> >
>> > --
>> > This posting is provided "AS IS" with no warranties, and confers no >> rights.
>> > Use of included script samples are subject to the terms specified at >> > http://www.microsoft.com/info/cpyright.htm.
>> >
>> >
>> >
>> > "Marina Anufreichik" <marina_at_pdvc orp_dot_com> wrote in message
>> > news:uK******** ******@TK2MSFTN GP10.phx.gbl...
>> > > Hi,
>> > >
>> > > After deploymnet web application on web server I can access page
>> > > on
>> local
>> > > machine and login fine but when I'm trying to access web site from >> remote
>> > > machine I can see login page, but when I'm trying to login with
> correct
>> > > credentials it give me error:
>> > >
>> > > Server Error in '/PDVMgr' Application.
>> > >
>> >
>>
------------------------------------------------------------------------ - -
>> > --
>> > > ----
>> > >
>> > > Runtime Error
>> > >
>> > > Description: An application error occurred on the server. The

current
>> > custom
>> > > error settings for this application prevent the details of the
>> application
>> > > error from being viewed remotely (for security reasons). It

could, >> > however,
>> > > be viewed by browsers running on the local server machine.
>> > >
>> > > Details: To enable the details of this specific error message to
>> > > be
>> > viewable
>> > > on remote machines, please create a <customErrors > tag within a
>> > "web.config "
>> > > configuration file located in the root directory of the current
>> > > web
>> > > application. This <customErrors > tag should then have its "mode"
>> attribute
>> > > set to "Off".
>> > >
>> > >
>> > >
>> > > ANY SUGGESTIONS AND CONCERNS???????
>> > >
>> > >
>> > >
>> > > Thanks
>> > >
>> > > Marina
>> > >
>> > >
>> >
>> >
>>
>>
>
>



Jul 21 '05 #9
re:
I was not recommending any solution.
You sure could have fooled me.

Didn't you make this recommendation ?
Below is the section you need to put in machine.config.
Make sure you remove the existing <customerrors > section
and then use the below. It's in a location allowOverride=" false"
to prevent users from overriding the setting in their web.config.
Maybe you don't realize that you did recommend that change
( that has happened to me in the past ), but when you ask
someone to "put" something in machine.config and to
"make sure you remove the existing <customerrors > section",
you sure were recommending a solution : to edit machine.config.

Later, you said this : Check if this is set in your machine.config on the server?
Which is different than your earlier recommendation :
Below is the section you need to put in machine.config.
Make sure you remove the existing <customerrors >
section and then use the below.


That she check for that setting was a good recommendation,
if she has access to machine.config (which I doubt, since she's
talking about a web server at her ISP), but editing machine.config
was not a good recommendation.

If <location allowOverride=" false"> *had* been placed in
machine.config by her ISP, she wouldn't have access to
machine.config, anyway.

She would only have access to her application directory and,
if that setting *had* been placed there by her ISP for security
reasons, in the scenario you describe, it's highly unlikely that
her ISP would change it back to true for her, violating the
security rule you invoke as the reason for that setting having
been placed there by her ISP.

That said, Marina hasn't popped back in here to tell us how she did.
Let's hope she was able to work around the problem.


Juan T. Llibre
ASP.NET MVP
===========
"Shuvro Mazumder [MSFT]" <sh*****@online .microsoft.com> wrote in message
news:%2******** *******@TK2MSFT NGP10.phx.gbl.. .I was not recommending any solution. I was trying to help Marina with her
original problem, where she observed that changing the setting on the
web.config for customErrors key *DID NOT* change the behavior. My
suggestion
was to ask the server Admin on which she was deploying her solution, if
such
a setting have been made on the machine.config.

I agree with your observation that changes to machine.config would affect
all websites. However, the location allowOverride=" False" allows the
server
administrator to specify default behavior for keys they ABSOLUTELY do not
want their users to override. Think about an ISP Scenario providing
ASP.Net
web hosting. For security reasons, they might want to not allow users to
have customErrors mode="Off" set (that's how my ISP has their server set
up). In such cases it makes more sense to change the settings in
machine.config and not rely on individual applications having the setting
in
their web.config.

Hope this helps
- Shuvro

--
This posting is provided "AS IS" with no warranties, and confers no
rights.
Use of included script samples are subject to the terms specified at
http://www.microsoft.com/info/cpyright.htm.

"Juan T. Llibre" <no***********@ nowhere.com> wrote in message
news:OA******** ******@TK2MSFTN GP09.phx.gbl...
Shuvro,

with all due respect, wouldn't setting
<location allowOverride=" false">
affect *all* websites in a server ?

The default machine.config setting is :
<location allowOverride=" true">

That would imply that any web.config setting would
override any machine.config setting, as it should be.

Simply setting <customErrors mode="Off" /> in an application's
web.config would do the same job, unless the setting in
machine.config has been changed to <location allowOverride=" false">
( the setting you're recommending).

I'd really hesitate to recommend *any* user to change
machine.config at all, especially to override default settings
which affect *all* websites in a machine.

It's vastly preferrable to override any setting in machine.config
with a setting in web.config, as opposed to establishing a
machine-wide override in machine.config.

Juan T. Llibre
ASP.NET MVP
===========
"Shuvro Mazumder [MSFT]" <sh*****@online .microsoft.com> wrote in message
news:%2******** *********@TK2MS FTNGP15.phx.gbl ...
> Below is the section you need to put in machine.config. Make sure you
> remove
> the existing <customerrors > section and then use the below. It's in a
> location allowOverride=" false" to prevent users from overriding the
> setting
> in their web.config.
>
> <location allowOverride=" false">
> <system.web>
> <!--
> customErrors Attributes:
> mode="[On|Off|RemoteOn ly]"
> On: Always display custom errors
> Off: Always display ASP.NET error pages
> RemoteOnly: Display custom errors to remote clients and

ASP.NET > errors to localhost
> defaultRedirect ="url" - Url to redirect client to when an
> error
> occurs
> -->
> <customErrors mode="Off" />
> </system.web>
> </location>
>
> Check if this is set in your machine.config on the server?
> - Shuvro

> "Juan T. Llibre" <no***********@ nowhere.com> wrote in message
> news:et******** ******@TK2MSFTN GP11.phx.gbl...
>> Hi, Shuvro.
>>
>> A setting in machine.config *cannot*
>> override a setting in web.config.
>>
>> A setting in web.config *can*
>> override a setting in machine.config.
>>
>>
>>
>>
>> Juan T. Llibre
>> ASP.NET MVP
>> ===========
>> "Shuvro Mazumder [MSFT]" <sh*****@online .microsoft.com> wrote in message >> news:uu******** *****@TK2MSFTNG P11.phx.gbl...
>> > Maybe the setting is overridden in the machine.config on your webserver >> >
>> > - Shuvro
>>
>> > "Marina Anufreichik" <marina_at_pdvc orp_dot_com> wrote in message
>> > news:e9******** ******@TK2MSFTN GP15.phx.gbl...
>> >> In web config the setting for customErrors is off, but it still not
>> >> displaying
>> >>
>> >> Thanks
>> >>
>> >> Marina
>> >>
>> >> "Shuvro Mazumder [MSFT]" <sh*****@online .microsoft.com> wrote in
> message
>> >> news:%2******** ********@TK2MSF TNGP14.phx.gbl. ..
>> >> > Try getting the actual error message by temporarily setting the
>> >> customErrors
>> >> > mode to off. That should show you the actual exception you're
>> >> > getting
>> >> > on
>> >> the
>> >> > remote server.
>> >> >
>> >> > --
>> >> > This posting is provided "AS IS" with no warranties, and confers no >> >> rights.
>> >> > Use of included script samples are subject to the terms specified at >> >> > http://www.microsoft.com/info/cpyright.htm.
>> >> >
>> >> >
>> >> >
>> >> > "Marina Anufreichik" <marina_at_pdvc orp_dot_com> wrote in message
>> >> > news:uK******** ******@TK2MSFTN GP10.phx.gbl...
>> >> > > Hi,
>> >> > >
>> >> > > After deploymnet web application on web server I can access
>> >> > > page
>> >> > > on
>> >> local
>> >> > > machine and login fine but when I'm trying to access web site from >> >> remote
>> >> > > machine I can see login page, but when I'm trying to login with
>> > correct
>> >> > > credentials it give me error:
>> >> > >
>> >> > > Server Error in '/PDVMgr' Application.
>> >> > >
>> >> >
>> >>
>>

------------------------------------------------------------------------ - > -
>> >> > --
>> >> > > ----
>> >> > >
>> >> > > Runtime Error
>> >> > >
>> >> > > Description: An application error occurred on the server. The
> current
>> >> > custom
>> >> > > error settings for this application prevent the details of the
>> >> application
>> >> > > error from being viewed remotely (for security reasons). It could, >> >> > however,
>> >> > > be viewed by browsers running on the local server machine.
>> >> > >
>> >> > > Details: To enable the details of this specific error message
>> >> > > to
>> >> > > be
>> >> > viewable
>> >> > > on remote machines, please create a <customErrors > tag within a
>> >> > "web.config "
>> >> > > configuration file located in the root directory of the current
>> >> > > web
>> >> > > application. This <customErrors > tag should then have its
>> >> > > "mode"
>> >> attribute
>> >> > > set to "Off".
>> >> > >
>> >> > >
>> >> > >
>> >> > > ANY SUGGESTIONS AND CONCERNS???????
>> >> > >
>> >> > >
>> >> > >
>> >> > > Thanks
>> >> > >
>> >> > > Marina
>> >> > >
>> >> > >
>> >> >
>> >> >
>> >>
>> >>
>> >
>> >
>>
>>
>
>



Jul 21 '05 #10

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

5
15105
by: Nathan Bloom | last post by:
Hi, I have a secured database that runs fine on the computer the database is installed on. I have several workstations with access runtime installed that also need access to the database. Access runtime runs fine when accessing an unsecured version of the database. However once the database was secured it generates a runtime error after...
7
2848
by: Yongsub Eric Shin | last post by:
Hi. I'm just a beginner in ASP.Net. I started writing codes and I keep on getting this Runtime Error page, where it says "Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could,...
4
1552
by: VB Programmer | last post by:
If I try ANY aspx pages on my server, even INVALID, bogus pages, I get a "Runtime Error". Any idea why? Here is the full message: Server Error in '/' Application. ---------------------------------------------------------------------------- ----
10
3342
by: Marina Anufreichik | last post by:
Hi, After deploymnet web application on web server I can access page on local machine and login fine but when I'm trying to access web site from remote machine I can see login page, but when I'm trying to login with correct credentials it give me error: Server Error in '/PDVMgr' Application. ...
5
278
by: Kiyomi | last post by:
Hello, I have created two different ASP.NET applications and placed one in the root and another one in a sub-directory. http://localhost/MyApp_1/Index.aspx
4
13589
by: Pat | last post by:
In my Web.config i have :- <customErrors mode="On" defaultRedirect="genericerror.htm"> <error statusCode="404" redirect="pagenotfound.aspx"/> </customErrors to get page not found error but instead i keep getting a RUN TIME error below: Any ideas.. Runtime Error
0
7563
marktang
by: marktang | last post by:
ONU (Optical Network Unit) is one of the key components for providing high-speed Internet services. Its primary function is to act as an endpoint device located at the user's premises. However, people are often confused as to whether an ONU can Work As a Router. In this blog post, we’ll explore What is ONU, What Is Router, ONU & Router’s main...
0
8001
jinu1996
by: jinu1996 | last post by:
In today's digital age, having a compelling online presence is paramount for businesses aiming to thrive in a competitive landscape. At the heart of this digital strategy lies an intricately woven tapestry of website design and digital marketing. It's not merely about having a website; it's about crafting an immersive digital experience that...
1
7520
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For...
0
7846
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the...
0
6104
agi2029
by: agi2029 | last post by:
Let's talk about the concept of autonomous AI software engineers and no-code agents. These AIs are designed to manage the entire lifecycle of a software development project—planning, coding, testing, and deployment—without human intervention. Imagine an AI that can take a project description, break it down, write the code, debug it, and then...
1
5404
isladogs
by: isladogs | last post by:
The next Access Europe User Group meeting will be on Wednesday 1 May 2024 starting at 18:00 UK time (6PM UTC+1) and finishing by 19:30 (7.30PM). In this session, we are pleased to welcome a new presenter, Adolph Dupré who will be discussing some powerful techniques for using class modules. He will explain when you may want to use classes...
0
5129
by: conductexam | last post by:
I have .net C# application in which I am extracting data from word file and save it in database particularly. To store word all data as it is I am converting the whole word file firstly in HTML and then checking html paragraph one by one. At the time of converting from word file to html my equations which are in the word document file was convert...
0
3533
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in...
0
3519
by: adsilva | last post by:
A Windows Forms form does not have the event Unload, like VB6. What one acts like?

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.