By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,077 Members | 2,160 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,077 IT Pros & Developers. It's quick & easy.

Swedish Characters

P: n/a
Hi I thought that working with swedish characters would be easy, but
since I'm working with MySQL 4.1 that's not the case any more.
First thing I noticed (emditly) was an application that I've written
in Qt showd rubbish in the QDataTable where there should be swedish
characters. So I took a look in the database using the 'mysql' client
app, but using this, all is good? So I made a 'mysqldump -u xx -pxx
dbname < cazzo.sql' and took a look in the .sql file, but again the
swedish characters were rubbish.
I've really tried a lot of thing to solve this. E.g. changing the
default-character-set to all kinds of values, creating new databases,
etc etc. But I just can't get it. What am I missing?
Any help would really be nice ... please

Tim Mickelson
Jul 20 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Tim Mickelson wrote:
Hi I thought that working with swedish characters would be easy, but
since I'm working with MySQL 4.1 that's not the case any more.
First thing I noticed (emditly) was an application that I've written
in Qt showd rubbish in the QDataTable where there should be swedish
characters. So I took a look in the database using the 'mysql' client
app, but using this, all is good? So I made a 'mysqldump -u xx -pxx
dbname < cazzo.sql' and took a look in the .sql file, but again the
swedish characters were rubbish.
I've really tried a lot of thing to solve this. E.g. changing the
default-character-set to all kinds of values, creating new databases,
etc etc. But I just can't get it. What am I missing?
Any help would really be nice ... please

Tim Mickelson


Not sure it matters, but you have your arrow the wrong way. Try ">"
instead.
Jul 20 '05 #2

P: n/a
no, that's not my problem :) just an error when writing the e-mail.


Paul Bramscher wrote:
Tim Mickelson wrote:
Hi I thought that working with swedish characters would be easy, but
since I'm working with MySQL 4.1 that's not the case any more.
First thing I noticed (emditly) was an application that I've written
in Qt showd rubbish in the QDataTable where there should be swedish
characters. So I took a look in the database using the 'mysql' client
app, but using this, all is good? So I made a 'mysqldump -u xx -pxx
dbname < cazzo.sql' and took a look in the .sql file, but again the
swedish characters were rubbish.
I've really tried a lot of thing to solve this. E.g. changing the
default-character-set to all kinds of values, creating new databases,
etc etc. But I just can't get it. What am I missing?
Any help would really be nice ... please

Tim Mickelson

Not sure it matters, but you have your arrow the wrong way. Try ">"
instead.

Jul 20 '05 #3

P: n/a
Here's another trick question for you. What are you using to look at
the file with? I'm not sure how mySQL dumps out the characters -- but
it's possible they are correct and your editor is not displaying them
properly?

Tim Mickelson wrote:
no, that's not my problem :) just an error when writing the e-mail.


Paul Bramscher wrote:
Tim Mickelson wrote:
Hi I thought that working with swedish characters would be easy,
but since I'm working with MySQL 4.1 that's not the case any more.
First thing I noticed (emditly) was an application that I've
written in Qt showd rubbish in the QDataTable where there should be
swedish characters. So I took a look in the database using the
'mysql' client app, but using this, all is good? So I made a
'mysqldump -u xx -pxx dbname < cazzo.sql' and took a look in the .sql
file, but again the swedish characters were rubbish.
I've really tried a lot of thing to solve this. E.g. changing the
default-character-set to all kinds of values, creating new databases,
etc etc. But I just can't get it. What am I missing?
Any help would really be nice ... please

Tim Mickelson


Not sure it matters, but you have your arrow the wrong way. Try ">"
instead.

Jul 20 '05 #4

P: n/a
Paul Bramscher <br*************@tc.umn.edu> wrote:
Here's another trick question for you. What are you using to look at
the file with? I'm not sure how mySQL dumps out the characters -- but
it's possible they are correct and your editor is not displaying them
properly?


That was my thought too. Output may very well be unicode (UTF-8).
Looks really ugly if you don't have the proper reader. Then you will
see each , or as a set of two very odd non-ascii characters.
If that is the case, try to find an interface that supports unicode.

I am trying out a php based booking system for meeting rooms (mrbs) on
my Mac at work - first I had to turn off either unicode support or the
translation modules, since the build-in php module lacked the required
iconv support. Weekdays looked weird in Swedish browsers.

After a few weeks of testing I assembled some courage and installed
PHP5, then I re-enabled unicode support, and it looks fine now.

--
I recommend Macs to my friends, and Intel machines
to those whom I don't mind billing by the hour
Jul 20 '05 #5

P: n/a
Tim
Actually I thought about that to. I changed the character set in mysql
from utf8 to latin1 to.... Etc. And I'm using gvim for windows to look
with, it has latin1 as default character set. When changing from, say
latin1 to utf8 in my db, the output changes, but is always rubbish. If I
put in the database from my application, written in Qt, in the database
I see strange characters, when looking in my datatable in the application,
all is ok, if I put the from the 'mysql' client app, then all looks ok
from the query inside the 'mysql' but in the datatable, only rubbish.

I understand that there is a real big messup here with the character sets
from my side, but I'd like to understand what's happening. If I create a db
with CREATE DATABASE cazzo DEFAULT CHARACTER SET latin1, then all varchars
are latin1 or no? But why can I not see the swedish chars in my app, or in
a mysqldump? Neither if I use utf8. There is something I'm missing here.

Tim.

Asterix wrote:
Paul Bramscher <br*************@tc.umn.edu> wrote:
Here's another trick question for you. What are you using to look at
the file with? I'm not sure how mySQL dumps out the characters -- but
it's possible they are correct and your editor is not displaying them
properly?


That was my thought too. Output may very well be unicode (UTF-8).
Looks really ugly if you don't have the proper reader. Then you will
see each , or as a set of two very odd non-ascii characters.
If that is the case, try to find an interface that supports unicode.

I am trying out a php based booking system for meeting rooms (mrbs) on
my Mac at work - first I had to turn off either unicode support or the
translation modules, since the build-in php module lacked the required
iconv support. Weekdays looked weird in Swedish browsers.

After a few weeks of testing I assembled some courage and installed
PHP5, then I re-enabled unicode support, and it looks fine now.


Jul 20 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.