469,345 Members | 6,212 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,345 developers. It's quick & easy.

Database stops responding

Hello everyone

I'm having a little problem where my mysql 4.0.21 for some reason
stops "responding" until I do a flush-hosts. This is happening almost
every day.
It's a pretty heavy loaded server with at aprox 130 querys per second
(it might not be that loaded for some of you :) ).

I'm using the my-huge.cnf config, and allowing 350 max-connections.

Actually, here's the config:

[mysqld]
port = 4306
datadir = /usr/local/mysql-4/var
basedir = /usr/local/mysql-4
socket = /tmp/mysql-4.sock
skip-locking
set-variable = key_buffer=256M
set-variable = max_allowed_packet=1M
set-variable = table_cache=256
set-variable = sort_buffer=1M
set-variable = record_buffer=1M
set-variable = myisam_sort_buffer_size=64M
set-variable = thread_cache=8
set-variable = max_connections=666666
set-variable = max_user_connections=66666

# Try number of CPU's*2 for thread_concurrency
set-variable = thread_concurrency=8
log-bin
server-id = 1

[isamchk]
set-variable = key_buffer=128M
set-variable = sort_buffer=128M
set-variable = read_buffer=2M
set-variable = write_buffer=2M

[myisamchk]
set-variable = key_buffer=128M
set-variable = sort_buffer=128M
set-variable = read_buffer=2M
set-variable = write_buffer=2M

[mysqlhotcopy]
interactive-timeout

If anyone knows what could be done to stop having to use the
flush-hosts every day, I'd appreciate the hint.

Thanks!

Lior
Jul 20 '05 #1
0 1440

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

7 posts views Thread by mjkahn | last post: by
9 posts views Thread by Dan S | last post: by
4 posts views Thread by Michael | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
1 post views Thread by Marylou17 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.