469,921 Members | 2,176 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,921 developers. It's quick & easy.

"edit" doesn't use environment variable.

I've seen this question asked a couple times in this forum
but never answered, so I guess my hopes aren't too high,
but:

I'm running
mysql Ver 12.21 Distrib 4.0.14, for pc-linux (i686)
on Linux with Bash and according to the documentation,
edit (\e) Edit command with $EDITOR.


Although my $EDITOR is set to /usr/bin/vim, when I use the
edit or \e command, the editor is started as vi (in my case
it's still vim, but it gets started in vi-compatible mode,
which I don't like).

Is $EDITOR perhaps being sought in mysqld's environment
instead of mysql's? That doesn't seem like the right thing
to do, but if so, is there a workaround (that wouldn't
involve making everybody who uses this server use the same
editor)?

--
Aaron
Jul 20 '05 #1
1 2007
I wrote:
Although my $EDITOR is set to /usr/bin/vim, when I use the
edit or \e command, the editor is started as vi (in my
case it's still vim, but it gets started in vi-compatible
mode, which I don't like).


Oops! I had to wait until my post appeared before I could
reply to it, but I got some local help and this turned out
to have nothing to do with MySQL. Here's what was
happening: In my .bash_profile I was setting my editor:

EDITOR=/usr/bin/vim

but I was forgetting to export it:

export PATH

So I just changed the above line to

export PATH EDITOR

and now everything works as advertised in the MySQL manual.

Sorry for the bother!

--
Aaron
Jul 20 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Aarono Brown | last post: by
2 posts views Thread by Nalaka | last post: by
reply views Thread by Amil Hanish | last post: by
reply views Thread by Waqarahmed | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.