467,161 Members | 933 Online
Bytes | Developer Community
Ask Question

Home New Posts Topics Members FAQ

Post your question to a community of 467,161 developers. It's quick & easy.

Can't get init_connect='AUTOCOMMIT=0' to work

Hi all,

I've got MySQL 4.1.3 installed on RH 7.3... everything's fine so far
except for getting the init_connect string to work.

I followed the instructions on
http://dev.mysql.com/doc/mysql/en/Se...variables.html

and added the below line to my '/etc/my.cnf' file under [mysqld]:
init_connect='SET AUTOCOMMIT=0'

When I restart the server and start mysql, I can see that the
init_connect was read:
mysql> select @@init_connect;
+--------------------+
| @@init_connect |
+--------------------+
| SET AUTOCOMMIT=0 |
+--------------------+

However, the Autocommit variable is still 1!
mysql> select @@AUTOCOMMIT;
+-----------------+
| @@AUTOCOMMIT |
+-----------------+
| 1|
+-----------------+

Anyone seen this before or know what's wrong??

Thx in advance,
Scott.
Jul 20 '05 #1
  • viewed: 2215
Share:

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Scott Mills | last post: by
8 posts views Thread by Scorpio | last post: by
4 posts views Thread by Jm lists | last post: by
reply views Thread by Allen | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.