By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,939 Members | 1,600 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,939 IT Pros & Developers. It's quick & easy.

Upgrading to MySQL 4.0 from MySQL 3.23 - Problems with MySQL Client Install

P: n/a
I've attempted to upgrade to MySQL 3.23 to 4.0. MySQL 4.0 server is
working great, buy I couldn't get MySQL 4.0 client to install
properly. Any help would be greatly appreciated. Here are the steps
I followed:

1. Downloaded the server, client, and "Dynamic client libraries
(including 3.23.x libraries)" rpms.

2. rpm -Uvh --nodeps MySQL-server-4.0.20-0.i386.rpm

This worked great, and MySQL 4.0 server is running fine.

3. rpm -Uvh MySQL-shared-compat-4.0.20-0.i386.rpm

After this, I received the following errors:

Installing all prepared tables
040801 22:24:53 Warning: Asked for 196608 thread stack, but got
126976
040801 22:24:53 /usr/sbin/mysqld: Shutdown Complete

1 out of 1 hunk FAILED -- saving rejects to file
/usr/bin/safe_mysqld.rej
I didn't know what to do after this, so I went ahead and tried to
install the client.

4. rpm -Uvh MySQL-client-4.0.20-0.i386.rpm

warning: MySQL-client-4.0.20-0.i386.rpm: V3 DSA signature: NOKEY, key
ID 5072e1f5
Preparing... ########################################### [100%]
file /usr/bin/mysqladmin from install of MySQL-client-4.0.20-0
conflicts with file from package mysql-server-3.23.58-4
This is my first Linux install, so I will need detailed instructions
on how to fix this. Any help would really be appreciated. Thanks.
Jul 20 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Any help with this? Thanks.
Jul 20 '05 #2

P: n/a
On Fri, 06 Aug 2004 10:00:51 -0700, Shaun wrote:
Any help with this? Thanks.

Try uninstalling mysql 3.2 before installing 4.0
I have a graphical installer (mdkinstaller) and unfortunately don't
remember the commands for it..
Jul 20 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.