469,167 Members | 1,280 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,167 developers. It's quick & easy.

cant select more than 1000 records

Hi all
command "select * from table" whith 3000 records give me only 1000
rows
I can't figure out what is wrong. I think that something wrong is with
my my.cnf but can't find which varaible I have to change. Can you
sugest something?

[mysqld]
skip-locking
set-variable = max_user_connections=100
set-variable = max_connections=150
set-variable = key_buffer=128M
set-variable = join_buffer=4M
#set-variable = record_buffer=1M
set-variable = sort_buffer=5M
set-variable = table_cache=1024
set-variable = myisam_sort_buffer_size=32M
set-variable = thread_cache_size=128
set-variable = wait_timeout=45
set-variable = connect_timeout=10
set-variable = interactive_timeout=60
set-variable = max_allowed_packet=16M
set-variable = max_connect_errors=10
set-variable = flush_time=600
innodb_data_home_dir = /var/lib/mysql/
innodb_data_file_path = ibdata1:10M:autoextend
set-variable = innodb_additional_mem_pool_size=5M

[querycache]
#query_cache_limit = 1M
query_cache_size = 32M
query_cache_type = 1
thread_concurrency=4

[mysqldump]
quick
set-variable= max_allowed_packet=16M

[mysqlhotcopy]
interactive-timeout

[isamchk]
set-variable = key=16M
set-variable = key_buffer=20M
set-variable = sort_buffer=20M
set-variable = read_buffer=2M
set-variable = write_buffer=2M

[myisamchk]
set-variable = key_buffer=20M
set-variable = sort_buffer=20M
set-variable = read_buffer=2M
set-variable = write_buffer=2M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
safe-updates
Jul 20 '05 #1
1 3550
What interface are you using for retrieving data? Are you using mySQL
control center? In this case, you must edit the connection and set-up the
limit to "unlimited". By default, mySQLcc only retrieves 1000 records.

HPEter
<ba**@sonik.pl> wrote in message
news:a4*************************@posting.google.co m...
Hi all
command "select * from table" whith 3000 records give me only 1000
rows
I can't figure out what is wrong. I think that something wrong is with
my my.cnf but can't find which varaible I have to change. Can you
sugest something?

[mysqld]
skip-locking
set-variable = max_user_connections=100
set-variable = max_connections=150
set-variable = key_buffer=128M
set-variable = join_buffer=4M
#set-variable = record_buffer=1M
set-variable = sort_buffer=5M
set-variable = table_cache=1024
set-variable = myisam_sort_buffer_size=32M
set-variable = thread_cache_size=128
set-variable = wait_timeout=45
set-variable = connect_timeout=10
set-variable = interactive_timeout=60
set-variable = max_allowed_packet=16M
set-variable = max_connect_errors=10
set-variable = flush_time=600
innodb_data_home_dir = /var/lib/mysql/
innodb_data_file_path = ibdata1:10M:autoextend
set-variable = innodb_additional_mem_pool_size=5M

[querycache]
#query_cache_limit = 1M
query_cache_size = 32M
query_cache_type = 1
thread_concurrency=4

[mysqldump]
quick
set-variable= max_allowed_packet=16M

[mysqlhotcopy]
interactive-timeout

[isamchk]
set-variable = key=16M
set-variable = key_buffer=20M
set-variable = sort_buffer=20M
set-variable = read_buffer=2M
set-variable = write_buffer=2M

[myisamchk]
set-variable = key_buffer=20M
set-variable = sort_buffer=20M
set-variable = read_buffer=2M
set-variable = write_buffer=2M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
safe-updates

Jul 20 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

4 posts views Thread by Dave | last post: by
1 post views Thread by bart | last post: by
1 post views Thread by JJ | last post: by
1 post views Thread by nizam | last post: by
4 posts views Thread by Vincent | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.