471,073 Members | 1,362 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,073 software developers and data experts.

deamon fails to start in windows

I've experienced this a couple of times on different Windows
workstations and it's driving me crazy. I've installed mysql-4.0 from
the installer to c:\mysql. Then just for kicks I try to start it by
double clicking mysqld-nt.exe. It opens a window and hangs for about
15 seconds then closes. So i opened a command prompt and ran it, same
thing. I've discovered that if I put anything on the command line as
a parameter it will start. Also, installation as a service is failing
because it sets the service up to run "c:\mysqld-nt.exe MySQL" which
is the wrong location. I setup the my.cnf from those provided in the
install and it still doesn't work. I put garbage characters into the
my.cnf file to see if it was even reading it. It did nothing. BUT
then I ran it with "mysqld-nt.exe --" and it complained about the
screwed up conf file. If I remove the my.cnf file and run it with
"mysqld-nt.exe --", it works. So I can't do mysqld-nt.exe log-error"
because it works right then. Can I get logging without that
parameter? Any ideas PLEASE? It's freaking me out.
Jul 20 '05 #1
0 1301

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Troy | last post: by
14 posts views Thread by Jasonkimberson | last post: by
12 posts views Thread by keepyourstupidspam | last post: by
1 post views Thread by Sabine Dinis Blochberger | last post: by
2 posts views Thread by Roy | last post: by
3 posts views Thread by =?Utf-8?B?S2VuIExlbWlldXg=?= | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.