422,577 Members | 860 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 422,577 IT Pros & Developers. It's quick & easy.

mysql backup trouble

P: n/a
I am using mysql 4.0.14-standard on Redhat linux 9 and am having a
problem with backup using mysqldump. The .sql file is written OK,
however the program reports an error when attempting to write the .txt
file, i.e.

mysqldump: Got error: 1: Can't create/write to file '/......txt'
(Errcode: 13) when executing 'Select into outfile'.

This seems very odd, as I am running the program locally as mysql root
and the directory has write permission for mysql (and it can certainly
write something i.e. the .sql file) to it.

I have tried this with several different databases and none worked.
The mysql monitor command "backup table" also fails with a similar
error:

"failed copying .frm file".

I would be very grateful if anyone can suggest what might be the
problem here.

Cheers,

Steve.
Jul 20 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.