470,643 Members | 1,373 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,643 developers. It's quick & easy.

Apache2triad 1.2 - innoDB tables

Jan
I am using Apache2triad 1.2 as local development environment. It is
working fine, but I cannot create InnoDB tables with the phpMyAdmin
2.5.6 included in this package.

According to the my.ini file (see below) some lines in this file must
be commented or uncommented to use innoDB. If I do this, the mySQL
server does not start any more.

Thanks for your help
Jan

# Comment the following row if you want touse the InnoDb tables
skip-innodb

# Uncomment the following rows if you are using InnoDB tables
# Create the directories ibdata and iblogs before to start the server.
# If necessary, modify the size of the files

#innodb_log_group_home_dir = C:\apache2\mysql\iblogs
#innodb_data_file_path = ibdata1:200M
#innodb_data_home_dir = C:\apache2\mysql\ibdata
#innodb_flush_log_at_trx_commit=1
#innodb_log_arch_dir = C:\apache2\mysql\iblogs
#innodb_log_archive=0
#set-variable = innodb_mirrored_log_groups=1
#set-variable = innodb_log_files_in_group=3
#set-variable = innodb_log_file_size=30M
#set-variable = innodb_log_buffer_size=8M
#set-variable = innodb_buffer_pool_size=80M
#set-variable=lower_case_table_names =0
#set-variable = innodb_additional_mem_pool_size=10M
#set-variable = innodb_file_io_threads=4
#set-variable = innodb_lock_wait_timeout=50
Jul 20 '05 #1
2 2804
On 26 Apr 2004 10:14:48 -0700, Jan <wi***@hsu-hh.de> wrote:

The most common reason the server won't start is that the directories
iblogs and ibdata need to be created beforehand. They aren't
automatically created. If that's not the issue check the error
logs...they are usually pretty helpful.
I am using Apache2triad 1.2 as local development environment. It is
working fine, but I cannot create InnoDB tables with the phpMyAdmin
2.5.6 included in this package.

According to the my.ini file (see below) some lines in this file must
be commented or uncommented to use innoDB. If I do this, the mySQL
server does not start any more.

Thanks for your help
Jan

# Comment the following row if you want touse the InnoDb tables
skip-innodb

# Uncomment the following rows if you are using InnoDB tables
# Create the directories ibdata and iblogs before to start the server.
# If necessary, modify the size of the files

#innodb_log_group_home_dir = C:\apache2\mysql\iblogs
#innodb_data_file_path = ibdata1:200M
#innodb_data_home_dir = C:\apache2\mysql\ibdata
#innodb_flush_log_at_trx_commit=1
#innodb_log_arch_dir = C:\apache2\mysql\iblogs
#innodb_log_archive=0
#set-variable = innodb_mirrored_log_groups=1
#set-variable = innodb_log_files_in_group=3
#set-variable = innodb_log_file_size=30M
#set-variable = innodb_log_buffer_size=8M
#set-variable = innodb_buffer_pool_size=80M
#set-variable=lower_case_table_names =0
#set-variable = innodb_additional_mem_pool_size=10M
#set-variable = innodb_file_io_threads=4
#set-variable = innodb_lock_wait_timeout=50


Jul 20 '05 #2
On 26 Apr 2004 10:14:48 -0700, Jan <wi***@hsu-hh.de> wrote:

The most common reason the server won't start is that the directories
iblogs and ibdata need to be created beforehand. They aren't
automatically created. If that's not the issue check the error
logs...they are usually pretty helpful.
I am using Apache2triad 1.2 as local development environment. It is
working fine, but I cannot create InnoDB tables with the phpMyAdmin
2.5.6 included in this package.

According to the my.ini file (see below) some lines in this file must
be commented or uncommented to use innoDB. If I do this, the mySQL
server does not start any more.

Thanks for your help
Jan

# Comment the following row if you want touse the InnoDb tables
skip-innodb

# Uncomment the following rows if you are using InnoDB tables
# Create the directories ibdata and iblogs before to start the server.
# If necessary, modify the size of the files

#innodb_log_group_home_dir = C:\apache2\mysql\iblogs
#innodb_data_file_path = ibdata1:200M
#innodb_data_home_dir = C:\apache2\mysql\ibdata
#innodb_flush_log_at_trx_commit=1
#innodb_log_arch_dir = C:\apache2\mysql\iblogs
#innodb_log_archive=0
#set-variable = innodb_mirrored_log_groups=1
#set-variable = innodb_log_files_in_group=3
#set-variable = innodb_log_file_size=30M
#set-variable = innodb_log_buffer_size=8M
#set-variable = innodb_buffer_pool_size=80M
#set-variable=lower_case_table_names =0
#set-variable = innodb_additional_mem_pool_size=10M
#set-variable = innodb_file_io_threads=4
#set-variable = innodb_lock_wait_timeout=50


Jul 20 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Lazy70 | last post: by
3 posts views Thread by Martin Gill | last post: by
3 posts views Thread by Andy Tran | last post: by
reply views Thread by Mike Chirico | last post: by
3 posts views Thread by Reuben Pearse | last post: by
1 post views Thread by Korara | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.