470,631 Members | 1,557 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,631 developers. It's quick & easy.

MySQL Behaving Badly - kind of involved

I am a relative newbie to MySQL. I had a Postfix+Courier+MySQL mail
server running for several months. It took me a week or so to get it up
and running in September. Now, I did a clean upgrade to Mandrake 9.2
and am reinstalling everything. MySQL is kicking my ass and I can't
seem to get past it to install everything else.

I have it installed and I can start the server through Webmin, but the
process runs away -- I get a series of instances of mysqld in the
process tables that take turns spawning and dying, and constantly soak
up processor cycles thrashing around. It's very hard to kill this
process. I have to execute "/usr/sbin/mysqld stop" repeatedly and
rapidly at the command line as root to shut it down.

If I start the server at the command line as root with "mysqld_safe
--skip-grant-tables &" I get a polite set of 3 instances of mysql and
one mysqld. They appear to function normally, but webmin reports that
mysql server is not running and it can't start it -- reports no error,
just that it isn't running and database list can not be retrieved.

Stopping this server is also next to impossible. When I issue "mysqld
stop" at the command line (root or user) I get:

[madams@adamsmdk init.d]$ /usr/sbin/mysqld stop
040101 22:22:41 Can't start server: Bind on TCP/IP port: Address
already in use
040101 22:22:41 Do you already have another mysqld server running on
port: 3306 ?
040101 22:22:41 Aborting

040101 22:22:41 /usr/sbin/mysqld: Shutdown Complete

This does not alter the process in the proc. table:

[madams@adamsmdk init.d]$ ps -aux|grep mysql
Warning: bad syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
root 24677 0.0 0.2 2456 1256 pts/4 S 22:13 0:00 /bin/sh
/usr/bin/mysqld_safe --skip-grant-tables
mysql 24693 0.0 0.5 13600 2624 pts/4 S 22:13 0:00
/usr/sbin/mysqld --basedir=/ --datadir=/var/lib/mysql --user=mysql
--pid-file=/var/lib/mysql/adamsmdk.pid --skip-locking --skip-grant-tables
mysql 24694 0.0 0.5 13600 2624 pts/4 S 22:13 0:00
/usr/sbin/mysqld --basedir=/ --datadir=/var/lib/mysql --user=mysql
--pid-file=/var/lib/mysql/adamsmdk.pid --skip-locking --skip-grant-tables
mysql 24695 0.0 0.5 13600 2624 pts/4 S 22:13 0:00
/usr/sbin/mysqld --basedir=/ --datadir=/var/lib/mysql --user=mysql
--pid-file=/var/lib/mysql/adamsmdk.pid --skip-locking --skip-grant-tables
madams 24823 0.0 0.1 1828 608 pts/0 R 22:25 0:00 grep mysql

"Killing" the process as root also has no effect. In fact, I don't know
how to stop this thing.

I tried mysql_fix_privilege_tables --password=root_password and thought
that fixed it. But it did not. I uninstalled and reinstalled it -- no
change.

And once I get this mess ironed out, I need to figure out how to grant
privileges to the postfix user so I can get on with that.

Does anybody have a clue about this?

Thanks.

Mark

Jul 19 '05 #1
0 1011

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

3 posts views Thread by Zaphod Beeblebrox | last post: by
5 posts views Thread by apchar | last post: by
20 posts views Thread by Sims | last post: by
8 posts views Thread by Tony Clarke | last post: by
reply views Thread by Mark Adams | last post: by
10 posts views Thread by Garmt de Vries | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.