469,167 Members | 1,334 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,167 developers. It's quick & easy.

MySQL Permissions

I have installed mysql (under SuSE 8.1) and everything seems to work
fine when I am logged in as root. However, with my normal user profile
I can get a mysql> prompt but have no permissions to carry out any
database operations.

I would really like to work with my normal profile and am hoping that it
is merely a question of setting permissions correctly. Can anyone tell
me which files and paths I should check (and change)?

Ideally, I would like mysql to create and manage the database files in
my normal /home directory (rather than in the mysql directories). Is
this possible? Is this desirable? Which settings would I need to
change to allow this? Or should I just let mysql create the databases
in it's default directory and set the permissions there?

Any tips would be gatefully received.

Regards,
Alan Searle

Jul 19 '05 #1
4 15367
Alan Searle wrote:
I have installed mysql (under SuSE 8.1) and everything seems to work
fine when I am logged in as root. However, with my normal user profile
I can get a mysql> prompt but have no permissions to carry out any
database operations.


As a root user, create a database and give permissions to the user:

GRANT ALL ON database.* TO user@localhost IDENTIFIED BY "password";

http://www.mysql.com/doc/en/GRANT.html

Jul 19 '05 #2
Alan Searle wrote:
I have installed mysql (under SuSE 8.1) and everything seems to work
fine when I am logged in as root. However, with my normal user profile
I can get a mysql> prompt but have no permissions to carry out any
database operations.


As a root user, create a database and give permissions to the user:

GRANT ALL ON database.* TO user@localhost IDENTIFIED BY "password";

http://www.mysql.com/doc/en/GRANT.html

Jul 19 '05 #3
Excellent.

This looks like the syntax that I need.

I'll check the document pages too.

Thanks,
Alan.

Aggro wrote:
Alan Searle wrote:
I have installed mysql (under SuSE 8.1) and everything seems to work
fine when I am logged in as root. However, with my normal user profile
I can get a mysql> prompt but have no permissions to carry out any
database operations.

As a root user, create a database and give permissions to the user:

GRANT ALL ON database.* TO user@localhost IDENTIFIED BY "password";

http://www.mysql.com/doc/en/GRANT.html

Jul 19 '05 #4
Excellent.

This looks like the syntax that I need.

I'll check the document pages too.

Thanks,
Alan.

Aggro wrote:
Alan Searle wrote:
I have installed mysql (under SuSE 8.1) and everything seems to work
fine when I am logged in as root. However, with my normal user profile
I can get a mysql> prompt but have no permissions to carry out any
database operations.

As a root user, create a database and give permissions to the user:

GRANT ALL ON database.* TO user@localhost IDENTIFIED BY "password";

http://www.mysql.com/doc/en/GRANT.html

Jul 19 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by j-marvin | last post: by
reply views Thread by flubdgub | last post: by
reply views Thread by Alan Searle | last post: by
4 posts views Thread by Manzoorul Hassan | last post: by
1 post views Thread by www.douglassdavis.com | last post: by
2 posts views Thread by KaHuNa | last post: by
4 posts views Thread by Robert Blackwell | last post: by
6 posts views Thread by Bob Sanderson | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
1 post views Thread by Mortomer39 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.