469,148 Members | 1,539 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,148 developers. It's quick & easy.

GLIBC_2.3.2' not found ????

Well I figured out that I cant connect to the mysql.sock file because the
server isnt actually running.
I chmoded the rc.mysqld file in /etc/rc.d to make it executable.
It says to do that if you want mysql to start at bootup.
Well it does'nt and when I try to run it manually this is the error I get.
bash-2.05b# ./rc.mysqld start
bash-2.05b# /usr/bin/my_print_defaults: /lib/libpthread.so.0: version `GLIBC_2.3
..2' not found (required by /usr/bin/my_print_defaults)
Starting mysqld daemon with databases from /var/lib/mysql
031115 14:03:35 mysqld ended
please help...
Thanks,
David
Jul 19 '05 #1
2 4468

"blizeach" <bl******@Slacker.blizeach.org> wrote in message
news:pa***************************@Slacker.blizeac h.org...
Well I figured out that I cant connect to the mysql.sock file because the
server isnt actually running.
I chmoded the rc.mysqld file in /etc/rc.d to make it executable.
It says to do that if you want mysql to start at bootup.
Well it does'nt and when I try to run it manually this is the error I get.
bash-2.05b# ./rc.mysqld start
bash-2.05b# /usr/bin/my_print_defaults: /lib/libpthread.so.0: version `GLIBC_2.3 .2' not found (required by /usr/bin/my_print_defaults)
Starting mysqld daemon with databases from /var/lib/mysql
031115 14:03:35 mysqld ended


try (as root):
cd to actual location of your mysql installation (ie /usr/local/mysql)
Then enter the following - where mysqluser is the user account you set up to
run the server

# bin/safe_mysqld --user=mysqluser &

this should get the server running
Jul 19 '05 #2

"blizeach" <bl******@Slacker.blizeach.org> wrote in message
news:pa***************************@Slacker.blizeac h.org...
Well I figured out that I cant connect to the mysql.sock file because the
server isnt actually running.
I chmoded the rc.mysqld file in /etc/rc.d to make it executable.
It says to do that if you want mysql to start at bootup.
Well it does'nt and when I try to run it manually this is the error I get.
bash-2.05b# ./rc.mysqld start
bash-2.05b# /usr/bin/my_print_defaults: /lib/libpthread.so.0: version `GLIBC_2.3 .2' not found (required by /usr/bin/my_print_defaults)
Starting mysqld daemon with databases from /var/lib/mysql
031115 14:03:35 mysqld ended


try (as root):
cd to actual location of your mysql installation (ie /usr/local/mysql)
Then enter the following - where mysqluser is the user account you set up to
run the server

# bin/safe_mysqld --user=mysqluser &

this should get the server running
Jul 19 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by John Houston | last post: by
reply views Thread by blizeach | last post: by
14 posts views Thread by NormD | last post: by
1 post views Thread by CARIGAR | last post: by
1 post views Thread by Mortomer39 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.