469,267 Members | 1,643 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,267 developers. It's quick & easy.

First time user nothing happening

This is the first time I've tried to use mysql/phpmyadmin and I'm having trouble. I'm using a geocites pro account and I got both installed and it set up a database call mysql and the user yroot. It asked me to make my own user name, which I did, and had me create a password as well. When I went into phpMyadmin I was able to create a new database but I cant really do anything with it. When I go into privileges I get this warning:

Warning: Your privilege table structure seem to be older than this MySQL version!
Please run the script mysql_fix_privilege_tables that should be included in your MySQL server distribution to solve this problem!

Also the user that I set up for myself I think has limited access because it says: Global privileges: Usage Grant: No

Whenever I try and change anything in the privileges it gives me this message: #1044 - Access denied for user 'majestic15'@'localhost' to database 'mysql'

I've tried creating a new user and I can't. I also can't delete my current one because access is denied. I tried running mysql_fix_privilege_tables through a query window along with several variations of the code I found on some forums pertaining to this problem but when I hit go nothing happens. The page just sits there and nothing loads.

I'm not trying to do anything to crazy here, I just wanted to set up a tool called WordPress. This is their install page linked to the step I was at: http://codex.wordpress.org/Installing_WordPress#Step_2:_Create_the_Database_a nd_a_User

So I am completely at a loss. If any one can help please do!

I am running MySQL 4.1.14 with phpMyAdmin 2.6.3-pl1 through my yahoo.geocities account.

Also one more thing, I don't know if this means anything but when I go into the phpmyadmin dir on geocities and click index.php 2 frames. The top is blue and says my domain name and has a link to the Control Panel. The frame underneath of it is completely blank. I need to go back to the directory and open main.php(im assuming this is the page that is supposed to load in that blank frame), I need to open main.php to do anything. I've tried deleting and re-installing phpMyadmin a couple times, nothing seems to work.
Sep 22 '07 #1
2 2043
I did figure out the last part about the frames was due to firefox. For some reason it doesn't run properly in that browser so I'm using internet explorer now. I think my problem is just that I can't access the root to change my privileges. Yahoo didn't give me a password for the root when I started and the user they gave me can't do squat. I emailed them requesting the password or to reset the database.
Sep 23 '07 #2
pbmods
5,821 Expert 4TB
Heya, Majestic. Welcome to TSDN!

Your account is probably located on a shared server, which is why they won't give you root access.

I would get in contact with Yahoo's support team and find out what's going on (which is what it sounds like you already did), because it sounds like the problem is on their end.
Sep 23 '07 #3

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

19 posts views Thread by DotNetIsHorrible | last post: by
8 posts views Thread by Robert Gravereaux | last post: by
6 posts views Thread by =?Utf-8?B?cmFuZHkxMjAw?= | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.