472,782 Members | 1,332 Online
Bytes | Software Development & Data Engineering Community
Post Job

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 472,782 software developers and data experts.

MySQL Installation Challenges

SEND-PR: -*- send-pr -*-
SEND-PR: Lines starting with `SEND-PR' will be removed automatically, as
SEND-PR: will all comments (text enclosed in `<' and `>').
From: moyc
To: my***@lists.mysql.com
Subject: Installation challenges - mysqld
<I've never installed MySql before and I am having a little trouble with
the installation procedure. I have installed the binaries as described
in the manual for installation and I am able to start mysql through

$mysqld_safe --user mysql &
[root@laptop mysql]# Starting mysqld daemon with databases from
030812 13:24:04 mysqld ended

but you can see that the deamon has "ended" right away. This should not
happen, correct?

Then I go to connect to the server (locally) by entering in a mysqladmin
command to check the version and the output is below:

bin/mysqladmin: connect to server at 'localhost' failed
error: 'Can't connect to local MySQL server through socket
'/tmp/mysql.sock' (2)'
Check that mysqld is running and that the socket: '/tmp/mysql.sock'

It does not seem like the deamon is running at all when I go to check
(ps -aux | grep mysql). Any ideas. I am a little new to MySql.

Note: I have tried the latest version of MySQL and still get the same
problems but on a diff computer running the same OS (Linux RH 9.0)>
Fix: <how to correct or work around the problem, if known (multiple lines)>
Submitter-Id: <submitter ID>
Originator: Chris Moy
Organization: <organization of PR author (multiple lines)>MySQL support: [none]
Synopsis: <synopsis of the problem (one line)>
Severity: <non-critical>
Priority: <medium>
Category: mysql
Class: <support>
Release: mysql-3.23.54 (Source distribution) Environment:

<Linux Redhat 9.0>
System: Linux bioserver 2.4.20-18.9 #1 Thu May 29 07:08:16 EDT 2003 i686
i686 i386 GNU/Linux
Architecture: i686

Some paths: /usr/local/bin/perl /usr/bin/make /usr/bin/gmake
/usr/bin/gcc /usr/bin/cc
GCC: Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/3.2.2/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --enable-shared --enable-threads=posix
--disable-checking --with-system-zlib --enable-__cxa_atexit
Thread model: posix
gcc version 3.2.2 20030222 (Red Hat Linux 3.2.2-5)
Compilation info: CC='i386-redhat-linux-gcc' CFLAGS='-O2 -march=i386
CXX='i386-redhat-linux-g++' CXXFLAGS='-O2 -march=i386 -mcpu=i686 -g
-fno-exceptions' LDFLAGS=''
lrwxrwxrwx 1 root root 13 May 27 07:49 /lib/libc.so.6
-> libc-2.3.2.so
-rwxr-xr-x 1 root root 1549556 Mar 13 19:43
-rw-r--r-- 1 root root 2321376 Mar 13 18:35 /usr/lib/libc.a
-rw-r--r-- 1 root root 204 Mar 13 17:58 /usr/lib/libc.so
lrwxrwxrwx 1 root root 10 May 27 08:36
/usr/lib/libc-client.a -> c-client.a
Configure command: ./configure '--host=i386-redhat-linux'
'--build=i386-redhat-linux' '--target=i386-redhat-linux-gnu'
'--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr'
'--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc'
'--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib'
'--libexecdir=/usr/libexec' '--localstatedir=/var'
'--sharedstatedir=/usr/com' '--mandir=/usr/share/man'
'--infodir=/usr/share/info' '--without-readline' '--without-debug'
'--enable-shared' '--with-extra-charsets=complex' '--with-bench'
'--with-mysqld-user=mysql' '--with-extra-charsets=all' '--with-innodb'
'--enable-local-infile' '--enable-large-files=yes'
'--enable-largefile=yes' '--with-berkeley-db-includes=/usr/include'
'--with-berkeley-db-libs=/usr/lib' '--enable-thread-safe-client'
'CFLAGS=-O2 -march=i386 -mcpu=i686 -g -D_GNU_SOURCE
-fno-rtti -fno-exceptions' 'build_alias=i386-redhat-linux'
'host_alias=i386-redhat-linux' 'target_alias=i386-redhat-linux-gnu'

MySQL General Mailing List
For list archives: http://lists.mysql.com/mysql
To unsubscribe: http://lists.mysql.com/my***********...ie.nctu.edu.tw

Jul 19 '05 #1
0 2120

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

by: Aditya Ivaturi | last post by:
We have a CMS which is written is based on php & mysql. Recently we received a request to support multiple languages so that sites in that particular laguage can be created. I did some search on...
by: Chris Moy | last post by:
SEND-PR: -*- send-pr -*- SEND-PR: Lines starting with `SEND-PR' will be removed automatically, as SEND-PR: will all comments (text enclosed in `<' and `>'). SEND-PR: From: moyc To:...
by: MLH | last post by:
I am having failures processing the following command and I wonder if you can tell me what I must do in order to have success. When I try to run source mysql_dump.sql.txt ==> it is a problem...
by: Murphy | last post by:
I am currently migrating a db from SQL Server & MySQL and ? (front end yet to be decided upon) As I familiarise myself with MySQL populating tables etc can be quite clumbersome. After reading the...
by: Good Man | last post by:
Hi there I've noticed some very weird things happening with my current MySQL setup on my XP Laptop, a development machine. For a while, I have been trying to get the MySQL cache to work....
by: jrs_14618 | last post by:
Hello All, This post is essentially a reply a previous post/thread here on this mailing.database.myodbc group titled: MySQL 4.0, FULL-TEXT Indexing and Search Arabic Data, Unicode I was...
by: alf | last post by:
Hi, is it possible that due to OS crash or mysql itself crash or some e.g. SCSI failure to lose all the data stored in the table (let's say million of 1KB rows). In other words what is the worst...
by: Robin S. | last post by:
I've used phpinfo() to confirm settings for mySQL on our host server, and it's not returning accurate info. phpinfo() returns a mySQL client API version of 3.23.54 (uselss for me), where as a...
by: ssnaik84 | last post by:
Hi Guys, Last year I got a chance to work with R&D team, which was working on DB scripts conversion.. Though there is migration tool available, it converts only tables and constraints.. Rest of...
by: isladogs | last post by:
The next Access Europe meeting will be on Wednesday 2 August 2023 starting at 18:00 UK time (6PM UTC+1) and finishing at about 19:15 (7.15PM) The start time is equivalent to 19:00 (7PM) in Central...
by: erikbower65 | last post by:
Using CodiumAI's pr-agent is simple and powerful. Follow these steps: 1. Install CodiumAI CLI: Ensure Node.js is installed, then run 'npm install -g codiumai' in the terminal. 2. Connect to...
by: erikbower65 | last post by:
Here's a concise step-by-step guide for manually installing IntelliJ IDEA: 1. Download: Visit the official JetBrains website and download the IntelliJ IDEA Community or Ultimate edition based on...
by: kcodez | last post by:
As a H5 game development enthusiast, I recently wrote a very interesting little game - Toy Claw ((http://claw.kjeek.com/))。Here I will summarize and share the development experience here, and hope it...
by: DJRhino1175 | last post by:
When I run this code I get an error, its Run-time error# 424 Object required...This is my first attempt at doing something like this. I test the entire code and it worked until I added this - If...
by: DJRhino | last post by:
Private Sub CboDrawingID_BeforeUpdate(Cancel As Integer) If = 310029923 Or 310030138 Or 310030152 Or 310030346 Or 310030348 Or _ 310030356 Or 310030359 Or 310030362 Or...
by: lllomh | last post by:
Define the method first this.state = { buttonBackgroundColor: 'green', isBlinking: false, // A new status is added to identify whether the button is blinking or not } autoStart=()=>{
by: Mushico | last post by:
How to calculate date of retirement from date of birth
by: DJRhino | last post by:
Was curious if anyone else was having this same issue or not.... I was just Up/Down graded to windows 11 and now my access combo boxes are not acting right. With win 10 I could start typing...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.