By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,417 Members | 1,825 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,417 IT Pros & Developers. It's quick & easy.

Enable Unicode in MySQL 4.1.0-alpha

P: n/a
Hi,

I have read that Unicode (UTF-8) was not enabled by default in the
mysql-4.1.0-alpha binaries. How can I enable it? What should I change in the
code to do so?

Thanks

Vincent

Jul 19 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
you have to compile the code yourself, but thankfully not change anything.
here's my install checklist (for linux):

a.. download mysql-4.1.0-alpha.tar.gz
a.. tar zxvf mysql-4.1.0-alpha.tar.gz
a.. cd mysql-4.1.0-alpha
a.. CFLAGS="-O3 -mcpu=pentiumpro" CXX=gcc
CXXFLAGS="-O3 -mcpu=pentiumpro -felide-constructors -fno-exceptions -fno-rtt
i"
../configure --prefix=/usr/local/mysql --with-charset=utf8 --enable-thread-sa
fe-client --enable-local-infile --enable-assembler --disable-shared
a.. make
a.. su
a.. make install
a.. ./scripts/mysql_install_db
a.. chown -R root /usr/local/mysql
a.. chown -R mysql /usr/local/mysql/var
a.. chgrp -R mysql /usr/local/mysql
a.. /usr/local/mysql/bin/mysqld_safe --user=root &
a.. exit

naturally, you should also change the root password, set it up for running
automatically, etc., etc., but this should get unicode working.

cheers!
daniel
"Vincent Bouret" <vb*****@iquebec.com> wrote in message
news:1S*******************@wagner.videotron.net...
Hi,

I have read that Unicode (UTF-8) was not enabled by default in the
mysql-4.1.0-alpha binaries. How can I enable it? What should I change in the code to do so?

Thanks

Vincent

Jul 19 '05 #2

P: n/a
you have to compile the code yourself, but thankfully not change anything.
here's my install checklist (for linux):

a.. download mysql-4.1.0-alpha.tar.gz
a.. tar zxvf mysql-4.1.0-alpha.tar.gz
a.. cd mysql-4.1.0-alpha
a.. CFLAGS="-O3 -mcpu=pentiumpro" CXX=gcc
CXXFLAGS="-O3 -mcpu=pentiumpro -felide-constructors -fno-exceptions -fno-rtt
i"
../configure --prefix=/usr/local/mysql --with-charset=utf8 --enable-thread-sa
fe-client --enable-local-infile --enable-assembler --disable-shared
a.. make
a.. su
a.. make install
a.. ./scripts/mysql_install_db
a.. chown -R root /usr/local/mysql
a.. chown -R mysql /usr/local/mysql/var
a.. chgrp -R mysql /usr/local/mysql
a.. /usr/local/mysql/bin/mysqld_safe --user=root &
a.. exit

naturally, you should also change the root password, set it up for running
automatically, etc., etc., but this should get unicode working.

cheers!
daniel
"Vincent Bouret" <vb*****@iquebec.com> wrote in message
news:1S*******************@wagner.videotron.net...
Hi,

I have read that Unicode (UTF-8) was not enabled by default in the
mysql-4.1.0-alpha binaries. How can I enable it? What should I change in the code to do so?

Thanks

Vincent

Jul 19 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.