469,336 Members | 6,192 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,336 developers. It's quick & easy.

passwords & DBI/DBD

I installed the current stable release of MySQL from RPMs. I used the client
and server packages.

After installing the server package, the RPM printed a note saying I should
run two commands. I only got the first one, which was
# ./mysqladmin -u root --password
I assume this gave the root user a password.

I then downloaded and proceeded to compile the Perl DBI and DBD:mysql
packages. The DBI package installed fine after I also installed the
"MySQL-devel" RPM.

However, the DBD compile/install failed when I ran 'make test'. The output
looked like this:

=============
Mysql connect('database=test;host=','',...) failed: Access denied for user:
'root@localhost' (Using password: NO) at t/mysql.t line 55
not ok 1: Access denied for user: 'root@localhost' (Using password: NO)
It looks as if your server is not up and running.
This test requires a running server.
Please make sure your server is running and retry.
t/mysql.............FAILED tests 1-68
Failed 68/68 tests, 0.00% okay
Failed Test Status Wstat Total Fail Failed List of Failed
----------------------------------------------------------------------------
----
t/10dsnlist.t 10 2560 9 9 100.00% 1-9
t/20createdrop.t 10 2560 5 5 100.00% 1-5
t/30insertfetch.t 10 2560 11 11 100.00% 1-11
t/40bindparam.t 10 2560 28 28 100.00% 1-28
t/40blobs.t 10 2560 11 11 100.00% 1-11
t/40listfields.t 10 2560 16 16 100.00% 1-16
t/40nulls.t 10 2560 11 11 100.00% 1-11
t/40numrows.t 10 2560 25 25 100.00% 1-25
t/50chopblanks.t 10 2560 35 35 100.00% 1-35
t/50commit.t 255 65280 30 30 100.00% 1-30
t/ak-dbd.t 255 65280 90 88 97.78% 1, 4-90
t/akmisc.t 10 2560 351 351 100.00% 1-351
t/dbdadmin.t 10 2560 21 21 100.00% 1-21
t/insertid.t 255 65280 12 12 100.00% 1-12
t/mysql.t 68 68 100.00% 1-68
t/mysql2.t 255 65280 ?? ?? % ??
1 test skipped.
Failed 16/18 test scripts, 11.11% okay. 721/728 subtests failed, 0.96% okay.
make: *** [test_dynamic] Error 29
==================================================

I also noticed that whenever I do anything with the mysqladmin program, I
always have to give the '-p' option and then enter my password for anything
to work.

So, what do I need to do to get 'make test' to work? Do I need to remove the
password somehow, or give some extra options with make? (I'm a complete
newbie to MySQL and DB administration)

Thanks in advance.

Regards,
Jeremy

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Jeremy Booker - Owner / Webmaster
JTech Web Systems
www.JTechWebSystems.com
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
"Therefore do not worry about tomorrow, for tomorrow will worry about
itself. Each day has enough trouble of its own." -Mathew 5:34
--
MySQL General Mailing List
For list archives: http://lists.mysql.com/mysql
To unsubscribe: http://lists.mysql.com/my***********...ie.nctu.edu.tw

Jul 19 '05 #1
0 1696

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

11 posts views Thread by Florian Lindner | last post: by
1 post views Thread by Shapper | last post: by
15 posts views Thread by Dino Vliet | last post: by
3 posts views Thread by Jeremy Deuel | last post: by
5 posts views Thread by Macca | last post: by
19 posts views Thread by Cord-Heinrich Pahlmann | last post: by
2 posts views Thread by Simon.Whiteside | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
reply views Thread by Marylou17 | last post: by
1 post views Thread by Marylou17 | last post: by
1 post views Thread by Marylou17 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.