469,625 Members | 1,094 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,625 developers. It's quick & easy.

need help: cannot connect on localhost (10061)

hey, i'm new to mySQL...this meaning that i have tried ~10000 times to
install it and get it working over the past few weeks...and it always gives
me the same error (scroll further down to see it) despite following the
manual's windows installation exactly

i have version 4.0.13 for windows and i used the installer

once i was done, i followed the instructions in the manual exactly

i have no firewall running

i am on windows XP

i am running the client and server on the same computer

i ran winmysqladmin and it starts up fine

the 'mysqld-nt' service is in my processes tab of task manager

i go to dos prompt and type net start and mysql is there running fine

however, when in c:\mysql\bin
and i run 'mySQL' i get this error:
ERROR 2003: Can't connect to MySQL server on 'localhost' (10061)

i have tried devshed, mysql help, etc. and cannot figure out why mine
doesn't work...it seems most people just reboot and it voile! works... but
i've rebooted over and over and over, and nothing changes...same error...

when i use mySQL Control Center v0.9.2-beta i get the same error when i
click Action->Connect

all i can say is ARGH!

all i can ask is "does anyone have any idea why this happens? or how to stop
it?"

i can telnet to port 3306, and get this readout (i have no idea how really
to use telnet...)

------------
c:\telnet localhost 3306

*
4.0.13-nt☺;7@yceRJ,☻ ►☺♦Bad handshake

Connection to host lost. (this when i press backspace, so i understand you
don't do that in telnet...)
i guess it is getting to mySQL, cuz the 4.0.13 at the beginning is my
version of mySQL
------------

i'll paste my my.ini (which is in c:\windows)

thanks so much,
\Kyle, who has been frustrated for a while now...

--beginning of my.ini

#This File was made using the WinMySQLAdmin 1.4 Tool
#7/18/2003 3:06:59 PM

#Uncomment or Add only the keys that you know how works.
#Read the MySQL Manual for instructions

[mysqld]
basedir=C:/mysql
#bind-address=127.0.0.1
datadir=C:/mysql/data
#language=C:/mysql/share/your language directory
#slow query log#=
#tmpdir#=
#port=3306
#set-variable=key_buffer=16M
[WinMySQLadmin]
Server=C:/mysql/bin/mysqld-nt.exe
user=sakurak
password=sfzero2

--end of my.ini
--
MySQL General Mailing List
For list archives: http://lists.mysql.com/mysql
To unsubscribe: http://lists.mysql.com/my***********...ie.nctu.edu.tw

Jul 19 '05 #1
0 8061

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

20 posts views Thread by Mr Dygi | last post: by
2 posts views Thread by pieter_hordijk | last post: by
reply views Thread by Ryan Stewart | last post: by
reply views Thread by gheharukoh7 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.