469,904 Members | 2,557 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,904 developers. It's quick & easy.

MySQL Syntax Error while installing DZCP

Hi,
I hope you can help me. As I try to install Devil'z Clanportal, i only recieve this error message:

Expand|Select|Wrap|Line Numbers
  1. MySQL-Query failed:
  2.  
  3.  
  4. ErrorNo = 1064
  5. Error = You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '2', `reg_forum` int(1) NOT NULL default '0', `reg_cw' at line 3
  6. Query = CREATE TABLE dzcp_settings ( `clanname` varchar(50) NOT NULL default 'Dein Clanname hier!', `pfad` varchar(50) NOT NULL default '\', `balken_vote` varchar(3) NOT NULL default '2', `reg_forum` int(1) NOT NULL default '0', `reg_cwcomments` int(1) NOT NULL default '0', `counter_start` int(10) NOT NULL default '0', `balken_vote_menu` varchar(3) NOT NULL default '0.9', `balken_cw` varchar(3) NOT NULL default '2.4', `reg_dl` int(1) NOT NULL default '0', `reg_artikel` int(1) NOT NULL default '0', `reg_newscomments` int(1) NOT NULL default '0', `tmpdir` varchar(100) NOT NULL default 'modern', `wmodus` int(1) NOT NULL default '0', `persinfo` int(1) NOT NULL default '1', `iban` varchar(100) NOT NULL default '', `bic` varchar(100) NOT NULL default '', `badwords` text NOT NULL, `pagetitel` varchar(50) NOT NULL default 'Dein Seitentitel hier!', `last_backup` int(20) NOT NULL default '0', `squadtmpl` int(1) NOT NULL default '1', `i_domain` varchar(50) NOT NULL default 'www.deineUrl.de', `i_autor` varchar(249) NOT NULL default 'Max Mustermann', `k_nr` varchar(100) NOT NULL default '123456789', `k_inhaber` varchar(50) NOT NULL default 'Max Mustermann', `k_blz` varchar(100) NOT NULL default '123456789', `k_bank` varchar(200) NOT NULL default 'Musterbank', `k_waehrung` varchar(15) NOT NULL default '', `ftp_host` varchar(100) NOT NULL default '', `ftp_login` varchar(100) NOT NULL default '', `ftp_pwd` varchar(100) NOT NULL default '', `language` varchar(50) NOT NULL default 'deutsch', `domain` varchar(200) NOT NULL default 'active2clan.de', `gametiger` varchar(20) NOT NULL default 'cstrike', `regcode` int(1) NOT NULL default '1', `ts_ip` varchar(200) NOT NULL default '', `mailfrom` varchar(200) NOT NULL default 'support@active2clan.de', `ts_port` int(10) NOT NULL default '0', `ts_sport` int(10) NOT NULL default '0', `ts_width` int(10) NOT NULL default '0', `bl_path` varchar(249) NOT NULL default '' ) TYPE=MyISAM
  7.  
thanks a lot for your help
Jun 15 '07 #1
3 133074
Atli
5,058 Expert 4TB
Hi, and welcome to TSDN.

The error is telling you that there is a problem with your CREATE TABLE query. The weird thing is that the query you gave us seemes to be ok.

If you have the code that creates this, please show us the part that generates the error and we will do our best to help you to fix it.

If you didn't write the code yoursef you might want to contact the one who did and ask him about it.
Jun 15 '07 #2
I do not know if this is, what you mean, but have a look at it

Expand|Select|Wrap|Line Numbers
  1. $httphost = $_SERVER['HTTP_HOST'];
  2.   $host = str_replace('www.','',$httphost); 
  3.   $qry = db("DROP TABLE IF EXISTS ".$db['settings']."");
  4.   $qry = db("CREATE TABLE ".$db['settings']." (
  5.              `clanname` varchar(50) NOT NULL default 'Dein Clanname hier!',
  6.              `pfad` varchar(50) NOT NULL default '".$pfad."',
  7.              `balken_vote` varchar(3) NOT NULL default '2',
  8.              `reg_forum` int(1) NOT NULL default '0',
  9.              `reg_cwcomments` int(1) NOT NULL default '0',
  10.              `counter_start` int(10) NOT NULL default '0',
  11.              `balken_vote_menu` varchar(3) NOT NULL default '0.9',
  12.              `balken_cw` varchar(3) NOT NULL default '2.4',
  13.              `reg_dl` int(1) NOT NULL default '0',
  14.              `reg_artikel` int(1) NOT NULL default '0',
  15.              `reg_newscomments` int(1) NOT NULL default '0',
  16.              `tmpdir` varchar(100) NOT NULL default 'modern',
  17.              `wmodus` int(1) NOT NULL default '0',
  18.              `persinfo` int(1) NOT NULL default '1',
  19.              `iban` varchar(100) NOT NULL default '',
  20.              `bic` varchar(100) NOT NULL default '',
  21.              `badwords` text NOT NULL,
  22.              `pagetitel` varchar(50) NOT NULL default 'Dein Seitentitel hier!',
  23.              `last_backup` int(20) NOT NULL default '0',
  24.              `squadtmpl` int(1) NOT NULL default '1',
  25.              `i_domain` varchar(50) NOT NULL default 'www.deineUrl.de',
  26.              `i_autor` varchar(249) NOT NULL default 'Max Mustermann',
  27.              `k_nr` varchar(100) NOT NULL default '123456789',
  28.              `k_inhaber` varchar(50) NOT NULL default 'Max Mustermann',
  29.              `k_blz` varchar(100) NOT NULL default '123456789',
  30.              `k_bank` varchar(200) NOT NULL default 'Musterbank',
  31.              `k_waehrung` varchar(15) NOT NULL default '€',
  32.              `ftp_host` varchar(100) NOT NULL default '',
  33.              `ftp_login` varchar(100) NOT NULL default '',
  34.              `ftp_pwd` varchar(100) NOT NULL default '',
  35.              `language` varchar(50) NOT NULL default 'deutsch',
  36.              `domain` varchar(200) NOT NULL default '".$host."',
  37.              `gametiger` varchar(20) NOT NULL default 'cstrike',
  38.              `regcode` int(1) NOT NULL default '1',
  39.              `ts_ip` varchar(200) NOT NULL default '',
  40.              `mailfrom` varchar(200) NOT NULL default 'support@".$host."',
  41.              `ts_port` int(10) NOT NULL default '0',
  42.              `ts_sport` int(10) NOT NULL default '0',
  43.              `ts_width` int(10) NOT NULL default '0',
  44.              `bl_path` varchar(249) NOT NULL default ''
  45.              ) TYPE=MyISAM");
  46.  
Jun 16 '07 #3
Atli
5,058 Expert 4TB
Yea thats it, but I can't spot any errors there :/

I tried this on my localhost and it works fine. I'm running PHP 5.2.2 and MySQL 5.0.

What versions of PHP and MySQL are you running? Might be some minor bug in some version of MySQL.

Also, if you can locate that db() function it's possible there might be an error in there.
Jun 16 '07 #4

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

1 post views Thread by Kerry Shetline | last post: by
reply views Thread by Sean Ian Rice | last post: by
reply views Thread by Andrew Keating | last post: by
reply views Thread by Arthur Perry | last post: by
19 posts views Thread by cover | last post: by
Atli
6 posts views Thread by Atli | last post: by
1 post views Thread by Waqarahmed | last post: by
reply views Thread by Salome Sato | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.