By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,910 Members | 1,077 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,910 IT Pros & Developers. It's quick & easy.

Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock'

P: n/a
Sorry if this is a really dumb question. I am trying to connect to our
remote MySQL server (which is running just fine). I have a perl script
which
worked just fine on my other Fedora 4 box (all servers are Fedora 4
with
latests updates). The one that worked fine it down and I cannot
compare
anything against it (it was a client also).

My problem is, when I try to connect to the server I get:

DBI connect('passwd','user',...) failed: Can't connect to local MySQL
server through socket '/var/lib/mysql/mysql.sock' (2) at
/home/perl_inc/mysql.pl line 19

I read all the articles I could on the subject talking about how
mysql.sock was in
/tmp and linking it etc, but on my system I did:

find / -name 'mysql.sock'

and cannot find it anywhere on my system.

My question is, on the mysql client, is there always a mysql.sock file?
If so, why cant I find it? What creates the client mysql.sock file?

Thanks

Jan 13 '06 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Ok I had thought I setup this box with 'everything' installed.
Turned out I didnt have a bunch of mysql packages etc
installed. I installed them and it worked.

FYI I found this good link for other problems:

http://dev.mysql.com/doc/refman/5.0/...to-server.html

Jan 13 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.