469,883 Members | 1,140 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,883 developers. It's quick & easy.

Error Upgrading MySQL from 4 to 5



Today I began preparations for upgrading MySQL. I downloaded the binary RPMs for
Red Hat Enterprise 4 (we're running CentOS, a clone) for MySQL 5.0.13 from the
MySQL AB web site. Running a test, I got this:

[root@seabass ~] rpm -hUv MySQL* --test
warning: MySQL-client-standard-5.0.13-0.rhel4.i386.rpm: V3 DSA signature: NOKEY,
key ID 5072e1f5
error: Failed dependencies:
libmysqlclient.so.14 is needed by (installed) mod_auth_mysql-2.6.1-2.2.i386
libmysqlclient.so.14 is needed by (installed) php-mysql-4.3.9-3.6.i386
libmysqlclient.so.14 is needed by (installed) dovecot-0.99.11-2.EL4.1.i386
libmysqlclient.so.14 is needed by (installed) perl-DBD-MySQL-2.9004-3.1.i386
Has anyone else encountered this dependency problem? What would happen if I
--force'd RPM to do the upgrade?

--Richard
Oct 12 '05 #1
3 4646
Richard Petty wrote:
Has anyone else encountered this dependency problem? What would happen if I
--force'd RPM to do the upgrade?


If it were me, I'd start by reinstalling the machine, using a distro
other than Redhat. I've run into their maze of RPM dependencies before.
I tried the path of forcing installation of RPM's, but it just got
worse. You can also try uninstalling the dependent RPM's, but they
undoubtedly have a collection of other packages dependent on them in turn.

Basically the Redhat model assumes that you subscribe to their Redhat
Network ($$$) and you get all your RPM updates at the same time. That's
the only way to resolve all the dependencies. But you'll probably have
to wait until 2009 for them to add MySQL 5 to their updates.

I'm very sorry to be so negative. I usually try to be much more
"can-do" on these newsgroups.

You can install MySQL from the tar.gz distribution instead of using
RPM's. Install the MySQL 5 distribution adjacent to, but not
overlapping, the existing MySQL 4 RPM's installed. Then shut off the
MySQL 4 service and disable it using chkconfig. But leave it installed
so that it resolves those other dependencies.

You can also build MySQL from source, and specify where to install it
when you configure the build.

Regards,
Bill K.
Oct 12 '05 #2
Hi,

I had the same problem with Fedora Core 4 - I managed to update the server
anyhow (unfortunately, I really can't remember how I did it), but it was a
painful task. You might have the best chances if you install Linux without
Apache and MySQL, install MySQL 5 using the RPMs and afterwards install
Apache (and pray that there are no failed dependencies then).

Recently I tried the same with SuSE 10 and it was very easy. So maybe it's
really the better option to consider another distribution.

Good luck!

Markus
Oct 15 '05 #3
The solutions seems to be using "shared-compat" rpm rather than "shared-standard" rpm. Check the bug notes at: http://bugs.mysql.com/bug.php?id=17035 for more information.

-S
Mar 20 '06 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Jonathan Hilgeman | last post: by
reply views Thread by Richard Gabriel | last post: by
2 posts views Thread by wellington fan | last post: by
2 posts views Thread by Jonathan | last post: by
1 post views Thread by Waqarahmed | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.