473,729 Members | 2,072 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

"Table Does Not Exist" (But It Does?)

65 New Member
I copied the files from my "test" database on my old server (MySQL was not running) to my new server ("./mysql/data/test" folder), and after starting the server, SHOW TABLES; shows all of the tables that are supposed to be there, but running a SELECT * FROM `configuration` ; (for example) returns "test.configura tion does not exist).

I've tried the following repair statement since I'm not too familiar with backing up and restoring data.

(Note that I removed my password after "-p")

Expand|Select|Wrap|Line Numbers
  1. sudo ./bin/mysqlcheck -r test -uroot -p
  2. test.configuration
  3. Error    : Table 'test.configuration' doesn't exist
  4. error    : Corrupt
  5. test.module_navigation_buttons                     OK
  6. test.module_register_fields                        OK
  7. test.module_register_steps                         OK
  8. test.modules
  9. Error    : Table 'test.modules' doesn't exist
  10. error    : Corrupt
  11. test.modules_auto
  12. Error    : Table 'test.modules_auto' doesn't exist
  13. error    : Corrupt
  14. test.modules_streams
  15. Error    : Table 'test.modules_streams' doesn't exist
  16. error    : Corrupt
  17. test.servers
  18. Error    : Table 'test.servers' doesn't exist
  19. error    : Corrupt
  20. test.session_identifiers
  21. note     : The storage engine for the table doesn't support repair
  22. test.session_keys
  23. note     : The storage engine for the table doesn't support repair
  24. test.styles
  25. Error    : Table 'test.styles' doesn't exist
  26. error    : Corrupt
  27. test.users
  28. Error    : Table 'test.users' doesn't exist
  29. error    : Corrupt
  30. test.users_activity
  31. Error    : Table 'test.users_activity' doesn't exist
  32. error    : Corrupt
  33. test.users_logins
  34. Error    : Table 'test.users_logins' doesn't exist
  35. error    : Corrupt
EDIT: The ones that did not properly move are using the FALCON engine. I do have access to the full installation of the old MySQL server. I just can't run it as the Operating System will not run under the new hardware I have on this system.

Also, I believe the files are definitely not corrupt as they ran fine on the system last time I used them. Maybe I need to move a few more files besides the entire test directory, or update something in the mysql table?

MySQL 6.0.8-alpha
Jan 14 '09 #1
3 10371
r035198x
13,262 MVP
Use mysqldump for backing up the database.
Jan 15 '09 #2
moltendorf
65 New Member
I'm just wondering as to how I can do that on the old install I have of it (which is 32-bit, not 64-bit)?

Do I copy the new file to the old installation, or is mysqldump not dependent on either?
Jan 15 '09 #3
r035198x
13,262 MVP
Moving databases by moving files is not the way to go. Check the MySQL site for migration options for your versions and platform.
Jan 16 '09 #4

Sign in to post your reply or Sign up for a free account.

Similar topics

1
3050
by: Dave | last post by:
Hi all, I was trying to make an image submit button with a rollover and discovered to my suprise that there is no way to access a form element of the "image" type. I tried specifying it by name and also by the elements array with no luck. Even weirder, I can sandwich an image button in between other input types and then write a script diplaying the contents of the elements array and it acts as if the image button does not exist at all!...
1
1456
by: avihaimar | last post by:
hello i have the code below: <html> <body> <table> <div id="div1" style="display :none"> <tr> <td> uuu </td>
2
7206
by: S.Peppe | last post by:
Hi there! I'm really new at this game, so please forgive me if my request is at all irritating. I have installed PostgreSQL onto a Debian/Linux machine, and I have just upgraded PostgreSQL via the apt-get update & upgrade commands. However, whenever I get into the PostgreSQL interactive terminal thus sp@vanthoff:~$ psql -U postgres SHG
0
2664
by: Dirk Försterling | last post by:
Hi all, a few days ago, I upgraded from PostgreSQL 7.2.1 to 7.4, following the instructions in the INSTALL file, including dump and restore. All this worked fine without any error (message). Since then, I found lots of the following in the postmaster output: 2003-11-29 15:19:54 ERROR: large object 4838779 does not exist 2003-11-29 15:20:11 ERROR: large object 4838779 does not exist
2
7063
by: Alanoly J. Andrews | last post by:
Hi, I have two tables (that I know of) in a database that seem to be corrupted. All SQL statements on the tables hang, "select * from..", "select count (*) from", "delete from..". I can't even drop the tables as the "drop table..." statement, too, hangs. But the tables do exist as they show up in "describe table <tabname> ". A "create table" statement fails saying that the table already exists.
6
3103
by: Paul T. Rong | last post by:
Dear all, Here is my problem: There is a table "products" in my access database, since some of the products are out of date and stopped manufacture, I would like to delete those PRODUCTS from the table, but I was not allowed to do that, because "there are records related with those PRODUCTS in other tables (e.g. in table "ORDER_DETAIL").
2
9919
by: Jeff | last post by:
hey asp.net 2.0 (C'#) In the code behind file I have this method: public String AddBR(Object param) { String text = (String) param; return text; }
2
6672
by: kilo | last post by:
Hey.. I need someone hwo can help me making my sql table.. I have no php skills. I have payed for a php program that shoud make dictation for people that have some problems reading danish.. with sound and text.. When I'm making the dictation with PHP I'm getting an error like this.: Query failed (SELECT word FROM repository): Table 'test_dig_dk.repository' doesn't exist the first one of the php, that I soud use for makeing the text is.. ...
2
16446
by: shalong | last post by:
Hi all, VS 2008 is complaining that HttpWebRequest class is not in System.Net namespace I have referenced System.Net and have coded "using System.Net" I think its a setup problem rather than a coding error The type or namespace name 'HttpWebRequest' does not exist in the namespace 'System.Net' (are you missing an assembly reference?) C:\Documents and Settings\user\My Documents\Visual Studio...
0
8936
marktang
by: marktang | last post by:
ONU (Optical Network Unit) is one of the key components for providing high-speed Internet services. Its primary function is to act as an endpoint device located at the user's premises. However, people are often confused as to whether an ONU can Work As a Router. In this blog post, we’ll explore What is ONU, What Is Router, ONU & Router’s main usage, and What is the difference between ONU and Router. Let’s take a closer look ! Part I. Meaning of...
0
9436
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. Here is my compilation command: g++-12 -std=c++20 -Wnarrowing bit_field.cpp Here is the code in...
0
9298
jinu1996
by: jinu1996 | last post by:
In today's digital age, having a compelling online presence is paramount for businesses aiming to thrive in a competitive landscape. At the heart of this digital strategy lies an intricately woven tapestry of website design and digital marketing. It's not merely about having a website; it's about crafting an immersive digital experience that captivates audiences and drives business growth. The Art of Business Website Design Your website is...
1
9226
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For most users, this new feature is actually very convenient. If you want to control the update process,...
0
9166
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the choice of these technologies. I'm particularly interested in Zigbee because I've heard it does some...
0
8170
agi2029
by: agi2029 | last post by:
Let's talk about the concept of autonomous AI software engineers and no-code agents. These AIs are designed to manage the entire lifecycle of a software development project—planning, coding, testing, and deployment—without human intervention. Imagine an AI that can take a project description, break it down, write the code, debug it, and then launch it, all on its own.... Now, this would greatly impact the work of software developers. The idea...
0
6028
by: conductexam | last post by:
I have .net C# application in which I am extracting data from word file and save it in database particularly. To store word all data as it is I am converting the whole word file firstly in HTML and then checking html paragraph one by one. At the time of converting from word file to html my equations which are in the word document file was convert into image. Globals.ThisAddIn.Application.ActiveDocument.Select();...
0
4799
by: adsilva | last post by:
A Windows Forms form does not have the event Unload, like VB6. What one acts like?
1
3248
by: 6302768590 | last post by:
Hai team i want code for transfer the data from one system to another through IP address by using C# our system has to for every 5mins then we have to update the data what the data is updated we have to send another system

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.