473,847 Members | 1,453 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

mysql Install Problems

I've been having a very rough time installinig mySQL on Linux. I have
been following the instructions form here:
http://www.hostlibrary.com/installin...l_php_on_linux
Everytime I get to #./configure it goes through all of the preparing
tables and starting mysqlServer and daemon, but than immediaetly says
"mysql ended" -- I try to do #make right after anyway, but I get the
error "No targets specified and no makefile found" -- Any suggestions
would be appreicted. Thanks!

Nov 1 '06 #1
1 5292
FYI, here is the *.err file; which loooks pretty "clean" :

061101 13:21:30 mysqld started
/usr/local/mysql/bin/mysqld: unrecognized option `--old_passwords=1 '
/usr/local/mysql/bin/mysqld Ver 4.0.1-alpha for pc-linux-gnu on i686
Copyright (C) 2000 MySQL AB & MySQL Finland AB, by Monty and others
This software comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to modify and redistribute it under the GPL license

Starts the MySQL server

Usage: /usr/local/mysql/bin/mysqld [OPTIONS]

--ansi Use ANSI SQL syntax instead of MySQL syntax
-b, --basedir=path Path to installation directory. All paths are
usually resolved relative to this
--big-tables Allow big result sets by saving all temporary sets
on file (Solves most 'table full' errors)
--bind-address=IP Ip address to bind to
--bootstrap Used by mysql installation scripts
--character-sets-dir=...
Directory where character sets are
--chroot=path Chroot mysqld daemon during startup
--core-file Write core on errors
-h, --datadir=path Path to the database root
--default-character-set=charset
Set the default character set
--default-table-type=type
Set the default table type for tables
--delay-key-write-for-all-tables
Don't flush key buffers between writes for any MyISAM
table

--enable-locking Enable system locking
--enable-pstack Print a symbolic stack trace on failure
-T, --exit-info Used for debugging; Use at your own risk!
--flush Flush tables to disk between SQL commands
-?, --help Display this help and exit
--init-file=file Read SQL commands from this file at startup
-L, --language=... Client error messages in given language. May be
given as a full path
-l, --log[=file] Log connections and queries to file
--log-bin[=file] Log queries in new binary format (for
replication)
--log-bin-index=file File that holds the names for last binary log
files
--log-update[=file] Log updates to file.# where # is a unique number
if not given.
--log-isam[=file] Log all MyISAM changes to file
--log-long-format Log some extra information to update log
--low-priority-updates INSERT/DELETE/UPDATE has lower priority than
selects
--log-slow-queries=[file]
Log slow queries to this log file. Defaults logging
to hostname-slow.log
--pid-file=path Pid file used by safe_mysqld
--myisam-recover[=option[,option...]] where options is one of DEAULT,
BACKUP or FORCE.
--memlock Lock mysqld in memory
-n, --new Use very new possible 'unsafe' functions
-o, --old-protocol Use the old (3.20) protocol
-P, --port=... Port number to use for connection

-O, --set-variable var=option
Give a variable an value. --help lists variables
--safe-mode Skip some optimize stages (for testing)
--safe-show-database Don't show databases for which the user has no
privileges
--safe-user-create Don't allow new user creation by the user who has
no write privileges to the mysql.user table
--skip-concurrent-insert
Don't use concurrent insert with MyISAM
--skip-delay-key-write
Ignore the delay_key_write option for all tables
--skip-grant-tables Start without grant tables. This gives all users
FULL ACCESS to all tables!
--skip-host-cache Don't cache host names
--skip-locking Don't use system locking. To use isamchk one has
to shut down the server.
--skip-name-resolve Don't resolve hostnames.
All hostnames are IP's or 'localhost'
--skip-networking Don't allow connection with TCP/IP.
--skip-new Don't use new, possible wrong routines.

--skip-stack-trace Don't print a stack trace on failure
--skip-symlink Don't allow symlinking of tables
--skip-show-database Don't allow 'SHOW DATABASE' commands
--skip-thread-priority
Don't give threads different priorities.
--socket=... Socket file to use for connection
-t, --tmpdir=path Path for temporary files
--sql-mode=option[,option[,option...]] where option can be one of:
REAL_AS_FLOAT, PIPES_AS_CONCAT , ANSI_QUOTES,
IGNORE_SPACE, SERIALIZE, ONLY_FULL_GROUP _BY.
--transaction-isolation
Default transaction isolation level
--temp-pool Use a pool of temporary files
-u, --user=user_name Run mysqld daemon as user
-V, --version output version information and exit
-W, --warnings Log some not critical warnings to the log file

--innodb_data_hom e_dir=dir The common part for Innodb table spaces
--innodb_data_fil e_path=dir Path to individual files and their sizes
--innodb_flush_me thod=# With which method to flush data
--innodb_flush_lo g_at_trx_commit[=#]
Set to 0 if you don't want to flush logs
--innodb_log_arch _dir=dir Where full logs should be archived
--innodb_log_arch ive[=#] Set to 1 if you want to have logs
archived
--innodb_log_grou p_home_dir=dir Path to innodb log files.
--skip-innodb Don't use Innodb (will save memory)
Default options are read from the following files in the given order:
/etc/my.cnf /usr/local/mysql/var/my.cnf
/usr/local/mysql/data/my.cnf/my.cnf ~/.my.cnf
The following groups are read: mysqld server
The following options may be given as the first argument:
--print-defaults Print the program argument list and exit
--no-defaults Don't read default options from any options file
--defaults-file=# Only read default options from the given file #
--defaults-extra-file=# Read this file after the global files are read

To see what values a running MySQL server is using, type
'mysqladmin variables' instead of 'mysqld --help'.
The default values (after parsing the command line arguments) are:

basedir: /usr/local/mysql/
datadir: /usr/local/mysql/var/
tmpdir: /tmp/
language: /usr/local/mysql/share/mysql/english/
pid file: /usr/local/mysql/var/member1.pid
binary log:
binary log index:
TCP port: 3306
Unix socket: /tmp/mysql.sock

system locking is not in use

Possible variables for option --set-variable (-O) are:
back_log current value: 50
binlog_cache_si ze current value: 32768
connect_timeout current value: 5
delayed_insert_ timeout current value: 300
delayed_insert_ limit current value: 100
delayed_queue_s ize current value: 1000
flush_time current value: 0
ft_min_word_len current value: 4
ft_max_word_len current value: 254
ft_max_word_len _for_sort current value: 20
innodb_mirrored _log_groups current value: 1
innodb_log_file s_in_group current value: 2
innodb_log_file _size current value: 5242880
innodb_log_buff er_size current value: 1048576
innodb_buffer_p ool_size current value: 8388608
innodb_addition al_mem_pool_siz e current value: 1048576
innodb_file_io_ threads current value: 9
innodb_lock_wai t_timeout current value: 1073741824
innodb_thread_c oncurrency current value: 8
innodb_force_re covery current value: 0
interactive_tim eout current value: 28800
join_buffer_siz e current value: 131072
key_buffer_size current value: 16773120
long_query_time current value: 10
lower_case_tabl e_names current value: 0
max_allowed_pac ket current value: 1047552
max_binlog_cach e_size current value: 4294967295
max_binlog_size current value: 1073741824
max_connections current value: 100
max_connect_err ors current value: 10
max_delayed_thr eads current value: 20
max_heap_table_ size current value: 16777216
max_join_size current value: 4294967295
max_sort_length current value: 1024
max_tmp_tables current value: 32
max_user_connec tions current value: 0
max_write_lock_ count current value: 4294967295
myisam_bulk_ins ert_tree_size current value: 8388608
myisam_block_si ze current value: 1024
myisam_max_extr a_sort_file_siz e current value: 256
myisam_max_sort _file_size current value: 2047
myisam_sort_buf fer_size current value: 8388608
net_buffer_leng th current value: 7168
net_retry_count current value: 10
net_read_timeou t current value: 30
net_write_timeo ut current value: 60
open_files_limi t current value: 0
query_buffer_si ze current value: 0
query_cache_lim it current value: 1048576
query_cache_siz e current value: 0
query_cache_sta rtup_type current value: 1
record_buffer current value: 131072
record_rnd_buff er current value: 0
slave_net_timeo ut current value: 3600
slow_launch_tim e current value: 2
sort_buffer current value: 524280
table_cache current value: 64
thread_concurre ncy current value: 10
thread_cache_si ze current value: 0
tmp_table_size current value: 33554432
thread_stack current value: 65536
wait_timeout current value: 28800
061101 13:21:30 mysqld ended
Po************* @gmail.com wrote:
I've been having a very rough time installinig mySQL on Linux. I have
been following the instructions form here:
http://www.hostlibrary.com/installin...l_php_on_linux
Everytime I get to #./configure it goes through all of the preparing
tables and starting mysqlServer and daemon, but than immediaetly says
"mysql ended" -- I try to do #make right after anyway, but I get the
error "No targets specified and no makefile found" -- Any suggestions
would be appreicted. Thanks!
Nov 1 '06 #2

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

0
1900
by: phpnube | last post by:
I used this php package to install on my system... (i had problems with the isapi package from php so im back to the cgi portion of PHP php-cgi.exe) PHP 5.0.0 installer - 26 July 2004 (CGI only, packaged as Windows installer to install and configure PHP, and automatically configure IIS, PWS and Xitami, with manual configuration for other servers. N.B. no external extensions included It works fine... as the test page outputs the...
0
2259
by: Anil Garg | last post by:
Hi, I am trying to install myql on redhat. mysql package used: mysql-3.23.52-unknown-freebsdelf4.6-i386.tar.gz While following the instructions in install document..when i run the follwing command.. scripts/mysql_install_db following errors appear: -------------
0
1344
by: albert | last post by:
Dear, Now i'm trying to install MySQL 4.0.14 through binary source install. I'm using Redhat 7.2 and 8.0 I'm trying like this.. ../configure --prefix=/usr/local/mysql \ --localstatedir=/usr/local/mysql/data \
0
4064
by: mikey | last post by:
Hi all, I'm having great problems trying to install the latest MySQl RPM package onto my Red Hat Linux OS. There is already MySQL v 3.0 pre-installed with the RH Linux distribution disk but I can not seem to get any of the functions working on it. So I have now dopwnloaded the latest version hoping that this will fix the error. I have managed to install the MySQL-shared-compat-4.0.1-0.i386.rpm but
2
2366
by: Shaun | last post by:
I've attempted to upgrade to MySQL 3.23 to 4.0. MySQL 4.0 server is working great, buy I couldn't get MySQL 4.0 client to install properly. Any help would be greatly appreciated. Here are the steps I followed: 1. Downloaded the server, client, and "Dynamic client libraries (including 3.23.x libraries)" rpms. 2. rpm -Uvh --nodeps MySQL-server-4.0.20-0.i386.rpm
1
3831
by: Alex Hunsley | last post by:
I am trying to install the DBD::mysql perl module. However, it claims I need mysql.h: cpan> install DBD::mysql CPAN: Storable loaded ok Going to read /home/alex/.cpan/Metadata Database was generated on Mon, 29 Nov 2004 16:01:05 GMT Running install for module DBD::mysql Running make for R/RU/RUDY/DBD-mysql-2.9004.tar.gz CPAN: Digest::MD5 loaded ok
2
6125
by: pc | last post by:
hi everyone, we have a server on which someone blew away the MySQL 4 progs directory before installing MySQL 5. When installing MySQL 5 the installation failed with an error stating that it was unable to create system tables as the MySQL 4 directory did not exist. We are now unable to uninstall MySQL 5: # rpm -i
15
4660
by: Cheryl Langdon | last post by:
Hello everyone, This is my first attempt at getting help in this manner. Please forgive me if this is an inappropriate request. I suddenly find myself in urgent need of instruction on how to communicate with a MySQL database table on a web server, from inside of my company's Access-VBA application. I know VBA pretty well but have never before needed to do this HTTP/XML/MySQL type functions.
5
5341
by: Frances | last post by:
a few days ago I installed XAMPP in my Windows 2000 machine, it completely messed my existing MySQL installation.. I've had it installed for over a year now (4.1) have never had any problems with it whatsoever (I connect to it from Tomcat and from stand-alone Java classes), now since I installed XAMPP I cannot connect to it at all, cannot start service... I uninstalled XAMPP completely, and my MySQL server still doesn't work.. so why...
3
8840
by: menzies | last post by:
Hi, I"m new to this forum, but I have been trying all day to install DBD::mysql onto my Intel MacBook. I've read lots of forums pages and none have gotten me to a successful 'make test' or a successful 'sudo make install.' Before every attempt I even do a sudo make distclean to make sure I haven't gotten things mucked up from a prior attempt. OS: Mac OS X 10.4.10 MySQL: v5.0.41 for Mac OSX-i686 DBI: v1.58 (installed fine using CPAN)...
0
9889
marktang
by: marktang | last post by:
ONU (Optical Network Unit) is one of the key components for providing high-speed Internet services. Its primary function is to act as an endpoint device located at the user's premises. However, people are often confused as to whether an ONU can Work As a Router. In this blog post, we’ll explore What is ONU, What Is Router, ONU & Router’s main usage, and What is the difference between ONU and Router. Let’s take a closer look ! Part I. Meaning of...
0
9732
by: Hystou | last post by:
Most computers default to English, but sometimes we require a different language, especially when relocating. Forgot to request a specific language before your computer shipped? No problem! You can effortlessly switch the default language on Windows 10 without reinstalling. I'll walk you through it. First, let's disable language synchronization. With a Microsoft account, language settings sync across devices. To prevent any complications,...
0
10988
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. Here is my compilation command: g++-12 -std=c++20 -Wnarrowing bit_field.cpp Here is the code in...
1
10712
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For most users, this new feature is actually very convenient. If you want to control the update process,...
1
7886
isladogs
by: isladogs | last post by:
The next Access Europe User Group meeting will be on Wednesday 1 May 2024 starting at 18:00 UK time (6PM UTC+1) and finishing by 19:30 (7.30PM). In this session, we are pleased to welcome a new presenter, Adolph Dupré who will be discussing some powerful techniques for using class modules. He will explain when you may want to use classes instead of User Defined Types (UDT). For example, to manage the data in unbound forms. Adolph will...
0
7058
by: conductexam | last post by:
I have .net C# application in which I am extracting data from word file and save it in database particularly. To store word all data as it is I am converting the whole word file firstly in HTML and then checking html paragraph one by one. At the time of converting from word file to html my equations which are in the word document file was convert into image. Globals.ThisAddIn.Application.ActiveDocument.Select();...
0
5914
by: adsilva | last post by:
A Windows Forms form does not have the event Unload, like VB6. What one acts like?
1
4536
by: 6302768590 | last post by:
Hai team i want code for transfer the data from one system to another through IP address by using C# our system has to for every 5mins then we have to update the data what the data is updated we have to send another system
2
4126
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.