473,857 Members | 2,187 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

Problem with install DBD::mysql on Mac os x 10.3

2 New Member
Hello there,

I've been trying to install DBD::mysql on Mac OS X Server 10.3 for 2 days, but it still raises error. So I'm going to send this message to ask for help. Any help will be much appreciated.

Here is what I've tried to install the DBD::mysql module:

1> Download DBD-mysql-2.9003 and un-zip it

2> cd to DBD-mysql-2.9003 directory

3> add 'env' in front of MACOSX in mysql_config & Makefile.PL

4> run: perl Makefile.PL

Unrecognized argument in LIBS ignored: '-arch'

Unrecognized argument in LIBS ignored: 'i386'

Unrecognized argument in LIBS ignored: '-arch'

Unrecognized argument in LIBS ignored: 'ppc'

Unrecognized argument in LIBS ignored: '-pipe'

Using DBI 1.40 (for perl 5.008001 on darwin-thread-multi-2level) installed in /Library/Perl/5.8.1/darwin-thread-multi-2level/auto/DBI

Writing Makefile for DBD::mysql



So apparently it raises error when I tried to "make".

5> To fix all unrecognized arguments, I run:

perl Makefile.PL --cflags="-I/usr/include/mysql -fno-omit-frame-pointer" --libs="-L/usr/lib/mysql -lmysqlclient -lz -lm"

This runs successfully.

6> run: make

cc -c -I/Library/Perl/5.8.1/darwin-thread-multi-2level/auto/DBI -I/usr/include/mysql -fno-omit-frame-pointer -g -pipe -pipe -fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -I/usr/local/include -Os -DVERSION=\"2.90 03\" -DXS_VERSION=\"2 .9003\" "-I/System/Library/Perl/5.8.1/darwin-thread-multi-2level/CORE" dbdimp.c

cc -c -I/Library/Perl/5.8.1/darwin-thread-multi-2level/auto/DBI -I/usr/include/mysql -fno-omit-frame-pointer -g -pipe -pipe -fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -I/usr/local/include -Os -DVERSION=\"2.90 03\" -DXS_VERSION=\"2 .9003\" "-I/System/Library/Perl/5.8.1/darwin-thread-multi-2level/CORE" mysql.c

Running Mkbootstrap for DBD::mysql ()

chmod 644 mysql.bs

rm -f blib/arch/auto/DBD/mysql/mysql.bundle

LD_RUN_PATH="/usr/lib" /usr/bin/perl myld env MACOSX_DEPLOYME NT_TARGET=10.3 cc -bundle -undefined dynamic_lookup -L/usr/local/lib dbdimp.o mysql.o -o blib/arch/auto/DBD/mysql/mysql.bundle -L/usr/lib/mysql -lmysqlclient -lz -lm

ld: warning -L: directory name (/usr/local/lib) does not exist

ld: /usr/lib/mysql/libmysqlclient. a(libmysql.o) r_type field of relocation entry 53 in section (__TEXT,__text) invalid

....

make: *** [blib/arch/auto/DBD/mysql/mysql.bundle] Error 1



I have no idea what is going on here. Can anyone help me out with this. Any hint is much appreciated.

Thanks alot

Vannie
Aug 24 '06 #1
1 2315
vssp
268 Contributor
Hai refer thsi link its use full for install mysql mac os

http://developer.apple.com/internet/...urce/osdb.html
Aug 25 '06 #2

Sign in to post your reply or Sign up for a free account.

Similar topics

0
3323
by: Randell D. | last post by:
Folks, I have installed MySQL v4 (client, server and development rpm's). I've tried and failed to use the recommended mysqladmin to set a root password after the installation (I have another post open on the MySQL newsgroup about this). I'm attempting an alternative solution and using webmin (www.webmin.com) to create/manage access to my databases. Webmin reports "Warning: The Perl module DBD::mysql is not installed on your system, so...
1
3427
by: Kerry Shetline | last post by:
I've successfully installed MySQL and the Perl DBI module, but when I try to install DBD::mysql, it keeps failing like this: -------------------- (from the CPAN shell) --------------------- .... chmod 644 mysql.bs rm -f blib/arch/auto/DBD/mysql/mysql.bundle LD_RUN_PATH="/usr/lib" /usr/bin/perl myld MACOSX_DEPLOYMENT_TARGET=10.3 cc -bundle -undefined dynamic_lookup -L/usr/local/lib dbdimp.o mysql.o -o...
0
1810
by: Madhu Nair | last post by:
I am getting errors while compiling DBD-mysql 2.9002 on HP-UX 11.00 I have perl 5.8 downloaded from HP depot installed at /opt/perl Mysql 4.0.13 compiled myself with gcc with Mysql recommended options and working fine I am getting this error ..... Running Mkbootstrap for DBD::mysql () chmod 644 mysql.bs
0
1471
by: Yun Guan | last post by:
Hello mysql gurus, I am trying to run perl on mysql database on Red Hat box. I want to install DBI and DBD:mysql using CPAN: perl -MCPAN -e shell cpan>install DBI The above succeeded, but cpan>install DBD::mysql
1
2630
by: Yun Guan | last post by:
Hello, I have problems installing DBD:mysql on Red Hat Linux 9, either from CPAN, or mannual install. The error is the same, something related to this Kid.pm file under perl. Should I reinstall Perl? Perl came with Red Hat Linux 9 installation. Please help. 1.) from CPAN: perl -MCPAN -e shell
0
1667
by: vetolimits | last post by:
Hi everyone, Machine info: Fedora Core 3, MySQL-server-4.1.9, and perl-DBD-MySQL-2.9003-5 When I try to use mysqlhotcopy command to backup database, following error occurs :(& install_driver(mysql) failed: DBD::mysql object version 2.9003 does not match bootstrap parameter 2.0419 at
3
7018
by: Nick | last post by:
hi, all I have a red hat 9 and looks like it had mysql 3.2.54 installed before, but, actually not, i can not find the install folder and I can not uninstall it. So I am trying to install/upgrade to 4.1, but, still can not get it work. Here is what I did: # rpm -Uvh MySQL-server-standard-4.1.14-0.rhel4.i386.rpm warning: MySQL-server-standard-4.1.14-0.rhel4.i386.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
0
3471
by: pvannie | last post by:
Hello there, I've been trying to install DBD::mysql on Mac OS X Server 10.3 for 2 days, but it still raises error. So I'm going to send this message to ask for help. Any help will be much appreciated. Here is what I've tried to install the DBD::mysql module: 1> Download DBD-mysql-2.9003 and un-zip it 2> cd to DBD-mysql-2.9003 directory
3
1587
by: thisisazam | last post by:
Hi I am installing DBD::mysql but getting the error like, ***************** Can't exec "mysql_config": No such file or directory at Makefile.PL line 76 Cannot find the file 'mysql_config'! your execution PATH does not seem contain the path to mysql_config............ ********** I would be greatly thankful to you if you please suggest any solution.
0
9767
by: Hystou | last post by:
Most computers default to English, but sometimes we require a different language, especially when relocating. Forgot to request a specific language before your computer shipped? No problem! You can effortlessly switch the default language on Windows 10 without reinstalling. I'll walk you through it. First, let's disable language synchronization. With a Microsoft account, language settings sync across devices. To prevent any complications,...
0
11082
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. Here is my compilation command: g++-12 -std=c++20 -Wnarrowing bit_field.cpp Here is the code in...
0
10711
jinu1996
by: jinu1996 | last post by:
In today's digital age, having a compelling online presence is paramount for businesses aiming to thrive in a competitive landscape. At the heart of this digital strategy lies an intricately woven tapestry of website design and digital marketing. It's not merely about having a website; it's about crafting an immersive digital experience that captivates audiences and drives business growth. The Art of Business Website Design Your website is...
1
10807
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For most users, this new feature is actually very convenient. If you want to control the update process,...
0
10394
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the choice of these technologies. I'm particularly interested in Zigbee because I've heard it does some...
0
9549
agi2029
by: agi2029 | last post by:
Let's talk about the concept of autonomous AI software engineers and no-code agents. These AIs are designed to manage the entire lifecycle of a software development project—planning, coding, testing, and deployment—without human intervention. Imagine an AI that can take a project description, break it down, write the code, debug it, and then launch it, all on its own.... Now, this would greatly impact the work of software developers. The idea...
0
7104
by: conductexam | last post by:
I have .net C# application in which I am extracting data from word file and save it in database particularly. To store word all data as it is I am converting the whole word file firstly in HTML and then checking html paragraph one by one. At the time of converting from word file to html my equations which are in the word document file was convert into image. Globals.ThisAddIn.Application.ActiveDocument.Select();...
0
5774
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in the same network. But I'm wondering if it's possible to do the same thing, with 2 Pfsense firewalls...
2
4190
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.