473,549 Members | 2,647 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

Error Upgrading MySQL from 4 to 5



Today I began preparations for upgrading MySQL. I downloaded the binary RPMs for
Red Hat Enterprise 4 (we're running CentOS, a clone) for MySQL 5.0.13 from the
MySQL AB web site. Running a test, I got this:

[root@seabass ~] rpm -hUv MySQL* --test
warning: MySQL-client-standard-5.0.13-0.rhel4.i386.rp m: V3 DSA signature: NOKEY,
key ID 5072e1f5
error: Failed dependencies:
libmysqlclient. so.14 is needed by (installed) mod_auth_mysql-2.6.1-2.2.i386
libmysqlclient. so.14 is needed by (installed) php-mysql-4.3.9-3.6.i386
libmysqlclient. so.14 is needed by (installed) dovecot-0.99.11-2.EL4.1.i386
libmysqlclient. so.14 is needed by (installed) perl-DBD-MySQL-2.9004-3.1.i386
Has anyone else encountered this dependency problem? What would happen if I
--force'd RPM to do the upgrade?

--Richard
Oct 12 '05 #1
3 4799
Richard Petty wrote:
Has anyone else encountered this dependency problem? What would happen if I
--force'd RPM to do the upgrade?


If it were me, I'd start by reinstalling the machine, using a distro
other than Redhat. I've run into their maze of RPM dependencies before.
I tried the path of forcing installation of RPM's, but it just got
worse. You can also try uninstalling the dependent RPM's, but they
undoubtedly have a collection of other packages dependent on them in turn.

Basically the Redhat model assumes that you subscribe to their Redhat
Network ($$$) and you get all your RPM updates at the same time. That's
the only way to resolve all the dependencies. But you'll probably have
to wait until 2009 for them to add MySQL 5 to their updates.

I'm very sorry to be so negative. I usually try to be much more
"can-do" on these newsgroups.

You can install MySQL from the tar.gz distribution instead of using
RPM's. Install the MySQL 5 distribution adjacent to, but not
overlapping, the existing MySQL 4 RPM's installed. Then shut off the
MySQL 4 service and disable it using chkconfig. But leave it installed
so that it resolves those other dependencies.

You can also build MySQL from source, and specify where to install it
when you configure the build.

Regards,
Bill K.
Oct 12 '05 #2
Hi,

I had the same problem with Fedora Core 4 - I managed to update the server
anyhow (unfortunately, I really can't remember how I did it), but it was a
painful task. You might have the best chances if you install Linux without
Apache and MySQL, install MySQL 5 using the RPMs and afterwards install
Apache (and pray that there are no failed dependencies then).

Recently I tried the same with SuSE 10 and it was very easy. So maybe it's
really the better option to consider another distribution.

Good luck!

Markus
Oct 15 '05 #3
srinivasb
1 New Member
The solutions seems to be using "shared-compat" rpm rather than "shared-standard" rpm. Check the bug notes at: http://bugs.mysql.com/bug.php?id=17035 for more information.

-S
Mar 20 '06 #4

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

0
1474
by: Morten Gulbrandsen | last post by:
Hello programmers this is my path, C:\mysql\bin>path PATH=C:\WINNT\system32;C:\WINNT;C:\WINNT\System32\Wbem;C:\mysql\bin After installing 4.1.0-alpha-max-debug I try to start winmysqladmin.exe
0
1420
by: Jonathan Hilgeman | last post by:
Currently, I'm running 3.23.51 on Red Hat 7.1, and I'm contemplating upgrading to MySQL 4.0, but I'm not sure what to expect. I don't know if MySQL 4.0 is fully backwards-compatible with 3.23.x versions, or if something is going to break if I upgrade. What are the main advantages of upgrading to 4.0? Speed? Features? I can go through the...
0
2043
by: Richard Gabriel | last post by:
Hi all, The following keeps happening and I can't pinpoint a query that is causing it. It did not happen in 3.23.x, but started upon upgrading to 4.0.14. The operating system/hardware information is as follows: RedHat 8.0 - kernel 2.4.18SMP 4x Xeon Processors 4x 80GB SCSI drives (hardware RAID-10) 2GB RAM
0
5786
by: Mike Chirico | last post by:
With mysql-4.1.1-alpha, using any User Defined Function ( UDF) at the query execution stage, on Linux 2.6, gave me the following error: "ERROR 2013 (HY000): Lost connection to MySQL server during query" However, upgrading to mysql-4.1.2-alpha seemed to solve the problem. Both versions were configured exactly as follows ...
2
1624
by: wellington fan | last post by:
Dear newsies, My ISP has offered to upgrade my servers from 3.23 to 4.1. I'm excited by the potential gains in performance, and the ability to write subqueries, but am wary of any forward incompatibilities. I have a mass of PHP code with MySQL throughout. I don't relish peeking into every file and making a determination of 'it should...
5
4139
by: Grant Nosbush | last post by:
I have searched the newsgroups and the web trying to solve this problem and just can't get it. Maybe someone will be able to help. I am getting the following error when I try to view a test page in my browser. This test page just reads a table in mysql and outputs the results. Fatal error: Call to undefined function: mysql_connect() in...
2
1327
by: Jonathan | last post by:
Hi! I am trying to get my C++ connecting and communicating with a mySQL server on my developer PC. I did a next-next-finish installation of mySQL and installed the developer libraries as well. I started programming in MS VC++ and can communicate with my server. However, every time I connect with a user that has no password (blank) I am...
1
1470
nirmalsingh
by: nirmalsingh | last post by:
hi my coding is <?php /* You should never post secure details like IP address, username and password on a public forum Removed for security Banfa Admin */
4
2634
by: adam.timberlake | last post by:
Me again! I am trying to create a currency converter function for my eCommerce that still pet treats. I am a little short on money recently and so cannot afford a programmer. Can somebody tell me why my script tells me that I have a syntax error on the "CONST" line. I am trying to follow the article below. Article:...
0
7730
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. ...
0
7975
jinu1996
by: jinu1996 | last post by:
In today's digital age, having a compelling online presence is paramount for businesses aiming to thrive in a competitive landscape. At the heart of this digital strategy lies an intricately woven tapestry of website design and digital marketing. It's not merely about having a website; it's about crafting an immersive digital experience that...
1
7492
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For...
1
5381
isladogs
by: isladogs | last post by:
The next Access Europe User Group meeting will be on Wednesday 1 May 2024 starting at 18:00 UK time (6PM UTC+1) and finishing by 19:30 (7.30PM). In this session, we are pleased to welcome a new presenter, Adolph Dupré who will be discussing some powerful techniques for using class modules. He will explain when you may want to use classes...
0
5101
by: conductexam | last post by:
I have .net C# application in which I am extracting data from word file and save it in database particularly. To store word all data as it is I am converting the whole word file firstly in HTML and then checking html paragraph one by one. At the time of converting from word file to html my equations which are in the word document file was convert...
0
3510
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in...
0
3491
by: adsilva | last post by:
A Windows Forms form does not have the event Unload, like VB6. What one acts like?
1
1957
by: 6302768590 | last post by:
Hai team i want code for transfer the data from one system to another through IP address by using C# our system has to for every 5mins then we have to update the data what the data is updated we have to send another system
0
777
bsmnconsultancy
by: bsmnconsultancy | last post by:
In today's digital era, a well-designed website is crucial for businesses looking to succeed. Whether you're a small business owner or a large corporation in Toronto, having a strong online presence can significantly impact your brand's success. BSMN Consultancy, a leader in Website Development in Toronto offers valuable insights into creating...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.