468,119 Members | 1,962 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,119 developers. It's quick & easy.

UCLinux hostname not making it to dhcp server

Plater
7,872 Expert 4TB
For starters we're using UCLinux on a blackfin (analog devices)device.
I am hoping that doesn't matter and there's a general way to do this.

Basically we are trying to get the name resolution to work.
The hostname shows up and appears to be fine when looked at on the device.
The device runs a dhcp client and obtains an IP just fine.
But when we go to our dhcp/dns server, where it would say
"PlaterDell 192.168.1.55" (my computer name) and then
"Blackfin 192.168.1.7"
But instead it just says " 192.168.1.7"

Its like the blackfin device never sends a name when it requests an IP (or whatever other protocal handles that)
Now we turned off netbios on the uclinux, but it wasn't working even when it was on. I have never been able to ping "blackfin" (which is its hostname)
If i do an NSLOOKUP 192.168.1.3 our dns returns the name of the previous device to have that ip "PlaterLaptop".
But if I do an NSLOOKUP PlaterLaptop, it returns me the current ip address of my laptop: 192.168.1.40.

So there are two entries on the dns server with the name PlaterLaptop, one of them is stale and should have been replaced with "blackfin"

Is there some setting on the linux side to have it send its name up to the server, or is it problem with our dns/nameserver not flushing its cache?

Any ideas would be helpful.
Jan 21 '09 #1
4 3847
ashitpro
542 Expert 512MB
I am not sure about your platform.
But generally this setting exists inside /etc/dhcp3/dhcpclient.conf
Look for similar file in etc directory...
You have to uncomment the line similar to next..

send host-name "<hostname>";

Don't forget to set the hostname..
Jan 22 '09 #2
Plater
7,872 Expert 4TB
Thanks for the point in the right direction!
We did not have a dhcp.conf file on the system itself.
There WAS one in the source code under an "examples" directory.
So far what has helped somewhat was that when we run dhcpd&, we should have been runnning dhcp -h BlackFin&
Seems to register correctly with the server, as the name shows up on the dhcp clients list now. But we still cannot ping or otherwise lookup the name.
I am thinking there is a disconnect between the server's dns server and dhcp server
Jan 22 '09 #3
ashitpro
542 Expert 512MB
Check your /etc/resolv.conf
this is the file which contains the DNS server...
Check if it set properly...

If you want immediate solution then consider this little hack:
You can edit "/etc/hosts" file and put ip/hostname mapping...

Regards,
Ash
Jan 23 '09 #4
Plater
7,872 Expert 4TB
So what seems to be workable was, in a script that runs at boot:
Setting hostname to desired name with HOSTNAME
Stop inetd
Replace hosts file
Replace the samba.conf
Start NMBD manually
Start inetd
(we can also start the dhcp process with a name so the dhcp leases shows who requested it)

This allows us to ping the name and use the network shares. We still cannot do an nslookup as the name does not make it to our seperate dns server. (It could be a domain issue, could be an issue of snycing between dhcp and dns)
But its capable of communicating with the name we set now (by using netbios lookup) so it will work for now.
Jan 30 '09 #5

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

8 posts views Thread by Richard D. Ford | last post: by
2 posts views Thread by WhatHappend | last post: by
5 posts views Thread by Richard | last post: by
reply views Thread by GHUM | last post: by
1 post views Thread by Screenbert | last post: by
reply views Thread by hide1713 | last post: by
reply views Thread by =?Utf-8?B?Z29tZXpqdQ==?= | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.