469,591 Members | 2,120 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,591 developers. It's quick & easy.

The difference between preview and real.

Hi,

I want to have a special layer show up on all my pages, the layer page is
Layer.htm. So I have this line in MyPage.htm,
<!--#include file="Layer.htm"-->
and the preview is fine, with the layer show up on the top of the
MyPage.htm.
However, in real world, when I browse to my website and point to MyPage.htm,
the layer just disappear.
Would anyone tell me how to fix thsi problem? I am using DreamWeaver.
Any help will be appreciated.

Jason
Jul 20 '05 #1
2 1064
Jason wrote:
Hi,

I want to have a special layer show up on all my pages, the layer page is
Layer.htm. So I have this line in MyPage.htm,
<!--#include file="Layer.htm"-->
and the preview is fine, with the layer show up on the top of the
MyPage.htm.
However, in real world, when I browse to my website and point to MyPage.htm,
the layer just disappear.
Would anyone tell me how to fix thsi problem? I am using DreamWeaver.
Any help will be appreciated.


This has nothing to do with client-side javascript. Open the real page,
view the source and see if its actually including the file Layer.htm in
the source code.

If its not showing in the source, figure out why (probably a path problem).

If its showing in the source, then see what else in the page might be
preventing it from displaying on the page.
--
Randy
Chance Favors The Prepared Mind
comp.lang.javascript FAQ - http://jibbering.com/faq/
Jul 20 '05 #2
Then include .html file method is not working 'cuase I'm using Tomcat,
and in the Tomcat I have to modify some little things such as
1.renaming servlets-ssi.renametojar to servlets-ssi.jar.
2.Uncomment some tags in the web.xml file.
Now the ontop layer is showing fine, however I have to adjust some space for
a nicer view.
Thanks.
"Randy Webb" <hi************@aol.com> ???
news:z-********************@comcast.com ???...
Jason wrote:
Hi,

I want to have a special layer show up on all my pages, the layer page is Layer.htm. So I have this line in MyPage.htm,
<!--#include file="Layer.htm"-->
and the preview is fine, with the layer show up on the top of the
MyPage.htm.
However, in real world, when I browse to my website and point to MyPage.htm, the layer just disappear.
Would anyone tell me how to fix thsi problem? I am using DreamWeaver.
Any help will be appreciated.
This has nothing to do with client-side javascript. Open the real page,
view the source and see if its actually including the file Layer.htm in
the source code.

If its not showing in the source, figure out why (probably a path

problem).
If its showing in the source, then see what else in the page might be
preventing it from displaying on the page.
--
Randy
Chance Favors The Prepared Mind
comp.lang.javascript FAQ - http://jibbering.com/faq/

Jul 23 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

3 posts views Thread by bissatch | last post: by
reply views Thread by suresh191 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.