By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,693 Members | 1,822 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,693 IT Pros & Developers. It's quick & easy.

How to disable Iframe resize???

P: 55
Hi !

I have a problem with my frame size. The frame is used to display results
in form of html table generated dynamically. Sometimes the frame resizes
its height according to the content in the page it loaded, due to which it
disturbs the whole structure of my webpage. How do i restrict the frame so
that it does not resize itself?

Although i used the attributes height & width ... but still it resizes
automatically??

Thanks in advance

Regards
Hash
Nov 21 '07 #1
Share this Question
Share on Google+
4 Replies


acoder
Expert Mod 15k+
P: 16,027
Have you used a fixed height and width? Show your code.
Nov 21 '07 #2

P: 18
Hi !

I have a problem with my frame size. The frame is used to display results
in form of html table generated dynamically. Sometimes the frame resizes
its height according to the content in the page it loaded, due to which it
disturbs the whole structure of my webpage. How do i restrict the frame so
that it does not resize itself?

Although i used the attributes height & width ... but still it resizes
automatically??

Thanks in advance

Regards
Hash

Hello,

try setting the noresize attribute.

ex :
<frame name="hiddenFrame" scr="about:blank" noresize="noresize" />

Hope this helps
Nov 22 '07 #3

P: 55
Hi acoder, Nibus !

I tried with the proposed noresize="noresize", but still it didnt
work....

the code which i m using is as follows:

Frame where the html page opens:
---------------------------------------------------
[HTML]<iframe id="ResultFrame" name="ResultFrame" width="190" height="175" frameborder="1" noresize="noresize" ></iframe>
[/HTML]
dynamically generated page:
-----------------------------------------
[HTML]<head><style>.thfont{font-size:8pt;font-family:'Tahoma'} .tdfont{font-size:7pt;font-family:Tahoma}</style></head>
<body onload='arsim_search();'><table id='sim_search_table' dir='rtl' border='2' style='display:none;border-collapse:collapse; border-bottom-color:#6ba849; border-right-color:#6ba849; border-left-color:#6ba849; border-top-color:#6ba849'><tr><td colspan='6'style='font-size:16x'> <strong><u>%u0646%u062A%u0627%u0626%u062C%20%u0627 %u0644%u0628%u062D%u062B</strong></u></td></tr> <tr class='thfont'><th>%u0627%u0644%u062D%u064A</th> <th>%u0627%u0644%u0634%u0627%u0631%u0639</th> <th>%u0631%u0645%u0632%20%u0628%u0631%u064A%u062F% u0649</th> <th>%u0631%u0642%u0645%20%u0627%u0644%u0645%u0628% u0646%u0649</th> <th>%u0627%u0644%u0631%u0642%u0645%20%u0627%u0644% u0625%u0636%u0627%u0641%u0649</th> <th>%u062A%u0643%u0628%u064A%u0631</th></tr> <tr class='tdfont' id='?objectid=98178&label=12991-3908-8522&minX=46.6245015335&minY=24.5826972616&maxX=46 .6248041351&maxY=24.5829684882'> <td>%u062D%u064A%20%u0627%u0644%u0633%u0648%u064A% u062F%u064A%20%u0627%u0644%u063A%u0631%u0628%u064A </td> <td>%u0634%u0627%u0631%u0639%20%u0627%u0644%u0645% u0633%u0644%u0645%u0629</td> <td>12991</td><td>3908</td><td>8522</td><td align=center><IMG SRC='../images/tool_zoomin.png' alt='ZoomTo' onClick=ZoomToPar(98178,'12991-3908-8522',46.6245015335,24.5826972616,46.6248041351,24 .5829684882); style='cursor:hand';></td></tr> <tr class='tdfont' id='?objectid=99984&label=12991-3908-7692&minX=46.6242629309&minY=24.5751039169&maxX=46 .6248352232&maxY=24.5755571956'> <td>%u062D%u064A%20%u0627%u0644%u0633%u0648%u064A% u062F%u064A%20%u0627%u0644%u063A%u0631%u0628%u064A </td> <td>%u0634%u0627%u0631%u0639%20%u0627%u0628%u064A% 20%u0627%u0644%u063A%u0646%u0627%u0626%u0645%20%u0 627%u0644%u0647%u0645%u062F%u0627%u0646%u064A</td> <td>12991</td><td>3908</td><td>7692</td><td align=center><IMG SRC='../images/tool_zoomin.png' alt='ZoomTo' onClick=ZoomToPar(99984,'12991-3908-7692',46.6242629309,24.5751039169,46.6248352232,24 .5755571956); style='cursor:hand';></td></tr> <tr class='tdfont' id='?objectid=426258&label=12991-3908-7620&minX=46.6243850924&minY=24.5745293931&maxX=46 .6245952336&maxY=24.5747543781'> <td>%u062D%u064A%20%u0627%u0644%u0633%u0648%u064A% u062F%u064A%20%u0627%u0644%u063A%u0631%u0628%u064A </td> <td>%u0634%u0627%u0631%u0639%20%u0642%u0631%u0636% u0629</td><td>12991</td><td>3908</td><td>7620</td><td align=center><IMG SRC='../images/tool_zoomin.png' alt='ZoomTo' onClick=ZoomToPar(426258,'12991-3908-7620',46.6243850924,24.5745293931,46.6245952336,24 .5747543781); style='cursor:hand';></td></tr></table></body>[/HTML]
----------------------------------------------------------------------------------------------------------

Note: In the above code the escaped characters are for arabic text.

regards,
Hash
Nov 24 '07 #4

acoder
Expert Mod 15k+
P: 16,027
Try setting the overflow CSS property to "auto".
Nov 26 '07 #5

Post your reply

Sign in to post your reply or Sign up for a free account.