By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,466 Members | 1,138 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,466 IT Pros & Developers. It's quick & easy.

How do I prevent IE Active Content warning message appearing?

P: n/a
I have now finally got the JSCookMenu to work (hooray!)

But every time I test it, my IE browser delivers an "Information Bar"
warning about active content.

The MS Help says "This message appears when a Web page on your computer
tries to run a script or ActiveX control."

I have tried setting Security to as low as possible, and enabling everything
I can see in the internet zone security settings .... but I can't stop this
warning from appearing.

HOW can I stop it?

NOTE please: I would prefer, if known, the MINIMUM security reduction
needed to stop it - but if no one knows that then what more general settings
do I need to change???

As I've said above, the [Security] tab in settings seems not to affect
things - even if I totally end IE and reload it.

TIA

Aug 12 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a
Richard said the following on 8/12/2005 6:42 PM:
I have now finally got the JSCookMenu to work (hooray!)
From your post, obviously not.
But every time I test it, my IE browser delivers an "Information Bar"
warning about active content.

The MS Help says "This message appears when a Web page on your computer
tries to run a script or ActiveX control."

I have tried setting Security to as low as possible, and enabling everything
I can see in the internet zone security settings .... but I can't stop this
warning from appearing.

HOW can I stop it?


Stop using ActiveX controls.....

--
Randy
comp.lang.javascript FAQ - http://jibbering.com/faq & newsgroup weekly
Aug 13 '05 #2

P: n/a

"Randy Webb" <Hi************@aol.com> wrote in message
news:f_********************@comcast.com...
Richard said the following on 8/12/2005 6:42 PM:

[..snipped...]
I have tried setting Security to as low as possible, and enabling
everything I can see in the internet zone security settings .... but I
can't stop this warning from appearing.

HOW can I stop it?


Stop using ActiveX controls.....


Thanks for the reply.

Could you please expand on how and where I may be using ActiveX controls in
JSCookMenu and how I can stop using them?
Aug 13 '05 #3

P: n/a


Richard wrote:

But every time I test it, my IE browser delivers an "Information Bar"
warning about active content.

The MS Help says "This message appears when a Web page on your computer
tries to run a script or ActiveX control."


That is a new security feature in IE 6 under Windows XP Service Pack 2
(sometimes called Windows XP SP 2) where the local file zone implements
that restriction.
You can do two things to avoid that prompt:
1) install and run a local web server (e.g. IIS if you have Windows XP
Professional or Apache for instance) to no longer load your pages from
the file system (e.g. file:///C:/dir/subdir/file.html) but from the
local web server instead (e.g.
http://localhost/virtualdir/virtualsubdir/file.html).
2) insert a so called mark of the web in your HTML documents:
<http://msdn.microsoft.com/workshop/author/dhtml/overview/motw.asp>
That way IE treats your HTML documents as if they are loaded from the
URL in the mark of the web.

--

Martin Honnen
http://JavaScript.FAQTs.com/
Aug 13 '05 #4

P: n/a
Richard said the following on 8/13/2005 6:15 AM:
"Randy Webb" <Hi************@aol.com> wrote in message
news:f_********************@comcast.com...
Richard said the following on 8/12/2005 6:42 PM:


[..snipped...]
I have tried setting Security to as low as possible, and enabling
everything I can see in the internet zone security settings .... but I
can't stop this warning from appearing.

HOW can I stop it?


Stop using ActiveX controls.....

Thanks for the reply.

Could you please expand on how and where I may be using ActiveX controls in
JSCookMenu and how I can stop using them?


Since I do not know, and honestly don't care, what JSCookMenu is, to
answer you question is impossible.

Since you say the browser issues an ActiveX warning, then you *must* be
using an ActiveX control because otherwise the browser wouldn't issue
the warning to start with.

--
Randy
comp.lang.javascript FAQ - http://jibbering.com/faq & newsgroup weekly
Aug 13 '05 #5

P: n/a
"Randy Webb" <Hi************@aol.com> kirjoitti
viestissä:T4********************@comcast.com...
Richard said the following on 8/13/2005 6:15 AM:
"Randy Webb" <Hi************@aol.com> wrote in message
news:f_********************@comcast.com...
Richard said the following on 8/12/2005 6:42 PM:


[..snipped...]
I have tried setting Security to as low as possible, and enabling
everything I can see in the internet zone security settings .... but I
can't stop this warning from appearing.

HOW can I stop it?

Stop using ActiveX controls.....

Thanks for the reply.

Could you please expand on how and where I may be using ActiveX controls
in JSCookMenu and how I can stop using them?


Since I do not know, and honestly don't care, what JSCookMenu is, to
answer you question is impossible.

Since you say the browser issues an ActiveX warning, then you *must* be
using an ActiveX control because otherwise the browser wouldn't issue the
warning to start with.

Randy Webb, back to school. You have not learned one thing about boolean
mathematics. What does OR mean? If a warning says: "a script _or_ ActiveX",
does that mean that
a) ActiveX *must* have been used.
b) ActiveX has not been used.
c) either a script or ActiveX has been used.

Hint 1: It's not a.
Hint 2: It's c.

--
SETI @ Home - Donate your cpu's idle time to science.
Further reading at <http://setiweb.ssl.berkeley.edu/>
Kimmo Laine <et****************@5P4Mgmail.com>
Aug 13 '05 #6

P: 1
The following link provides a concise explanation of the LOCAL SECURITY ZONE (the cause of your info bar woes) and some good little work arounds.
http://weblogs.asp.net/jgalloway/arc...20/218123.aspx
Aug 19 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.