By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,960 Members | 1,563 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,960 IT Pros & Developers. It's quick & easy.

IE Warnings after adding Mouseover code - but not with other sites??

P: n/a
Hi all,
very new to web design in general and Javacript in particular.

I found....
http://www.peterkerr.freeserve.co.uk...over/html.html

and used the mouseover example to add some changing buttons to my own
web page....
It works, but when I run the page IE 6 gives me the active content
warning. 'Internet Explorer has restricted this file from Showing
active content that could access your computer. Click here for
options.'
If I click and allow blocked content it all works fine.

I didn't get the message before I added the Javascript. So it's the
script that's caused it.
HOWEVER....

If I run other pages, including the one I copied the code from, I don't
get this message.
The only difference I can find is that my links refer to a reference on
the same page rather than to a new page.

Am I missing a trick?
Regards
Graeme

Jul 23 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Stranger - I loaded it to my Web space on line and when I connect to it
it doesn't give the warnings???? Only when I run it locally.

Please explain someone :-Z

Graeme

Jul 23 '05 #2

P: n/a
gr************@hotmail.com wrote:
Stranger - I loaded it to my Web space on line and when I connect to it
it doesn't give the warnings???? Only when I run it locally.

Please explain someone :-Z

Graeme


Search the archives for "mark of the web" and read the *entire* thread.
What you are seeing is increased security in IE6 SP2 when run from the
local zone.

--
Randy
comp.lang.javascript FAQ - http://jibbering.com/faq & newsgroup weekly
Jul 23 '05 #3

P: n/a
Thanks Randy - explains my problems perfectly.
Cheers
Graeme

Jul 23 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.