471,091 Members | 1,526 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,091 software developers and data experts.

Problem with Pop Up and Netscape 7.0

My Website (Template) uses JavaScript to create a pop-up window in the
gallery.
With IE it works fine, but not with my Netscape 7.0.
No Pop up apears.

In the script I found the line:

if (browser_type == "Microsoft Internet Explorer" && (browser_version >=
4) && (navigator.userAgent.indexOf("Windows") != -1)) {

has it something to do with not working?
Thanks a lot
Christina

Jul 23 '05 #1
5 1110
"Christina Joch" <da*****@gmx.at> wrote in message
news:41**********@gmx.at...
My Website (Template) uses JavaScript to create a pop-up window in the
gallery.
With IE it works fine, but not with my Netscape 7.0.
No Pop up apears.

In the script I found the line:

if (browser_type == "Microsoft Internet Explorer" && (browser_version >=
4) && (navigator.userAgent.indexOf("Windows") != -1)) {

has it something to do with not working?
Thanks a lot
Christina

Netscape 7.0 No Pop up apears.

if (browser_type == "Microsoft Internet Explorer"

Wait, wait, it'll come to you...
Jul 23 '05 #2
Christina Joch wrote:
My Website (Template) uses JavaScript to create a pop-up window in the
gallery.
With IE it works fine, but not with my Netscape 7.0.
No Pop up apears.

In the script I found the line:

if (browser_type == "Microsoft Internet Explorer" && (browser_version >=
4) && (navigator.userAgent.indexOf("Windows") != -1)) {

has it something to do with not working?


Very likely, however without seeing a bit more code it's hard to
propose a solution. Do you have a link to the web site? Or can you
post a bit more code that shows what the browser detection is trying to
achieve?

If it's something useful, then a feature detection method can almost
always be substituted that is far more reliable. Otherwise, it likely
can be ditched altogether.
--
Rob
Jul 23 '05 #3
The URL is
<http://www.fotografisches.at>
Thanl you very much
Christina

RobG schrieb:
Christina Joch wrote:
My Website (Template) uses JavaScript to create a pop-up window in the
gallery.
With IE it works fine, but not with my Netscape 7.0.
No Pop up apears.

In the script I found the line:

if (browser_type == "Microsoft Internet Explorer" && (browser_version >=
4) && (navigator.userAgent.indexOf("Windows") != -1)) {

has it something to do with not working?


Very likely, however without seeing a bit more code it's hard to
propose a solution. Do you have a link to the web site? Or can you
post a bit more code that shows what the browser detection is trying to
achieve?

If it's something useful, then a feature detection method can almost
always be substituted that is far more reliable. Otherwise, it likely
can be ditched altogether.


Jul 23 '05 #4
Christina Joch wrote:
The URL is
<http://www.fotografisches.at>
Thanl you very much
Christina

RobG schrieb:
Christina Joch wrote:
My Website (Template) uses JavaScript to create a pop-up window in the
gallery.
With IE it works fine, but not with my Netscape 7.0.
No Pop up apears.


I tried the site in Netscape 7.2 and it seems to work fine. Do you
still have the problem? The bit using browser detection seems to be
just looking for IE and should not affect the general use of the site.

I can't see that making the pop-ups fixed size helps at all, it means
you have to scroll in Netscape to reach them. In IE, they are
frequently hidden and you can't scroll to them.

The link behind your banner goes to index.htm, which appears to be
broken - perhaps it is actually called default.html?

Changing the link to <URL:http://www.fotografisches.at/> should fix it.

Incidentally, I like the look of the site and the photography is great!
--
Rob
Jul 23 '05 #5
Iīve downloaded also Netscape 7.2 now and it works with it.
But with Netscape 7.0 it didnīt work.
But I donīt know why.
Thanks
Christina

RobG wrote:
Christina Joch wrote:
The URL is
<http://www.fotografisches.at>
Thanl you very much
Christina

RobG schrieb:
Christina Joch wrote:

My Website (Template) uses JavaScript to create a pop-up window in the
gallery.
With IE it works fine, but not with my Netscape 7.0.
No Pop up apears.

I tried the site in Netscape 7.2 and it seems to work fine. Do you
still have the problem? The bit using browser detection seems to be
just looking for IE and should not affect the general use of the site.

I can't see that making the pop-ups fixed size helps at all, it means
you have to scroll in Netscape to reach them. In IE, they are
frequently hidden and you can't scroll to them.

The link behind your banner goes to index.htm, which appears to be
broken - perhaps it is actually called default.html?

Changing the link to <URL:http://www.fotografisches.at/> should fix it.

Incidentally, I like the look of the site and the photography is great!

Jul 23 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

3 posts views Thread by Chris Leonard | last post: by
11 posts views Thread by Jonny | last post: by
53 posts views Thread by Andrew Poulos | last post: by
8 posts views Thread by Bob Skutnick | last post: by
10 posts views Thread by Stephen | last post: by
5 posts views Thread by Stephen | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.