468,110 Members | 1,910 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,110 developers. It's quick & easy.

Here's one possible solution for slow rollovers in IE

Rollovers on a web page I created were instantaneous on my computer when
the page was loaded directly from my hard drive, but were painfully slow
when loaded from the web. However, on another computer the rollovers were
speedy when connected to the web. Eventually I found that one of the
settings in IE accounted for the difference. In the menu Tools/Internet
Options/General/Settings change from "Every visit to the page" to
"Automatically".
Jul 23 '05 #1
3 1328
Norman Swartz wrote:
Rollovers on a web page I created were instantaneous on my computer when
the page was loaded directly from my hard drive, but were painfully slow
when loaded from the web. However, on another computer the rollovers were
speedy when connected to the web. Eventually I found that one of the
settings in IE accounted for the difference. In the menu Tools/Internet
Options/General/Settings change from "Every visit to the page" to
"Automatically".


That's not a solution at all, since

a) there are people who don't use IE (like me) and so don't care
about those settings;

b) there are people who don't change your configuration for your
script-kiddie games;

c) there are people who (have to) use a UA that does not support
changing the document dynamically, i.e. one that does not
provide the required DOM;

d) there are people who (have to) use a UA with support for
client-side scripting disabled or restricted;

e) there are people who (have to) use a UA that does not have
support for client-side scripting at all.

Have I forgotten something?
PointedEars
Jul 23 '05 #2
Norman Swartz wrote:
Rollovers on a web page I created were instantaneous on my computer when
the page was loaded directly from my hard drive, but were painfully slow
when loaded from the web. However, on another computer the rollovers were
speedy when connected to the web. Eventually I found that one of the
settings in IE accounted for the difference. In the menu Tools/Internet
Options/General/Settings change from "Every visit to the page" to
"Automatically".


That's not a solution at all, since

a) there are people who don't use IE (like me) and so don't care
about those settings;

b) there are people who don't change their configuration for your
script-kiddie games;

c) there are people who (have to) use a UA that does not support
changing the document dynamically, i.e. one that does not
provide the required DOM;

d) there are people who (have to) use a UA with support for
client-side scripting disabled or restricted;

e) there are people who (have to) use a UA that does not have
support for client-side scripting at all.

Have I forgotten something?
PointedEars
Jul 23 '05 #3
Thomas 'PointedEars' Lahn wrote:
<--snip lots of useless babble-->
Have I forgotten something?


Yes, you forgot two things:

1) To fix your newsreader so it doesn't double-post.
2) The thread was about slow rollovers in *IE*. Based on a rollover
being present, then its safe to assume that scripting is enabled. IE
doesn't handle CSS rollovers yet (if it ever does). Since its an IE-only
solution, you can discount all your babbling about "other UA's".

Your move.

--
Randy
comp.lang.javascript FAQ - http://jibbering.com/faq
Answer:It destroys the order of the conversation
Question: Why?
Answer: Top-Posting.
Question: Whats the most annoying thing on Usenet?
Jul 23 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.

By using this site, you agree to our Privacy Policy and Terms of Use.