By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
454,651 Members | 1,316 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 454,651 IT Pros & Developers. It's quick & easy.

Incompatible JVM and Java project compiler settings

P: 2
When trying to use jbuilder designer i keep getting the error:
"You run Eclipse under JVM version 1.5.0_12, but Java project requires at least 1.6, so Designer can not be used. See FAQ for more information.
Can someone please advise me on how to solve this issue. Any help will be highly appreciated.
Oct 3 '13 #1
Share this Question
Share on Google+
5 Replies


P: 94
Maybe you should update the Java Development Kit (JDK) and/or the Java Runtime Environment (JRE).
Oct 3 '13 #2

P: 2
Thank you for responding. I have the latest JDK installed (1.7) also I have the latest JRE installed (version 7 update 25) so it may be another issue.
Oct 3 '13 #3

Nepomuk
Expert 2.5K+
P: 3,112
It seems that there's also a Java version 1.5.0_12 still installed; my guess would be that the old version may be the one in your PATH variable. My suggestions would be:
  1. Unless you need them for a specific task, deinstall all but the newest Java version
  2. Check your PATH variable and make sure it's pointing to your JDK 1.7 installation
Then, just to make sure, restart your computer and see whether it works.
Oct 4 '13 #4

P: 1
any update on this ?
Oct 16 '13 #5

Nepomuk
Expert 2.5K+
P: 3,112
Are you having a similar problem then? If so, I'd recommend trying the steps I described and telling us whether it worked.
Oct 16 '13 #6

Post your reply

Sign in to post your reply or Sign up for a free account.