By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
454,237 Members | 1,256 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 454,237 IT Pros & Developers. It's quick & easy.

unsupported major .minor version 51.0

P: 4
I am trying to use notepad++ as my all-in-one tool edit, run, compile etc.

I have jre installed, i have setup my path variable to .../bin directory.

When I run my "Hello world" in notepad++ , I get this message:

Expand|Select|Wrap|Line Numbers
  1. java.lang.UnsupportedClassVersionError: test_hello_world :
  2.  Unsupported major.minor version 51.0
  3.     at java.lang.ClassLoader.defineClass1(Native Method)
  4.     at java.lang.ClassLoader.defineClassCond(Unknown Source)
  5.        ......................................... 
  6.  
I think the problem here is about versions, some version of java may be old or too new.

how do i fix it?

should i install jdk , and setup my path variable to JDK instead of jre?

difference between PATH variable in jre or jdk?
Apr 30 '12 #1
Share this question for a faster answer!
Share on Google+

Post your reply

Sign in to post your reply or Sign up for a free account.