By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
444,208 Members | 1,592 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 444,208 IT Pros & Developers. It's quick & easy.

java.util.MissingResourceException: Can't find bundle for base name MessagesBundle

oll3i
100+
P: 679
when i run my jsp file i get an error


SEVERE: Servlet.service() for servlet jsp threw exception
java.util.MissingResourceException: Can't find bundle for base name MessagesBundle, locale pl_PL
at java.util.ResourceBundle.throwMissingResourceExcep tion(ResourceBundle.java:1508)
at java.util.ResourceBundle.getBundleImpl(ResourceBun dle.java:1262)
at java.util.ResourceBundle.getBundle(ResourceBundle. java:789)
at Classes.Config.<init>(Config.java:20)
at Classes.Config.getInstance(Config.java:11)
at org.apache.jsp.candidates.index_jsp._jspService(in dex_jsp.java:51)
at org.apache.jasper.runtime.HttpJspBase.service(Http JspBase.java:98)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:803)
at org.apache.jasper.servlet.JspServletWrapper.servic e(JspServletWrapper.java:331)
at org.apache.jasper.servlet.JspServlet.serviceJspFil e(JspServlet.java:329)
at org.apache.jasper.servlet.JspServlet.service(JspSe rvlet.java:265)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:803)
at org.apache.catalina.core.ApplicationFilterChain.in ternalDoFilter(ApplicationFilterChain.java:269)
at org.apache.catalina.core.ApplicationFilterChain.do Filter(ApplicationFilterChain.java:188)
at org.apache.catalina.core.StandardWrapperValve.invo ke(StandardWrapperValve.java:213)
at org.apache.catalina.core.StandardContextValve.invo ke(StandardContextValve.java:174)
at org.apache.catalina.core.StandardHostValve.invoke( StandardHostValve.java:127)
at org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.java:117)
at org.apache.catalina.core.StandardEngineValve.invok e(StandardEngineValve.java:108)
at org.apache.catalina.connector.CoyoteAdapter.servic e(CoyoteAdapter.java:174)
at org.apache.coyote.http11.Http11Processor.process(H ttp11Processor.java:874)
at org.apache.coyote.http11.Http11BaseProtocol$Http11 ConnectionHandler.processConnection(Http11BaseProt ocol.java:665)
at org.apache.tomcat.util.net.PoolTcpEndpoint.process Socket(PoolTcpEndpoint.java:528)
at org.apache.tomcat.util.net.LeaderFollowerWorkerThr ead.runIt(LeaderFollowerWorkerThread.java:81)
at org.apache.tomcat.util.threads.ThreadPool$ControlR unnable.run(ThreadPool.java:689)
at java.lang.Thread.run(Thread.java:619)
2008-06-03 13:25:19 org.apache.coyote.http11.Http11BaseProtocol pause
INFO: Pausing Coyote HTTP/1.1 on http-8080
2008-06-03 13:25:23 org.apache.catalina.core.StandardService stop
INFO: Stopping service Catalina
2008-06-03 13:25:34 org.apache.coyote.http11.Http11BaseProtocol destroy
INFO: Stopping Coyote HTTP/1.1 on http-8080
2008-06-03 13:25:34 org.apache.catalina.core.AprLifecycleListener lifecycleEvent
INFO: Failed shutdown of Apache Portable Runtime

i know polish locale is not tested what should i do?


Thank You
Jun 3 '08 #1
Share this Question
Share on Google+
6 Replies


Expert 10K+
P: 11,448
Does a file "MessagesBundle" or "MessagesBundle_pl" exist?

kind regards,

Jos
Jun 3 '08 #2

oll3i
100+
P: 679
You are right i had a typo
Jun 3 '08 #3

oll3i
100+
P: 679
i corrected the typo and i still get the same error:(
Jun 4 '08 #4

10K+
P: 13,264
i corrected the typo and i still get the same error:(
Did you rebuild the project?
Also Jos' question above is still valid.
Jun 4 '08 #5

Expert 10K+
P: 11,448
i corrected the typo and i still get the same error:(
Well, the exception tells you that it still can't find that resource bundle so either
the name is not correct or the file is not stored in the right place.

kind regards,

Jos
Jun 4 '08 #6

oll3i
100+
P: 679
yupi it works i moved it to the classes package and it works :)
Jun 4 '08 #7

Post your reply

Sign in to post your reply or Sign up for a free account.