By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
446,266 Members | 1,816 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 446,266 IT Pros & Developers. It's quick & easy.

java.net.SocketException: Address already in use

P: 16
Hello, I have a JBoss web application (v4.04GA), run on an Apache Tomcat HTTP server (v5.5.17). It connects with a MySQL database (v4.1.10). My web application takes an XML file, creates a CSV file from database entries, and returns the file to the user.

This has worked well in general. However, a particular file is giving me problems. It compiles a total of 1800 entries from the database, and before it returns the CSV file, it gives the following error:

Expand|Select|Wrap|Line Numbers
  1. 16:42:47,412 ERROR [STDERR] com.mysql.jdbc.CommunicationsException: Communications link failure due to underlying exception: 
  2.  
  3. ** BEGIN NESTED EXCEPTION ** 
  4.  
  5. java.net.SocketException
  6. MESSAGE: java.net.SocketException: Address already in use
  7.  
  8. STACKTRACE:
  9.  
  10. java.net.SocketException: java.net.SocketException: Address already in use
  11.  
This happens at about 1000 entries into the compilation, while going through the same action that has successfully gone through before. If I change the order around of what I am requesting, it still fails. If I reduce the number of entries, it works fine.

This is largest file I have tried creating, but would this make sense for why it would not work?

Any tips on this error message would be appreciated. Thanks, Wes
Oct 9 '07 #1
Share this Question
Share on Google+
1 Reply


Motoma
Expert 2.5K+
P: 3,235
I have moved this question to the Java forum, where I am sure you will get more help.

Is that a full stack trace? That's the smallest stack trace I have ever seen.

It might also help if you posted a small section of the relevant code, or were able to produce a simple test case.
Oct 10 '07 #2

Post your reply

Sign in to post your reply or Sign up for a free account.