469,927 Members | 1,922 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,927 developers. It's quick & easy.

Problem with public parameters in WSRP portlet

Hi

I have to make few portals for all departments in my company. One portal
for one department. Each portal has to present information about
department employees.
I have written WSRP portlet, which gets data from LDAP,and shows them on
portal page. I'd like to reuse this portlet in all my portals.
I think that my portlet should be parametrizable. Each instance should
get unique unit code, which can be set (on default, constans, string
value) during laying it on portal page.
Unfortunatelly, I don't know how to make portlet to accept a public
parameter.

I found the document, which describes this problem for Oracle Java
Portlets
http://portalstudio.oracle.com/pls/o...RS.EVENTS.HTML
(in chapter PUBLIC PORTLET PARAMETER).

I'd like to do the same thing, but with WSRP portlet.

I suppose, that information about portlet public parameters, should be
put somewhere in portlet.xml descriptor file - but so far I havent't
found directions how to do it.

My portlet container is OC4J, and my portlet is registered in Oracle
Portal as a web provider.

Do you have any suggestions?

Best regards
mario
Oct 13 '06 #1
0 2462

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by allerhed | last post: by
reply views Thread by Ara Kassabian | last post: by
reply views Thread by Bob | last post: by
5 posts views Thread by Jason Huang | last post: by
2 posts views Thread by Constantine | last post: by
3 posts views Thread by Constantine | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.