By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,321 Members | 1,875 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,321 IT Pros & Developers. It's quick & easy.

Cannot attach to java applet

P: n/a
I am running an applet in Internet Explorer using <Object> tag and
trying to attach to it using Netbeans IDE. However Netbeans is not able
to attach to the applet. However I can use Netbeans to attach to
Weblogic server.

a) Have read various documents on various websites including
http://java.sun.com/products/plugin/...debugging.html
b) My classes are compiled with -g option. (Attaching to VM fails, so I
dont think that's an issue at this stage)

I will appreciate any help or comments.
Thanks
Gen
---------
Here are the settings and parameters:

Java plugin version = 1.3.1_02
Internet Explorer version = 6.0.xxx
(have tried various versions for both)
1)
Java runtime parameters in Java plugin control panel.
-Djava.compiler=NONE -Xnoagent -Xdebug
-Xrunjdwp:transport=dt_shmem,address=2502,server=y, suspend=n

2) <OBJECT> tag:
OBJECT name="ABC" classid="clsid:CAFEEFAC-0013-0001-0002-ABCDEFFEDCBB"
width="10" height="10" align="baseline"

codebase="http://<%=request.getServerName()%>:<%=request.getServerP ort()%>/downloads/jre_plugin.cab#Version=1,3,1,02">

<PARAM NAME="code" VALUE="com.mypackage.myclass.class">
<PARAM NAME="type" VALUE="application/x-java-applet;version=1.3.1_02">
<PARAM NAME="scriptable" VALUE="true">
<PARAM NAME="mayscript" VALUE="true">
<PARAM NAME="codebase" VALUE="/mydir/mycodebase">
<PARAM NAME="cache_option" VALUE="Plugin">
<PARAM NAME="cache_archive" VALUE="MyArchive.jar">
</object>

3) I have tried to attach using both shared memory attach and socket
attach (dt_shmem and dt_socket).

Jul 17 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.