By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
428,978 Members | 1,492 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 428,978 IT Pros & Developers. It's quick & easy.

Change encoding of Java Vm to ISO-8859-1

P: n/a
Ann
Hi,
Is there any way to Change encoding of Java Vm to ISO-8859-1?

i am using Java vm along with an application called opencms.
I get the following error message..

Error: the encoding of your Java VM is different from
the OpenCms encoding!

Java VM file encoding: UTF-8
OpenCms encoding: ISO-8859-1

To continue the setup process:

* Change the encoding of your Java VM. To do that
you must modify the file.encoding setting. Using
Apache Tomcat, a different encoding can be set in the
environment variable CATALINA_OPTS by the -D parameter
e.g.:
CATALINA_OPTS=-Dfile.encoding=ISO-8859-1

* If you want to use an encoding different from
ISO-8859-1, you must also adjust the
defaultContentEncoding setting in
WEB-INF/config/opencms.properties.

Unless you have specific encoding requirements, you
should use the default ISO-8859-1 setting. Please
refer to the Sun documentation for a list of supported
encodings for your OS.
Can some one please help me out?
Thanks,
Ann
Jul 17 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Ann
Figured it out

Add the following entry in /root/.bash_profile/ or etc/profile

CATALINA_OPTS=-Dfile.encoding=ISO-8859-1

ns****@yahoo.com (Ann) wrote in message news:<cc**************************@posting.google. com>...
Hi,
Is there any way to Change encoding of Java Vm to ISO-8859-1?

i am using Java vm along with an application called opencms.
I get the following error message..

Error: the encoding of your Java VM is different from
the OpenCms encoding!

Java VM file encoding: UTF-8
OpenCms encoding: ISO-8859-1

To continue the setup process:

* Change the encoding of your Java VM. To do that
you must modify the file.encoding setting. Using
Apache Tomcat, a different encoding can be set in the
environment variable CATALINA_OPTS by the -D parameter
e.g.:
CATALINA_OPTS=-Dfile.encoding=ISO-8859-1

* If you want to use an encoding different from
ISO-8859-1, you must also adjust the
defaultContentEncoding setting in
WEB-INF/config/opencms.properties.

Unless you have specific encoding requirements, you
should use the default ISO-8859-1 setting. Please
refer to the Sun documentation for a list of supported
encodings for your OS.
Can some one please help me out?
Thanks,
Ann

Jul 17 '05 #2

P: n/a
I just had the same problem. Here's what I did to fix it:

OS: WinXP Pro

1. Right-click on the Tomcat icon in the system tray and select
'Properties'

2. Select the Java VM tab.

3. Add -Dfile.encoding=ISO-8859-1 to the Java Options box on a
separate line after the other stuff.

You may need to restart Tomcat after making this change. This fixed my
problem right away. I hope it helps.

Andrew
ns****@yahoo.com (Ann) wrote in message news:<cc**************************@posting.google. com>...
Hi,
Is there any way to Change encoding of Java Vm to ISO-8859-1?

i am using Java vm along with an application called opencms.
I get the following error message..

Error: the encoding of your Java VM is different from
the OpenCms encoding!

Java VM file encoding: UTF-8
OpenCms encoding: ISO-8859-1

To continue the setup process:

* Change the encoding of your Java VM. To do that
you must modify the file.encoding setting. Using
Apache Tomcat, a different encoding can be set in the
environment variable CATALINA_OPTS by the -D parameter
e.g.:
CATALINA_OPTS=-Dfile.encoding=ISO-8859-1

* If you want to use an encoding different from
ISO-8859-1, you must also adjust the
defaultContentEncoding setting in
WEB-INF/config/opencms.properties.

Unless you have specific encoding requirements, you
should use the default ISO-8859-1 setting. Please
refer to the Sun documentation for a list of supported
encodings for your OS.
Can some one please help me out?
Thanks,
Ann

Jul 17 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.